LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-13-2003, 11:22 AM   #1
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Rep: Reputation: 30
Mplayer video problems


I just installed the last version of Mplayer, but when i try to play a file i can't see anything.
This is what it writes to me


[Harp00] mplayer sigla_chobin.mpg
MPlayer 1.0pre1-3.2.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/franco/.mplayer/config
Reading /home/franco/.mplayer/codecs.conf: Can't open '/home/franco/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/franco/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
Can't open input config file /home/franco/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config

Playing sigla_chobin.mpg
MPEG-PS file format detected.
VIDEO: MPEG1 352x240 (aspect 12) 30,000 fps 1089,6 kbps (136,2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 14000->176400 (112,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Can't open /dev/fb0: No such device
[fbdev2] Can't open /dev/fb0: No such device
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
VDec: using Mpeg PES as output csp (no 0)
Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
VO: [null] 352x240 => 352x264 Mpeg PES
Selected video codec: [mpegpes] vfm:mpegpes (Mpeg PES output (.mpg or Dxr3/DVB card))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
A: 0,0 V: 0,0 A-V: 0,000 ct: 0,000 48/ 48 0% 0% 0,0% 0 0 0%

Exiting... (End of file)
 
Old 09-13-2003, 11:34 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Code:
Can't open /dev/fb0: No such device
[fbdev2] Can't open /dev/fb0: No such device
That is most likely your problem. Either maybe you don't have the XFree86 development packages installed or you don't have framebuffer support, etc.
 
Old 09-13-2003, 11:47 AM   #3
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 51
are you trying to play in X or in the console? if in console then you need to sort out a framebuffer for it to use as the error message suggests if in X try running it like this

mplayer movie.mpg -vo xv
 
Old 09-13-2003, 12:02 PM   #4
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
So, what should i do?
Have i to download some packages?
I tried only in console mode, also because if i try to click over a mpeg file in X it say that i have no installed any appropriate program for .mpeg files.
And i do not understand why if i have just installed one.
Probably the problem it's only i am a new newbie.
 
Old 09-13-2003, 12:09 PM   #5
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 51
i wouldnt try to play it in a virtual terminal because it will require properly setting up a framebuffer(not an easy thing for a newbie), so go with X. now while your in X open up a terminal and type 'mplayer movie.mpg -vo xv' and see what happens
 
Old 09-13-2003, 12:20 PM   #6
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
I would recommend just getting the Xfree86 development package as trickykid said. If you dont have it on CD then yeah you will have to download it as an rpm. No big deal. It will be called Xfree86 devel though as opposed to development. I had the same problem too and installing that rpm did the trick for me! Good luck.
 
Old 09-15-2003, 10:09 AM   #7
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
I installed Xfree86 developing packages but it doesn't works!
Here is what it writes :

[franco@localhost franco]$ mplayer /mnt/cdrom/chobin/sigla_chobin.mpg
MPlayer 1.0pre1-3.2.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/franco/.mplayer/config
Reading /home/franco/.mplayer/codecs.conf: Can't open '/home/franco/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/franco/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
Can't open input config file /home/franco/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config

Playing /mnt/cdrom/chobin/sigla_chobin.mpg
MPEG-PS file format detected.
VIDEO: MPEG1 352x240 (aspect 12) 30,000 fps 1089,6 kbps (136,2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 14000->176400 (112,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Can't open /dev/fb0: No such device
[fbdev2] Can't open /dev/fb0: No such device
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
VDec: using Mpeg PES as output csp (no 0)
Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
VO: [null] 352x240 => 352x264 Mpeg PES
Selected video codec: [mpegpes] vfm:mpegpes (Mpeg PES output (.mpg or Dxr3/DVB card))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
A: 0,0 V: 0,0 A-V: 0,000 ct: 0,000 81/ 81 0% 0% 0,0% 0 0 0%

Exiting... (End of file)

The problem now is i don't know what a framebuffer is.

I tried also with: mplayer /mnt/cdrom//chobin/sigla_chobin.mpg -vo xv
but here is what it writes back:

MPlayer 1.0pre1-3.2.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/franco/.mplayer/config
Reading /home/franco/.mplayer/codecs.conf: Can't open '/home/franco/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/franco/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
Can't open input config file /home/franco/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config

Playing /mnt/cdrom/chobin/sigla_chobin.mpg
MPEG-PS file format detected.
VIDEO: MPEG1 352x240 (aspect 12) 30,000 fps 1089,6 kbps (136,2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 14000->176400 (112,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Error opening/initializing the selected video_out (-vo) device.


Exiting... (End of file)


Please if you can, help me.
Thank you!!
 
Old 09-15-2003, 10:24 AM   #8
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try -vo x11
or compile it with gui (./configure --enable-gui) and use gmplayer(need to download skins)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
video problems (mplayer) keith2045 Fedora 2 10-27-2005 07:18 PM
problems playing video files with mplayer mabuse Linux - Software 2 09-23-2004 06:43 AM
Mplayer Problems (Sound, but no Video) shaolin77 Linux - Software 5 08-06-2004 05:27 PM
No video on mplayer lramos85 Linux - Newbie 13 11-06-2003 10:40 PM
video problems with mplayer Pathian Linux - Software 2 09-14-2003 12:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration