LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 09-13-2005, 07:19 PM   #1
mcah5
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
mplayer .mkv sound problem


I'm having trouble getting sound to work when playing .mkv files with mplayer

Typing in:
# mplayer movie.mkv

I get:
Trying to force audio codec driver family libmad...
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
mplayer: relocation error: mplayer: undefined symbol: faacDecOpen

So I try using another audio codec

Typing in:
# mplayer -ac mad movie.mkv

I get:
Forced audio codec: mad
Cannot find codec for audio format 0x4134504D.
Read DOCS/HTML/en/codecs.html!

The video plays, but there is no sound. I was wondering if there was a specific audio codec I should have used.
 
Old 09-13-2005, 07:28 PM   #2
mcah5
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Oh, and I tried downloading libfaad2_0 through urpmi. It says everything has already been installed.
 
Old 09-22-2006, 10:42 AM   #3
grammarsoft
LQ Newbie
 
Registered: Sep 2004
Location: somewhere in NJ
Distribution: slackware, debian, and fedora core 2
Posts: 1

Rep: Reputation: 0
Solution - MKV format no sound

You will need to download and compile the following libraries from Matroska official site.

libeblml
libmatroska

Once compiled you can copy the libs to the default codecs directory e.g. /usr/lib/codecs or /usr/local/lib/codecs
 
  


Reply

Tags
mkv, mplayer, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MKV Xine Problem Blipside Linux - General 0 09-20-2005 06:32 PM
playing mkv files on mplayer joq Linux - Software 3 12-07-2004 07:24 AM
MPlayer Sound Problem webterractive Linux - Software 2 06-23-2004 02:38 AM
sound sync problem in mplayer kmeehl Slackware 1 03-14-2004 11:55 PM
help me mplayer sound problem ! duker_d_cooker Linux - General 3 03-13-2004 02:42 AM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration