LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-23-2008, 04:37 AM   #1
KrzysieQ
LQ Newbie
 
Registered: Aug 2007
Posts: 12

Rep: Reputation: 0
mplayer doesn't play stearms


Distro: Debian (SID)
Mplayer: MPlayer dev-SVN-r26940

When I try play any video stream I received, for example:

Code:
kszyh@debian:~$ mplayer mms://xxx.com
MPlayer dev-SVN-r26940 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) XP 2000+ (Family: 6, Model: 8, Stepping: 0)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing mms://xxx.com.
STREAM_ASF, URL: mms://xxx.com
Resolving xxx.com for AF_INET6...
Couldn't resolve name for AF_INET6: xxx.com
Resolving xxx.com for AF_INET...
Connecting to server xxx.com[yyy.yyy.yyy.yyy]: 1755...
Connected
file object, packet length = 2888 (2888)
unknown object
unknown object
unknown object
unknown object
unknown object
unknown object
stream object, stream ID: 32771
stream object, stream ID: 32772
stream object, stream ID: 32773
stream object, stream ID: 32774
unknown object
unknown object
unknown object
unknown object
data object
mmst packet_length = 2888
Cache size set to 64 KBytes
Cache fill: 12.31% (8069 bytes)
libavformat file format detected.
[asf @ 0x87773b4]Could not find codec parameters (Video: wmv3, 384x288, 300 kb/s)
[asf @ 0x87773b4]Could not find codec parameters (Video: wmv3, 384x288, 148 kb/s)
[asf @ 0x87773b4]Could not find codec parameters (Video: wmv3, 384x288, 60 kb/s)
[lavf] Audio stream found, -aid 0
[lavf] Audio stream found, -aid 1
[lavf] Audio stream found, -aid 2
[lavf] Video stream found, -vid 3
[lavf] Video stream found, -vid 4
[lavf] Video stream found, -vid 5
VIDEO:  [WMV3]  384x288  24bpp  1000.000 fps  300.0 kbps (36.6 kbyte/s)
Clip info:
[...]
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
s3fb: can't open /dev/fb0: No such file or directory
[VO_XV] Using Xv Adaptor #0 (NV17 Video Texture)
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:331776  align:1
StreamCount r=0x0  1  1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 384 x 288 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 384x288 => 384x288 Planar YV12
Selected video codec: [wmv9dmo] vfm: dmo (Windows Media Video 9 DMO)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 64.0 kbit/4.17% (ratio: 8004->192000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
A:   0.0 V:   0.0 A-V:  0.000 ct:  0.000   0/  0 ??% ??% ??,?% 0 0 0%

Exiting... (End of file)
But when I download that stream using VLC to disk and try play with mplayer - it is ok. So... where is problem ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Play Mplayer Startup bogoda Linux - Software 9 01-31-2006 08:38 PM
mplayer doesn't play thelonius Linux - Software 1 08-19-2005 01:30 PM
mplayer won't play in english blackdragonblood Linux - Software 2 06-24-2005 09:32 PM
mplayer won't play fullscreen Ren Linux - Software 4 10-28-2004 05:36 PM
can't play anything on mplayer!! blaze_wk Linux - Software 1 01-17-2004 04:49 PM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration