LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-08-2008, 07:08 AM   #1
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
MPG playback becomes choppy during scenes with lots of movement


Hey guys,

Using Ubuntu 8.10 (Intrepid Ibex) 32 bit

I noticed that when playing an MPG file or DVD video in Xine, during scenes with lots of movement and action, the playback starts to produce horizontal lines and then starts to skip frames or become choppy.

Some info about my setup is:

* Video Card is ATI 128Mn Radeon Mobility HD 3400 series
* 3gb RAM
* Xine video driver setting is set to xshm
* fglrx restricted driver package is installed
* Compiz is installed and active

I wondered if anybody seen this kind of problem and had any suggestions to where to start tweaking?

Regards,
Greenie
 
Old 12-08-2008, 07:57 AM   #2
armandh
LQ Newbie
 
Registered: Nov 2008
Location: st louis mo usa
Distribution: ubuntu/xp
Posts: 6

Rep: Reputation: 0
my media box is 8.10 powered

it is a 933 P-III 512 meg ram 128 meg "gamer" video card [nvidia chip] using VLC to play the movies. with the medibuntu add in. runs fine palys DVDs and AVI files no pixalation.

try swapping DVD drive then if that is not it try a different video card. test memory. pull other cards shut off periferals [you would be supprised what a bad mouse cord will do.]

Last edited by armandh; 12-08-2008 at 08:01 AM.
 
Old 12-09-2008, 07:34 AM   #3
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by armandh View Post
it is a 933 P-III 512 meg ram 128 meg "gamer" video card [nvidia chip] using VLC to play the movies. with the medibuntu add in. runs fine palys DVDs and AVI files no pixalation.
Are you running compiz? Maybe I might try VLC.

Quote:
Originally Posted by armandh View Post
try swapping DVD drive then if that is not it try a different video card. test memory. pull other cards shut off periferals [you would be supprised what a bad mouse cord will do.]
I aint doing any of that, its a brand new notebook computer!
 
Old 12-09-2008, 11:06 AM   #4
dv502
Member
 
Registered: Sep 2006
Location: USA - NYC
Distribution: Whatever icon you see!
Posts: 642

Rep: Reputation: 57
Check if DMA is enabled for your dvd drive. Most distros do this by default if your drives supports it.

To verify:

sudo hdparm -d /dev/dvd # Replace dvd with your actual dvd device ID.

using_dma = 0 (off)

This means DMA is off.

To enable:

sudo hdparm -d 1 /dev/dvd


If you still get jumps on fast scenes, try mplayer to play your dvds and videos. You can add the framedrop option to the command line. Examples

mplayer dvd://1 -framedrop
mplayer videofile.avi -framedrop

If this works, you can load the framedrop option automatically.

There is a hidden directory called .mplayer in your home folder. Edit or create a file called config and add this

framedrop=yes

You can add additional flages to this file. See the man page.

You can also use gmplayer and kmplayer. These are GUI front ends for mplayer.

I am puzzled, based on your your hardware, dvd and video files playback should run smoothly, unless your dvd has corrupted sectors or has scuff marks on certain areas on the disk.

Last edited by dv502; 12-09-2008 at 11:13 AM.
 
Old 12-09-2008, 11:44 AM   #5
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
Check:

http://linux-ata.org/faq.html
http://www.storagereview.com/guide20...modesUDMA.html

Couple of good resources on dma on drives someone gave me on another forum. I happen to have one of the odd chipsets and drives that do not work well with the new method and have to force dma on my drives.

Last edited by Hern_28; 12-09-2008 at 11:46 AM.
 
Old 12-09-2008, 05:37 PM   #6
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
Thanks guys, but how would the dma on dvd drive also cause an MPG file that is stored on the SATA hard disk to play choppy and cause horizontal lines through the picture when there is a lot of action and movement in the video?

I was thinking the problem was more likely to do with the video drivers or settings somewhere.
 
Old 12-09-2008, 09:27 PM   #7
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by dv502 View Post
Check if DMA is enabled for your dvd drive. Most distros do this by default if your drives supports it.

To verify:

sudo hdparm -d /dev/dvd # Replace dvd with your actual dvd device ID.

using_dma = 0 (off)

This means DMA is off.

To enable:

sudo hdparm -d 1 /dev/dvd

When I type: sudo hdparm -d /dev/dvd

I get:
Code:
HDIO_GET_DMA failed: Inappropriate ioctl for device
What does that mean? How do I fix?

Is it because my HDD is a SATA type?

Last edited by greengrocer; 12-09-2008 at 09:31 PM.
 
Old 12-09-2008, 09:48 PM   #8
lakedude
Member
 
Registered: Jun 2005
Distribution: Puppy, Sabayon
Posts: 141

Rep: Reputation: 16
After playing around with all the cool Compiz features I turned the Compiz 3d desktop off because it interfered with video playback.

Did something similar on a M$ Vista box, turned off the 3-d "Aero" desktop because it interfered with 3d games and video playback.


YMMV
 
Old 12-09-2008, 10:26 PM   #9
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
But I want compositing Desktop with a working multimedia solution.
 
Old 12-09-2008, 10:30 PM   #10
lakedude
Member
 
Registered: Jun 2005
Distribution: Puppy, Sabayon
Posts: 141

Rep: Reputation: 16
It won't kill you to turn of Compiz for 5 minutes to see if this is even part of the problem.

Compiz may have nothing to to with your playback issues.

The easiest way to know for sure is to try it out.

Last edited by lakedude; 12-10-2008 at 01:42 AM.
 
Old 12-10-2008, 12:12 AM   #11
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
I had already tried disabling compiz, and playback is a little better without Compiz running, especially for gstreamer-totem.

In fact, playback would probably be better if I did not use the ATI fglrx driver. However, I want to use the fglrx driver and Compiz, and all I am really wondering is if any body knows any little tweaks for xine or the xorg.conf file options that can improve things.

Last edited by greengrocer; 12-10-2008 at 01:08 AM.
 
Old 12-10-2008, 01:59 AM   #12
lakedude
Member
 
Registered: Jun 2005
Distribution: Puppy, Sabayon
Posts: 141

Rep: Reputation: 16
Quote:
Originally Posted by greengrocer View Post
... horizontal lines through the picture when there is a lot of action and movement in the video?
Sounds like you need to enable "deinterlacing" or change the deinterlacing settings....

Can't really advise on Xine because I don't currently use it anymore.

I like "The KMPlayer", SMPlayer and VLC. Xine would be next on the list but the others typically handle my video needs.

I used Xine back in my Knoppix days so I've got a general idea what you are talking about.

I'll edit in instructions on how to enable deinterlacing in Xine later.

Last edited by lakedude; 12-10-2008 at 02:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse movement recorder/Playback? Sintu Linux - Software 1 06-01-2007 06:47 AM
RealPlayer playback very choppy! 144419855310001 Fedora 1 10-08-2006 10:13 PM
choppy DVD playback marks_linux Linux - Hardware 6 05-03-2005 08:51 AM
Choppy mouse movement with xorg 6.7.0-11 tommyr1216 Linux - Hardware 5 01-23-2005 01:48 AM
Optical mouse and choppy movement sienarot Linux - Hardware 7 07-06-2003 07:11 PM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration