LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2004, 02:03 PM   #1
mrvikki
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Rep: Reputation: 15
mozilla won't start in gnome except for root...


Hi I'm running slackware 10.0, I just installed it, and am having this weird problem.
In X-windows (Gnome desktop) under my user account, I click on mozilla under
internet and nothing happens. In a terminal window if I type mozilla
It says:

bash-2.05b$ mozilla
*** Registering -webcal handler.
*** Registering text/calendar handler.
*** Registering webcal protocol handler.

and then it hangs. I've waited for 30 minutes and nothing has happened...

HOWEVER, If I su to root, and type mozilla...it doesn't say anything but mozilla
pops up on the gnome desktop in 2 seconds.
Anyone know what the problem is?

Thanks for your help!
Vik
 
Old 08-31-2004, 02:26 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Sounds like some sort of permission problem.
Check the permissions on Mozilla, it's libraries,
the users home and files therein, and in /tmp


Cheers,
Tink
 
Old 08-31-2004, 09:28 PM   #3
mrvikki
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Original Poster
Rep: Reputation: 15
ahhh well, I had no idea even where to begin to look for the files and permissions...however, visiting ftp.slackware.com and downloading the mozilla 1.7.2 patch and installing it using upgradepkg
seemed to fix whatever the problem was...it also fixed the failure of galeon to load when I downloaded the galeon fix.

Anyways, thanks for your help!
now I know where to look absolutely first before whining in a public forum =)

Vik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.1: KDE or GNOME start only as root blish_blash Linux - General 4 09-18-2004 09:35 AM
CUPS Cannot print in mozilla non-root (can as root)? mismacku Linux - Software 0 08-26-2004 03:07 AM
gnome 2.6 doesn't start as root hypermegachi Slackware 6 07-12-2004 07:08 PM
Problem: Only root can start Mozilla... Baix Slackware 11 07-02-2004 12:25 AM
Mozilla will only start as root. Crickit Linux - Software 8 01-11-2004 09:41 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration