LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2004, 10:19 PM   #1
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Rep: Reputation: 15
Mouse problems... How do I disable hotplug?


Last time I installed Slackware, my mouse didn't work at start, so I searched online and found out that if you edit your XF86Config file, by either browsing to it or using the xf86config wizard, that you can get your mouse working in there. I have the same mouse this time as I did last time, a Logitech Mx700 (a wireless optical mouse) and it is connected via USB. Last time, I got my mouse working no problem, I guess I chose the correct options the first time through, this time I have ran through xf86config so many times and I have been tryin all day to get my mouse to work. I've done several searches here and on google and everything I've found isn't working for me. Also, unfortunately I decided to delete my old Slackware installation (when I was installing the new one on /dev/hde). I know my mouse is working, batteries are full and it works on Windows XP. I just wonder what I am doing wrong this time around...

Last time I don't think I had Hotplug enabled and this time I remember that I enabled it during the installation. Maybe that could be the problem...?

How do I disable hotplug???
 
Old 06-02-2004, 10:21 PM   #2
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Original Poster
Rep: Reputation: 15
xf86config

And the following is my XF86Config for the mouse section:

Code:
Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"
    Option "Protocol"    "Auto"
    Option "Device"      "/dev/mouse"

# Mouse-speed setting for PS/2 mouse.

#    Option "Resolution"	"256"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"	"Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"	"9600"
#    Option "SampleRate"	"150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection
But my main question is about hotplug, how to disable it..?
 
Old 06-06-2004, 08:54 PM   #3
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Original Poster
Rep: Reputation: 15
Nevermind, I just had to change it so it read:

Code:
# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "Auto"
    Option "Device"      "/dev/input/mice"
"/dev/input/mice" is supposed to be good for USB mice. Right after I did that my mouse worked fine! Thanks to Vectordrake from another thread for this solution!

Erik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't hotplug usb mouse bobwall Linux - Hardware 1 12-23-2004 02:54 PM
Slackware 10: How do you disable hotplug at startup? jtp51 Slackware 6 10-29-2004 05:14 PM
Disable hotplug or USB device in Fedora Core 2 crashdum Fedora 1 09-03-2004 09:01 AM
disable usb hotplug service ? YBA^[x] VectorLinux 1 08-23-2004 01:18 PM
RH9 and Hotplug USB mouse xtrips Linux - Hardware 1 04-12-2003 06:20 PM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration