LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2005, 12:24 AM   #1
Psyche73
LQ Newbie
 
Registered: Feb 2005
Location: uk
Distribution: fedora core 3
Posts: 17

Rep: Reputation: 0
Mouse does'nt register-mandrake


Installed mandrake 10.1 just there


got through to the GUI but my mouse does not register.

Tried booting from install cd1 and configured mouse with standard ps/2 option,clicked on the diagram picture then booted again.

Cursor does not move,- mouse does'nt register

What's up?

Thanks very much indeed,as usual, for all your stupendous much appreciated excellent help.(sorted my last problem out here- cheers!!!)

Psyche.
 
Old 02-04-2005, 01:07 AM   #2
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
It happend to me in Slackware when I upgraded the kernel to 2.6.10 and sometimes in Mandrake. Hit CTL+ALT+F1...F6 to go to the terminal. Login as root and type "modprobe psmouse". Stay logged in as root and hit CTL+ALT+F7. If the mouse works, go back to what ever virtual terminal you logged in for root. Then logout of root.
 
Old 02-04-2005, 08:02 PM   #3
Psyche73
LQ Newbie
 
Registered: Feb 2005
Location: uk
Distribution: fedora core 3
Posts: 17

Original Poster
Rep: Reputation: 0
Mouse does'nt register

Quote:
Originally posted by Electro
It happend to me in Slackware when I upgraded the kernel to 2.6.10 and sometimes in Mandrake. Hit CTL+ALT+F1...F6 to go to the terminal. Login as root and type "modprobe psmouse". Stay logged in as root and hit CTL+ALT+F7. If the mouse works, go back to what ever virtual terminal you logged in for root. Then logout of root.

Mandrake 10.1 -installed on P3 , 550 mhz, dual boot ,with windows 2000 also.

I tried the instructions quoted here as posted by Electro to get my mouse working.

I got an error message logged however, I believe, relating to the device:-

[EE] xf86OpenSerial : Cannot open device /dev/mouse
No such file or directory

I did get through to the KDE gui but i might want to add these other feedback messages too if it helps diagnosis of the problem-

Build OS - Linux 2.6.8.1.2mdkenterprise i686
Current - Linux local host 2.6.8.1-12mdk #1
Build date 23 sept 2004
blah blah blah
Using vt 7
[EE] Failed to load module "usr/x11r6/lib/modules/extensions/libglxa"
(once only module, 135962511)
[WW] ATI (o) : Failed to set up write-combining range (oxfd000000, ox000000)
[WW] ATI (o) : Failed to set up write-combining range (oxfd000000, ox000000)
[EE] xf68OpenSerial : Cannot open device /dev/mouse
No such file or directory exists
EE] xf68OpenSerial : Cannot open device /dev/mouse
No such file or directory exists
[EE] xf68OpenSerial : Cannot open device /dev/mouse
No such file or directory exists

Everything went fine- just my mouse would'nt work once i got through to the gui.
Have tried changing the system configuration through the boot install disk cd1- Mandrake 10.1 (3cd edition) Also my mouse clicked fine when i tested it during set-up config with universal ps/2- i tried just ps/2 standard and changing graphics card cos i think the install identified my graphics/display card wrongly-( as ati utah instead of ati 3d rage pro). but still could'nt sort it.

Any suggestions

Much appreciated, in advance.

Psyche
---------

(Thanks for the help guys!)
 
Old 02-05-2005, 02:36 PM   #4
poppopwill
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
I'm having exactly the same problem with 10.1. I really would like to know how to solve this. It's absolutely ridiculous. I'm no computer noob, I've used and worked on them a very long time -- mostly Windoze and unix (not Linux). I did some research before picking a distro and Mandrake was "suppose" to be fairly simple to insatll and fairly good on hardware detection---NOT. Couldn't detect my video, couldn't detect my printer, couldn't detect etc. I fixed most of that by manual configuration myself during the install. This mouse thing is B.S. Configures and tests good during install, craps the bed at boot.

I tried a Live CD based on Mandrake before I went for a full install and it worked fine. If I don't get this going very soon, I'll try a different distro or can Linux altogether ... again. I tried it three years ago and gave up because of this stuff. There's another thread somewhere around here-- Linux Not Ready for Prime Time. That would appear to sum it up.

I hate Windoze but at least Windoze can detect a mouse and make it available after boot.

 
Old 02-05-2005, 10:14 PM   #5
Psyche73
LQ Newbie
 
Registered: Feb 2005
Location: uk
Distribution: fedora core 3
Posts: 17

Original Poster
Rep: Reputation: 0
Mouse does'nt register-mandrake

I hear what you're saying,loud & clear.

This is my first install. And i did read while trying to research this issue that linux is more stable and reliable than windows, perhaps they mean most linux distros. Saying that, my mandrake crashed after i repeatedly tested diff. video config's..But i was able to go back and repair with boot cd 1.

i hear all the praising of the virtues of linux about stability,robustness,relibality etc etc in the manuals and guide books but i would'nt expect the same things to occur with windows. Saying that there's abviously less scope for changing config., options,playing about with windows and it's not portable across different hardware like macs for e.g so the hardware configuration has to be built in., BUt my machine is a pretty common ,once v. popular, pentium 3 with the usual x86 architecture the linux,so i read anyway, is designed for,. so it really should work in principle given i don't have an obscure machine or exotic hardware that's not been tested on or is diifcult to configure.And I use ps/2 port for the microsoft ps/2 - 2 button mouse- that i've got btw.

It is annoying as fuck. I chose mandrake cos it sounded like not too diffult install for a linux newbie like myself-easy partitioning etc. Though, the claim it was'nt the most stable distro, cos it was regulalry updated, put me off a little but it is really just a test-bed for linux for me.It sounded like it had a stylish gui anyway.

I am wanting to set up a modest server you see ,probably on another machine and i read fedora is updated less frequently and so more stable and seccure than mandrake and therefore suited to that purpose. Saying that ,one really needs to try distros out before you can develop a preferred taste for them,aside fromn the alleged functionalities and best purpose for them.

If i can't get mandrake to work , i may either set up fedora or redhat enterprise ,depending on which is good for a small server but might want to be used as a desktop, even if just occassionally to dabble about when i'm bored of using wondows ,which i am ,on another machine on the network.. Which rh distro of the two i've mentioned i should choose, i'm tempted to ask here.

It is fucking annoying but any 1st install is a learning curve and should help you install other distro's and learn about linux period.

I am not impressed either though and will install another distro once i've wasted enough time trying to resolve this teether.

Let me know if you manage to sort this same problem out, please.#

It is all part of the learning curve and the wonderful world of linux, i say sarcastically

Good luck!
 
Old 02-05-2005, 11:10 PM   #6
amosf
Senior Member
 
Registered: Jun 2004
Location: Australia
Distribution: Mandriva/Slack - KDE
Posts: 1,672

Rep: Reputation: 46
You guys aren't going to get much help if you just sit there and b!tch...

say, how about we look at what /dev/mouse is pointing to...

BTW I've installed dozens of copies of MDK and haven't seen it miss the mouse. It's not a common thing...
 
Old 02-06-2005, 12:52 AM   #7
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
In /etc/X11/xorg.conf file you should have /dev/psaux instead of /dev/mouse for device under the InputDevice section for the mouse. In simpler terms find:
Option "Device" "/dev/mouse"

and comment it out by placing # in the beginning of it. Then add
Option "Device" "/dev/psaux"
underneath
Option "Device" "/dev/mouse"

In Mandrake 9, it has /dev/psaux, but since 2.6.x kernel came out the PS/2 mouse seem to not be popular by kernel developers. When I used Mandrake 10, the mouse worked with out any problems even though I was using PS/2 mouse with a KVM switch. I trashed Mandrake 10 and installed Slackware 10 because Mandrake 10 had a very screwy setup to compile programs that I do not feel like spending weeks to strighten it. If you want to try Linux, install Mandrake 9.2 or Redhat 9. Both of them use a very stable setup, but I prefer Mandrake because it gives more freedom for filesystems during installation and fool proof partition setup.

Quote:
It sounded like it had a stylish gui anyway.
The GUI is all distributions is X Window Server from either XFree86 or Xorg. The X Window Server then branches into Desktop Managers and Window Managers. You are talking about KDE which is combination of a Desktop Manager and Window Manager. KDE is Windows users best friend when switching to Linux because it can look and act like Windows in many ways. GNOME is the next Desktop Manager and Window Manager but it has less styles and it takes less memory than KDE. Both KDE and GNOME are memory hoggers. A Window Manager like XFCE is like Mac OS X GUI, but takes up very little memory. XFCE is great if you want an easy GUI setup without taking up a lot memory. Then there is blackbox and fluxbox which are lighter than XFCE but they have a learning curve.

BTW, it may help us if you post your /etc/X11/xorg.conf or /etc/X11/XF86Config file and /var/log/XF86.0.log or /var/log/xorg.0.log.
 
Old 02-06-2005, 03:34 AM   #8
Psyche73
LQ Newbie
 
Registered: Feb 2005
Location: uk
Distribution: fedora core 3
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Electro
In /etc/X11/xorg.conf file you should have /dev/psaux instead of /dev/mouse for device under the InputDevice section for the mouse. In simpler terms find:
Option "Device" "/dev/mouse"

and comment it out by placing # in the beginning of it. Then add
Option "Device" "/dev/psaux"
underneath
Option "Device" "/dev/mouse"

In Mandrake 9, it has /dev/psaux, but since 2.6.x kernel came out the PS/2 mouse seem to not be popular by kernel developers. When I used Mandrake 10, the mouse worked with out any problems even though I was using PS/2 mouse with a KVM switch. I trashed Mandrake 10 and installed Slackware 10 because Mandrake 10 had a very screwy setup to compile programs that I do not feel like spending weeks to strighten it. If you want to try Linux, install Mandrake 9.2 or Redhat 9. Both of them use a very stable setup, but I prefer Mandrake because it gives more freedom for filesystems during installation and fool proof partition setup.


The GUI is all distributions is X Window Server from either XFree86 or Xorg. The X Window Server then branches into Desktop Managers and Window Managers. You are talking about KDE which is combination of a Desktop Manager and Window Manager. KDE is Windows users best friend when switching to Linux because it can look and act like Windows in many ways. GNOME is the next Desktop Manager and Window Manager but it has less styles and it takes less memory than KDE. Both KDE and GNOME are memory hoggers. A Window Manager like XFCE is like Mac OS X GUI, but takes up very little memory. XFCE is great if you want an easy GUI setup without taking up a lot memory. Then there is blackbox and fluxbox which are lighter than XFCE but they have a learning curve.

BTW, it may help us if you post your /etc/X11/xorg.conf or /etc/X11/XF86Config file and /var/log/XF86.0.log or /var/log/xorg.0.log.
--------------------------------------------------------------

Following Error message displayed in KDE when i tried to write to the xorg.conf file-

'
The document could not be saved, as it was not possible to write to file:/etc/X11/xorg.conf.
Check that you have write access to this file or that enough disc space is available.'


So therefore my Q. is how do i get *access permissions* to alter/modify the file.?

When i googled this whole' no mouse detection' issue ' in 10.1 ' there was a liisting - mandrake 10.1 but one solution suggested there was to replace the
"/dev/mouse" with "/dev/input/mice" instead ., alittle different iguess from your suggestion.

I tried to do this but ran into access permissions not granted problem.

I can only get my mouse working if login as root .. F2,go to 'mousedrake' ,then i altered my config. seting in little mouse config. utility to ps/2 standard from universal-usb&ps/2.

Then Go to ........./F7 gui/KDE and the mouse worked ...
But if i rebooted up again the settings would not be saved and set-up/remembered at the next boot.(someone described it/like having to reboot twice)

So i opened up the 'xorg.conf' file through KDE with 'KWrite' program/editor but i had no access permission to change file. How to i gain aceess permission then to modify the file and save. Thiss should overwrite the old file rather than duplicate presumably.

Thanks for your superb effort,feedback,help and patience to a linux newbie like me.
I thik i tried to log in as root to do this maybe ??? ...mmm but perhaps i was'nt logged in as root or i need to do something else-use some utility i'm unaware of-perhaps- just a guess.

I'll try modifying the file once i have accesss permission with 'Kwrite' editor-
------------------------

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"

Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

---------------------------
Option "Device" "/dev/input/mice"

-ABOVE is the line i was proposing to add to the above inputdevice text section of the file

******So therefore my Q. is how do i get *access permissions* to alter/modify the file.?****


Thanks very much indeed, as usual

psyche73
----------
:
 
Old 02-06-2005, 05:47 PM   #9
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The /etc/X11/xorg.conf can only be access by root and it is useless and a security risk to let normal users have permission to write to. Hit CTL+ALT+F1..F6. Then do not go to the gui and login in as root. Type `vi /etc/X11/xorg.conf`. Press i to activate edit mode and find the lines that I told you to look for. After you are done editing, hit ESC key to get out of editing mode. Hit ZZ (SHIFT+z+z) to save and quite vi. Go back to virtual terminal 7 or hit CTL+ALT+F7. Hit CTL+ALT+BKSPC to reset X Window Server.

Gives us a print out of /sbin/lsmod before and after you setup the mouse. I think you still need to load up psmouse. The only way to automatically load up the module (driver) is edit /etc/rc.local and place /sbin/modprobe psmouse at the last line.

Only use vi or other console editing programs instead of GUI programs. GUI programs tends to screw up the file.
 
Old 02-06-2005, 10:48 PM   #10
Psyche73
LQ Newbie
 
Registered: Feb 2005
Location: uk
Distribution: fedora core 3
Posts: 17

Original Poster
Rep: Reputation: 0
This post/thread can be marked as resolved..

tried looking for an faq for this site but did'nt look hard enough i guess

Regarding the solution,Electro, i just ended up reinstalling mandrake 10.1 a pretty clean install (slight scratch on cd-3 so i'll reburn that disc again once i get hold of some more cd-r's)why i did'nt work 1st time i'm not quite sure- think it was maybe the initial install config.

So i enountered no problems with my mouse not registering on a fresh 2nd install.

I stubbornly followed my own instructions to try to resolve the prob. rather than yours and then i could not use my mouse at all even through the mousedrake utility, but at least i learnt more about the command line/linux in process.

. I managed to change the access permissions for file - '/etc/X11/xorg.conf ' through root-
'chown myself /etc/X11/xorg.conf '
'chmod 777 /etc/X11/xorg.conf'

and edited/altered the mouse entry in the file ,
BUT then could'nt use the mouse at all. through mandrake utility and so could'nt then change it back to what it was originally through kde gui.

I should have followed your instructions in hindsight, i guess.

But i have NO problem now, however after the second install of mandrake 10.1-3cd edition

So thanks very much for helping me out,Electro .
I'm wanting to set up a small server for on another machine same network so i probably try out another distro like red-hat with security and stability that will work well for a small server. Meanwhile learn more about linux/command line with mandrake on my windows 2k dual boot.

Psyche
______
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Eth0 does'nt exist???? matthewa Linux From Scratch 1 06-08-2005 03:54 PM
How to register new codecs with Totem? (mandrake 9.2) [k]ar| Linux - Software 3 02-22-2004 12:11 PM
Linux does'nt boots ksathya Linux - Software 6 09-18-2003 07:14 PM
Mouse - Sometimes work and sometimes does'nt danishmr Linux - Hardware 0 05-09-2002 05:44 AM
Mandrake 8.2 - can not register boxed set Haldir Linux - Newbie 2 05-07-2002 09:44 PM


All times are GMT -5. The time now is 05:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration