LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-24-2004, 02:14 PM   #1
LovelyJunna
LQ Newbie
 
Registered: Mar 2004
Location: Sunnyvale, California 94086
Distribution: debian
Posts: 6

Rep: Reputation: 0
mouse cursor doesn't move in X/Debian


Hi all,

The mouse was working fine in X. Then press Ctrl+Alt+F1 to get the text
console and do something there. When done, Ctrl+Alt+F7 gives me the X
root window back. But, in there, the mouse cursor doesn't respond to
the movement of the mouse anymore. It moves maybe one pixel length
at first after coming back from text console, but that's it. It sticks there
and absolutely no movement at all afterwards.
The keyboard is fine by the way.

How can I get the mouse back?

TIA
 
Old 03-24-2004, 04:23 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Do you have gpm running in the console? The two drivers may make conflicts. Try to turn gpm off.
 
Old 03-24-2004, 06:35 PM   #3
LovelyJunna
LQ Newbie
 
Registered: Mar 2004
Location: Sunnyvale, California 94086
Distribution: debian
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for replying.

No, gpm is not running.
I have never installed it myself.
"ps -aef | grep gpm" hits nothing.

It was worse before. The mouse didn't move at all right from the start.
Booting up, xdm comes up, the mouse cursor appears, right there
it didn't move. I could log in and had the full X window, but the mouse
didn't move in X neither. ;-<

Now, I recompiled the kernel for a totally different purpose
(to get smbfs compiled in). With this newly compiled kernel, somehow
(do you say automagically? I'm a newbie here, bare with me please)
the mouse started working. I was delighted, and disappointed when
I did the Ctrl-Alt-Fx thing and saw it stuck again.

Before and after this recompile, I didn't touch anything in XF86Config-4.

The kernel core is the same. I just added smbfs. It is 2.2.20 I believe.
 
Old 03-25-2004, 04:39 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Please tell us what do you have in 'Secion "Pointer"' of your /etc/X11/XF86Config-4
 
Old 03-26-2004, 12:25 PM   #5
LovelyJunna
LQ Newbie
 
Registered: Mar 2004
Location: Sunnyvale, California 94086
Distribution: debian
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for replying.

You mean the "InputDevice" section?

<pre>
Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "off"
Option "ZAxisMapping" "4 5"
EndSection
</pre>


Remember, it works when it works.
Even before the recompile, it wasn't all the time. Very rarely,
maybe 1 out of 10, I was able to move the mouse cursor.

Is it a configuration issue, or could it be something else?
 
Old 03-26-2004, 04:30 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
The generic driver should work with nearly everything. Do you have a special mouse? Is it possible it needs another driver (Microsoft ones do, for instance)?
 
Old 03-26-2004, 04:34 PM   #7
LovelyJunna
LQ Newbie
 
Registered: Mar 2004
Location: Sunnyvale, California 94086
Distribution: debian
Posts: 6

Original Poster
Rep: Reputation: 0
It is a Logitech PS2 two-button mouse.
No middle or wheel or scroll button. A simple, typical, old one.
 
Old 03-26-2004, 05:12 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Quote:
Originally posted by LovelyJunna
Thanks for replying.

You mean the "InputDevice" section?
Yes, that's the right one.
Code:
Section "InputDevice"
        Identifier      "Generic Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "PS/2"    #<--
        Option          "Emulate3Buttons"       "off"
#        Option          "ZAxisMapping"          "4 5"
EndSection
# comments out a line. You don't need the one I marked this way - it's for wheel.
In the line I marked with <-- you can try "Logitech" or "Auto". It may help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i'm using xandros 3.0.2, my mouse(logitech) is not being sensed(cursor doesnt move) rocky_sk0c Linux - Hardware 0 09-13-2005 10:51 AM
[Mouse cursor] flicking on animated cursor Creak Debian 1 06-10-2005 02:16 AM
startx on Debian gives grey background - cannot move mouse cursor or type fdac Linux - Newbie 7 05-04-2005 03:11 PM
move cursor to default button? vzzt! Linux - Newbie 6 10-05-2004 06:14 PM
My cursor doesnt move Fiery Mandriva 13 04-13-2004 06:18 PM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration