LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-11-2008, 03:01 PM   #1
AibLink
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Rep: Reputation: 0
Mouse & Keyboard not responding under X, OpenSuse 11.1 b2


Hi Everybody

I'v installed a fresh copy of OpenSuse 11.1 beta 2 (x86_64) on my desktop machine and it seems that keyboard & mouse not functioning at all under X

I can work my keyboard in cli mode and switch between the "tty's"

Am i doing something wrong ?

I's a standard "qwerty" keyboard and a USB mouse

Thanx & Excuse my English

Edit:

Could not find any Errors in Xorg.0.log
Just warnings
Quote:
(WW) The directory "/usr/share/fonts/TTF/" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/OTF" does not exist.
Entry deleted from font path.
this is my xorg.conf if it can help you help me

Quote:
# /.../
# SaX generated X11 config file
# Created on: 2008-10-11T21:04:13+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
EndSection

Section "Module"
EndSection









Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Last edited by AibLink; 10-11-2008 at 03:52 PM.
 
Old 10-13-2008, 12:27 AM   #2
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
Hi AibLink,

Welcome to Linuxquestions.org.

I can suggest a couple of things. Log into the console as root and type 'yast'. That would be the main "control panel". There is a section for hardware. Just run the configuration there again.
BTW do you have a PS2 mouse or a USB. There could be issues with the usb-mouse.
Another thing I can suggest is run the 'sax' command as a root. Even this will rewrite your config files if necessary.

Hope this helps.
 
Old 10-14-2008, 06:09 AM   #3
AibLink
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Solved:


1. boot into init 3
2. did "sax2 -r" as root
3. reboot to normal again

Thank you
 
Old 10-14-2008, 08:11 AM   #4
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
Hi there,

Glad you were able to do it
 
Old 11-25-2009, 05:07 PM   #5
d3x73r
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
Hi all

I got the same problem here...
When i tried to do sax2 -r under console, mouse and keyboard won't work anymore. Then i boot using an ubuntu live cd and chroot OpenSuse.
Tried sax2 again and it worked, but now when i start suse it wont work mouse and keyboard anymore, so i cant do anything!

Is there any way for me to fix this? I'm crazy here!

[update]

I tried now to boot with runlevel 3 and i got terminal access.
But if i do a sax2 -r it stuks on vga configuration. I can't move the mouse and type on my keyboard.

[fixed]

After take a breath i take another shot on my xorg.conf and added on ServerFlags section:
Option "AutoAddDevices" "off"

It fixed mouse and keyboard problems!

Thats it! Thanks anyway!

Last edited by d3x73r; 11-25-2009 at 05:31 PM. Reason: fixed!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
logitech keyboard and mouse stopped responding Shankarrajus Linux - Hardware 1 04-07-2006 09:30 AM
Laptop keyboard stops responding after usb mouse installed koloth Slackware 2 07-11-2005 07:50 AM
keyboard and mouse stop responding coffeedemon Linux - Software 8 11-09-2004 03:53 PM
Keyboard and mouse not responding in RH9 satish427 Linux - Newbie 2 10-16-2004 08:12 AM
Keyboard and Mouse Buttons stop responding h2gofast Linux - General 2 02-26-2004 12:32 PM


All times are GMT -5. The time now is 12:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration