LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-15-2002, 11:53 PM   #1
Moebius
Member
 
Registered: Dec 2002
Location: Milwaukee, WI
Distribution: Ubuntu, Kubuntu, Debian, CentOS
Posts: 216

Rep: Reputation: 30
mounting windows shares


So I've been able to use this little LinNeighborhood app to mount my windows shares, but when i reboot they're no longer mounted. (Wouldn't it be logical just to keep them mounted? I mean usually if you mount something once, you want it to stay mounted, yes?)

So how do i get them to mount all the time so i don't have to go through all this every time I reboot.

Thanks.

IM me if you want.
AIM: hellomynameiszac
ICQ: 5070238
MSN: ejunksux@hotmail.com
 
Old 12-16-2002, 04:56 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
search this site for "fstab smb" should give you plenty to get on with
 
Old 12-16-2002, 08:33 AM   #3
pilot1
Member
 
Registered: Jun 2002
Location: USA
Distribution: Gentoo, Fedora Core
Posts: 408

Rep: Reputation: 30
You could use automount, i've never used it but if you type "man automount" you should get some information on how to use it.
 
Old 12-17-2002, 04:11 PM   #4
maxpluto
LQ Newbie
 
Registered: Dec 2002
Location: Atlanta
Distribution: Redhat, Mandrake, Zipslack
Posts: 1

Rep: Reputation: 0
To mount and keep the mount you need to do the following.
Open your terminal editor and login as root.
Go to /mnt and create a folder ie. winxp. mkdir winxp
Change dir to /etc
Open fstab with favorite editor .. example 'vi' or 'kate'
add the following line

/dev/hda1 /mnt/winxp ntfs ro,users,exec,uid=500,iocharset=iso8859-1 0 0

then save
(if you have more than one drive say d:\ repeat process but change to hda2)
test your work. in terminal go to /mnt/winxp then do a ls
or go to your file manager and /mnt/winxp your window files should show up if the procedure was worked. only thing that can go wrong is the hda? not sure how you set yours up. (Or if you are using fat or fat32 change the ntfs to fat or fats32. ) I did not test this as I have only NTFS partitions.
If all goes well and you have the set up correct the partitions will be mounted when you boot.
the security level can be changed with the uid=?

Regards
 
Old 12-17-2002, 05:31 PM   #5
bumpert
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat
Posts: 29

Rep: Reputation: 15
Quote:
Originally posted by maxpluto
To mount and keep the mount you need to do the following.
Open your terminal editor and login as root.
Go to /mnt and create a folder ie. winxp. mkdir winxp
Change dir to /etc
Open fstab with favorite editor .. example 'vi' or 'kate'
add the following line

/dev/hda1 /mnt/winxp ntfs ro,users,exec,uid=500,iocharset=iso8859-1 0 0

then save
(if you have more than one drive say d:\ repeat process but change to hda2)
test your work. in terminal go to /mnt/winxp then do a ls
or go to your file manager and /mnt/winxp your window files should show up if the procedure was worked. only thing that can go wrong is the hda? not sure how you set yours up. (Or if you are using fat or fat32 change the ntfs to fat or fats32. ) I did not test this as I have only NTFS partitions.
If all goes well and you have the set up correct the partitions will be mounted when you boot.
the security level can be changed with the uid=?

Regards
thx a lot, now my fat32 partition is mouting each time a log in, but i have a question, why they always said to me that its read only.. where can i change this???

thx
 
Old 12-18-2002, 07:31 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,969

Rep: Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752
Add umask=0 option to your /etc/fstab entry.
 
Old 12-18-2002, 07:38 AM   #7
bumpert
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat
Posts: 29

Rep: Reputation: 15
Quote:
Originally posted by michaelk
Add umask=0 option to your /etc/fstab entry.
at the end of the line to mount my partition, or in a new line!?

ill try it tonight, cuse now im at work
 
Old 12-18-2002, 08:23 AM   #8
ajk
Member
 
Registered: Nov 2002
Location: CH-3416 Affoltern
Distribution: (SuSE 8.0), Mandrake 9.2
Posts: 58

Rep: Reputation: 15
end of the line
 
Old 12-18-2002, 08:33 AM   #9
bumpert
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat
Posts: 29

Rep: Reputation: 15
Quote:
Originally posted by ajk
end of the line
thx a lot, ill try it tonight when ill eb at home, and give you feedback , thx
 
Old 12-18-2002, 06:53 PM   #10
bumpert
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat
Posts: 29

Rep: Reputation: 15
Quote:
Originally posted by michaelk
Add umask=0 option to your /etc/fstab entry.
didnt work, still given me the read only error
 
Old 12-18-2002, 09:30 PM   #11
ktaylo58
LQ Newbie
 
Registered: Nov 2002
Location: Detroit, MI USA
Distribution: SuSE 8.2
Posts: 27

Rep: Reputation: 15
automount read write (rw)

Just change the ro to rw on the line from MaxPluto's reply.

FYI, the uid=500 might need to also be changed. When you do a
ls -nl in your home directory, it shows you ids instead of the user and group.

i.e.,

taylork@canopus /home/guest 385 > ls -nl
total 0
drwx------ 2 501 100 48 2002-12-09 22:25 cur/
drwx------ 2 501 100 48 2002-12-09 22:25 new/
drwx------ 2 501 100 48 2002-12-09 22:25 tmp/

so it would be uid=501 in this case.
 
Old 12-19-2002, 06:33 AM   #12
bumpert
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat
Posts: 29

Rep: Reputation: 15
Re: automount read write (rw)

Quote:
Originally posted by ktaylo58
Just change the ro to rw on the line from MaxPluto's reply.

FYI, the uid=500 might need to also be changed. When you do a
ls -nl in your home directory, it shows you ids instead of the user and group.

i.e.,

taylork@canopus /home/guest 385 > ls -nl
total 0
drwx------ 2 501 100 48 2002-12-09 22:25 cur/
drwx------ 2 501 100 48 2002-12-09 22:25 new/
drwx------ 2 501 100 48 2002-12-09 22:25 tmp/

so it would be uid=501 in this case.
ok thx a lot, ill give a try tonight when ill be at home, i have the "joy" to work on windows at work, lol

thx, ill give you feedback tonight
 
Old 12-19-2002, 08:58 PM   #13
bumpert
LQ Newbie
 
Registered: Dec 2002
Distribution: RedHat
Posts: 29

Rep: Reputation: 15
coool that work man, i changed the ro to rw, so stupid when you know this
hehe

thx a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Mounting Windows Shares as non-root Chebyshev Linux - Networking 2 05-29-2004 07:22 PM
Mounting Windows Shares using SAMBA Flossie Mandriva 2 03-26-2004 10:12 AM
Mounting windows shares... mattbeekler Linux - Software 2 11-24-2003 01:35 PM
Mounting Windows Shares ilumin8d Linux - Networking 4 07-15-2003 02:36 AM
Mounting Windows Shares Thermos Linux - Networking 3 07-09-2003 01:34 PM


All times are GMT -5. The time now is 09:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration