LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2004, 02:40 PM   #1
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Rep: Reputation: 30
Mounting windows partitions


I have read a previous thread post here on this. But I want to make it accessible not just to root. I'd prefer mounting my D partition in somewhere like /home so that other users have permissions to it. or, is there I can access entire folders temporarily? I'd prefer to work with the files through Konquerer.
 
Old 03-27-2004, 03:22 PM   #2
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
You don't need to go through that. Just edit your /etc/fstab where the partition is listed. You should see something like:
/dev/hd(whatever) /mnt/windows NTFS noauto,ro 0 0

The part you should be concerned with is the "noauto,ro" part(yours most likely has something different). Add the word user or users to it so it reads "noauto,user,ro"

This is assuming your Windows partition is NTFS.
 
Old 03-27-2004, 03:25 PM   #3
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Original Poster
Rep: Reputation: 30
What does ro(root?) and owner mean? I'm going to try to mount FAT32(vfat). Actually... what does each parameter mean? How do I execute this new config? The only way is to reboot with it?

Last edited by PhuckFonix; 03-27-2004 at 03:32 PM.
 
Old 03-27-2004, 03:32 PM   #4
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
Quote:
Originally posted by PhuckFonix
What does ro(root?) and owner mean? I'm going to try to mount FAT32(vfat). Actually... what does each parameter mean?
ro means read only, and you don't need it if it's vfat, so don't add it. Noauto tells it not to automount during startup, so you'll mount it laster by typing 'mount /mnt/windows', user means that only the user that mounted it can unmount it(I think), users means all users have access to it.
 
Old 03-27-2004, 03:35 PM   #5
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Original Poster
Rep: Reputation: 30
I'd like to write new files and edit those files. And the columns of 0 0? They are currently set to 1 0.
 
Old 03-27-2004, 04:00 PM   #6
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
Quote:
Originally posted by PhuckFonix
I'd like to write new files and edit those files. And the columns of 0 0? They are currently set to 1 0.
So your fstab entry should look something like:
Code:
/dev/hd(whatever)      /mnt/windows      vfat    noauto,users     0  0
I don't think it hurts to keep that 1 there.

Don't forget to 'mkdir /mnt/windows'
 
Old 03-27-2004, 04:08 PM   #7
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Original Poster
Rep: Reputation: 30
My fstab

Code:
/dev/hda5        swap             swap        defaults               0   0
/dev/hda3        /                ext2        defaults               1   1
/dev/hda6        /usr             ext2        defaults               1   2
/dev/hda7        /home            ext2        defaults               1   2
/dev/hda2        /mnt/fat-g       vfat        noauto,ro, user        1   0
/dev/hdb5        /mnt/fat-files   vfat        noauto,ro, user        1   0
/dev/hdb2        /mnt/hdb-2       vfat        noauto,ro, user        1   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro, user  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner           0   0
devpts           /dev/pts         devpts      gid=5,mode=620         0   0
proc             /proc            proc        defaults               0   0

I have my directories set:
Code:
root@home:/# mkdir /mnt/fat-g
root@home:/# mkdir /mnt/fat-d
root@home:/# mkdir /mnt/hdb-2
root@home:/# mv /home/user/Desktop/fstab /etc/fstab
I did a mount /dev/hdb2 /mnt/fat-files but nothing changed.

Last edited by PhuckFonix; 03-27-2004 at 04:26 PM.
 
Old 03-27-2004, 06:07 PM   #8
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
Code:
/dev/hda2        /mnt/fat-g       vfat        noauto,ro, user        1   0
Get rid of those spaces between ro, and user.
it should be noauto,ro,user

Speaking of the ro, I thought you didn't want it to be read only?

So it should really be noauto,user

And once your fstab is configured correctly, you don't need to do 'mount /dev/hda2 /mnt/fat-g', you just type 'mount /mnt/fat-g'

Quote:
I did a mount /dev/hdb2 /mnt/fat-files but nothing changed.
You don't even have hdb2 mapped to /mnt/fat-files. At any rate, you shouldn't have to type it, just type 'mount /mnt/fat-files'

Also, you made a directory called "fat-d", but your fstab doesn't point to that directory. It's pointing at fat-files. So either rename that directory, or change the fstab entry to
Code:
/dev/hdb5        /mnt/fat-d   vfat        noauto,ro, user        1   0
 
Old 03-27-2004, 06:37 PM   #9
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Original Poster
Rep: Reputation: 30
Okay, I think I'll have to remount the mounted ones for the fstab to apply the new settings. I tried "unmount /mnt/fat-g" but that doesn't work. Also, how do I remove directories? I can't rm directories.

Last edited by PhuckFonix; 03-27-2004 at 06:38 PM.
 
Old 03-27-2004, 06:49 PM   #10
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Quote:
Originally posted by PhuckFonix
I tried "unmount /mnt/fat-g" but that doesn't work.
the command is umount, instead of unmount.
 
Old 03-27-2004, 06:55 PM   #11
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Original Poster
Rep: Reputation: 30
I haven't rebooted but I have:

Code:
/dev/hda5        swap             swap        defaults                    0   0
/dev/hda3        /                ext2        defaults                    1   1
/dev/hda6        /usr             ext2        defaults                    1   2
/dev/hda7        /home            ext2        defaults                    1   2
/dev/hda2        /mnt/fat-g       vfat        noauto,users,user           0   0
/dev/hdb5        /mnt/fat-d       vfat        noauto,users,user           0   0
/dev/hdb2        /mnt/hdb-2       vfat        noauto,users,user           0   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro,users,user  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner                0   0
devpts           /dev/pts         devpts      gid=5,mode=620              0   0
proc             /proc            proc        defaults                    0   0
I am still denied access with konquerer logged in as user in group users.
 
Old 03-27-2004, 09:45 PM   #12
Pauli
Member
 
Registered: Feb 2004
Location: Montreal
Distribution: Gentoo/Debian
Posts: 365

Rep: Reputation: 30
Why do you have seperate partitions for /usr and /home?

secondly, for me to mount things in FC1 and Slack, I think its mount /dev/hda1 or whatever you hd is. It works for me, so try that.

Oh yes, but with slack there is a problem with that. Sec, Ill get youthe proper fstab for the slack mounting and permissions. Even with defaults 0 0 you wont have the proper permissions. Put this in instead.

/dev/hdb2 /mnt/fat32 vfat users,umask=000,noauto,rw 0 0

I THINK that is the one, I am not positive though. When I get back to my flat and check my fstab ill tell you.
 
Old 03-27-2004, 10:31 PM   #13
PhuckFonix
Member
 
Registered: Mar 2004
Location: United States of Bush
Distribution: Knoppix 3.7, Debian Sarge
Posts: 297

Original Poster
Rep: Reputation: 30
I think the way it works for me is that the user who mounts it uses it. I think the partitions get unmounted on shutdown, also. I'll be waiting, thanks!
 
Old 03-28-2004, 12:15 PM   #14
Pauli
Member
 
Registered: Feb 2004
Location: Montreal
Distribution: Gentoo/Debian
Posts: 365

Rep: Reputation: 30
Try the one I put. It doesnt need a restart.

And all partitions get unmounted when you shut down. No matter what
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Mounting Windows Partitions sidharth0384 Linux - Newbie 2 04-22-2005 03:22 PM
Mounting Windows XP partitions in Debian John_Emad Linux - Software 1 12-26-2004 05:24 PM
automatic mounting of windows partitions vijeesh_ep Linux - Networking 1 07-31-2004 02:05 PM
mounting windows partitions shahzadiub Programming 1 04-22-2004 05:49 AM
ELX mounting windows partitions? mato30 Linux - Distributions 0 03-05-2002 05:44 PM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration