LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2003, 01:29 AM   #1
jsin
Member
 
Registered: Jul 2003
Distribution: RedHat 8
Posts: 36

Rep: Reputation: 15
Mounting Windows Partition. Frustrated!!!


I have written about this problem before, and I was finally
able to get my Windows partition mounted.
I noticed something though, when I booted into Windows
and went to the C: drive there was a folder there named
" .Trash-root ". Why did Linux create this? Is it safe to
delete and is there a way to stop Linux from creating this folder?
Also I used shell commands to create a dir named Windows
so that I could see my Windows drive, and also experimented
with editing my fstab file, but one of my other problems is
that I can not unmount the dir, I get an error saying folder
is busy. I have used various options of the umount command
and still cant get this damned thing unmounted!

Can anyone tell me the "proper" way to mount my windows
partition safely?
If possible I would like an icon to it on my desktop.

Thanks.
 
Old 08-01-2003, 01:52 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
but one of my other problems is
that I can not unmount the dir, I get an error saying folder
is busy. I have used various options of the umount command
and still cant get this damned thing unmounted!
Show us the fstab? :)

Most likely you're in the directory
somewhere (in some other window,
maybe in a console, maybe holding
a file open, ...)

Cheers,
Tink
 
Old 08-01-2003, 03:34 AM   #3
Zoombie
Member
 
Registered: Jul 2003
Distribution: Debian Testing
Posts: 180

Rep: Reputation: 30
It would be useful to know what distribution of Linux you're using, and what version of Windows you're using. And yeah, if you're unable to mount a drive, you're probably still using it.
 
Old 08-02-2003, 08:11 PM   #4
jsin
Member
 
Registered: Jul 2003
Distribution: RedHat 8
Posts: 36

Original Poster
Rep: Reputation: 15
Sorry I havent posted back, I have been busy at work and
family issues.
I have Redhat 8. 40 gig dirve partitioned into 2 20 gig drives.
Windows 2000 on one and Linux on the other.
I cant access the web because I have a winmodem, and I
havent been able to scrape together the $$$ for a new one.

I created the mount point a few times, but I still have trouble,
such as not being able to unmount it.
I would also like to have an icon on the desktop for my
"C" drive.
I also need to know about the folder Linux adds to the drive
that is named .Trash-root
Thanks guys.
 
Old 08-02-2003, 08:19 PM   #5
Cafrow
Member
 
Registered: Aug 2003
Location: Mesa, AZ
Distribution: Redhat 9
Posts: 45

Rep: Reputation: 15
http://linux-ntfs.sourceforge.net/info/ntfs.html#4.5

That is the link I used to get it to work. I just fallowed everything on their site, and I got it to work. You have to install the NTFS drivers because RH does not support it I believe.

Anyways, hope you get it to work with that, I am a newbie also, but found that this page told me everything I needed to know on how to mount it.
 
Old 08-02-2003, 08:28 PM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Jsin

To Mount a FAT32 Filesystem on boot-up were All users have Read, Write, Execute access you'll have to create a line in your /etc/fstab file (just substitue in your Partition and Mount point)

/dev/hda1 /mnt/windows vfat defaults,umask=000 0 0

To manually mount a FAT32 filesystem to test initially

mount t vfat o rw /dev/hda1 /mnt/windows


To Mount a NTFS Filesystem on boot-up were All users have Read access create a line in /etc/fstab
(just substitue in your Partition and Mount point)

/dev/hda1 /mnt/windows ntfs auto,ro,umask=002 0 0


To manually mount an NTFS filesystem

mount t ntfs o ro /dev/hda1 /mnt/windows

( Red Hat currently doesnt include a NTFS driver because of uncertainties surrounding the legal status of the driver)

So - to READ a NTFS partition, you can either:

Download and install an RPM or

Compile your kernel

Your best just getting the relevant RPM -



Last edited by Skyline; 08-02-2003 at 08:39 PM.
 
Old 08-02-2003, 10:48 PM   #7
jsin
Member
 
Registered: Jul 2003
Distribution: RedHat 8
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks for the help skyline, I forgot to mention the disk is
fat32.
I still cant figure out why when I use the umount command
it tells me the dir is busy. No matter where I cd to I get this
error.
 
Old 08-02-2003, 11:40 PM   #8
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
does the drive get mounted at startup? (if it does, get rid of that)

if not, and u just manually mount it, try mounting the drive and then unmounting it (don't actually access the drive) and see if u still have a problem

about the .trash-root, don't worry about it, it just means that you've gone inside your windows fat32 drive and deleted something, that folder is basically a trash bin, so yes u can safely delete it
 
Old 08-03-2003, 10:28 AM   #9
jsin
Member
 
Registered: Jul 2003
Distribution: RedHat 8
Posts: 36

Original Poster
Rep: Reputation: 15
One of the times I experimented with it I did have it set to
auto, then I tried playing around with the fstab and
set it to noauto.
I noticed when I use my user account with the KDE desktop
my floppy and cdrom have icons even when unmounted.
I use Gnome as root, and I was wondering if maybe there
was something keeping Gnome from making an icon on the
desktop when I mounted the folder.
I still cant figure out why I cant unmount it no matter what
dir I am in.
I cant access the internet because of my modem, so I have
to boot back and forth. I'll mount my Windows dir and copy
the fstab and post it, maybe I'll take some screen shots
if that will help.
Oh, and I'll try Skylines advice. Hope it works.

Last edited by jsin; 08-03-2003 at 10:31 AM.
 
Old 08-03-2003, 11:44 AM   #10
jsin
Member
 
Registered: Jul 2003
Distribution: RedHat 8
Posts: 36

Original Poster
Rep: Reputation: 15
This is my fstab after I mounted the "Windows" dir manually.
I have made no changes.


LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0



Here is my mtab after I mounted "Windows". Again I have made no changes.


/dev/hda3 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda2 /boot ext3 rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
none /dev/shm tmpfs rw 0 0
/dev/hda1 /mnt/Windows vfat rw 0 0
/dev/fd0 /mnt/floppy vfat rw,nosuid,nodev 0


Copied and pasted from command.........

[root@localhost root]# umount /dev/hda1 /mnt/Windows
umount: /mnt/Windows: device is busy
umount: /mnt/Windows: device is busy
[root@localhost root]# umount /mnt/Windows
umount: /mnt/Windows: device is busy
[root@localhost root]# umount -a
umount: /mnt/floppy: device is busy
umount: /mnt/Windows: device is busy
umount: /dev/pts: device is busy
umount: /: device is busy
[root@localhost root]#


No matter what I try it is always busy, even though I am not in
that dir.
Strange, I just noticed something. I used the locate command to
try to find a file. When I did, it showed me only items from my
"Windows" dir even though I am in the root dir.


I didnt want to use Skyline's tip because of what my mtab said.
I dont want to add anything into my fstab so I wont screw anything
up more than it is.

When I right click in Gnome I can choose which disk I can mount,
either cdrom or floppy. Is there also a way to have "Windows" in
that list?
 
Old 08-14-2003, 08:49 AM   #11
vaseem ingva
LQ Newbie
 
Registered: Aug 2003
Location: Bellary,Karnataka,India
Distribution: can't say cause i do my browsing at different shops
Posts: 1

Rep: Reputation: 0
dear jsin,
I don't know what position i hold in this linux world but i recently loged on to the site.Coming to ur problem.I had the same when i tried to mount a win harddisk. but i figured it out and it worked fine.
This is what i did. i first went to the system section of the startupmenu(KDE) and opened the hardware browser. this is to find out on what position of the /dev/hd??, was my harddisk i was trying to mount was located under where the first ? stands for a character assigned by the os to my harddisk and the second ? stands for the partition number of the hardisk i did similar to that in windows (but only in numbers from 1 2 3....). Now go to any directory and creat a new folder (I preffered the /usr/win123.. ) for each number of harddisk partition u want to mount. Then there are two options either go to the terminal or the run window in startup menu and type the command which is similar in both cases.

mount -t vfat /dev/hdd1 /usr/win 1 (if hardisk is under /dev/hdd and the partition i want to mount is the hdd1)
the above is to mount a vfat file system on the hardisk of given partion number to a given created directory. I have not mounted ntfs but after reading skyline's letter i am sure u can (thanks.......... a lot pal) mount even ntfs . he is given a good explanation of things only u didn't mention that u didnt know where to find the hardisks. for the rest refer his letter for more know how. and to unmount just type umount instead of mount and there u have it walla.good luck hunting win
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting Windows partition ZeroIdea Linux - General 6 10-25-2005 02:38 AM
Mounting windows partition drguitarum2005 Linux - General 15 02-28-2005 04:53 AM
Mounting Windows Partition johnny_575 Linux - Newbie 4 08-30-2003 06:36 PM
mounting a windows partition? codename000 Linux - Newbie 1 04-15-2003 10:27 PM
mounting windows partition. FLuff_Suit Linux - General 2 05-10-2002 12:31 AM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration