LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-05-2004, 11:23 PM   #1
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Rep: Reputation: 15
Mounting via CD icon works, but via command line = permission denied


Im having some serious woes trying to mount stuff on my Slackware box.

I have tried everything I could google up (right now, I think even your toaster has access to my CD-ROM) but when i do "mount /dev/cdrom /mnt/cdrom" I always get "mount: only root can do that". Same for when I try to mount my USBdisk.

BUT, when I choose "mount" from the KDE cdrom icon, it mounts fine. And if I run KsCD cd player it plays fine too.

My fstab file has
/dev/cdrom /mnt/cdrom iso9660 noauto,umask=000,users,ro 0 0
/dev/sda /mnt/usbdisk auto noauto,users 0 0

in it, and everything related to the drives has full access to everyone AND the SUID bit set (I'll change it when i fix it - promise!)

Does anyone have any suggestions I might try to get this to mount?

Thanks!
 
Old 03-05-2004, 11:24 PM   #2
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
Edit: oops did not finish reading your post..

swap them places like this:
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro,umask=000 0 0

and do not forget to reboot. sorry but sometimes it messes up if you add options and only reboot will clear it up.
Why do you need umask too?

Also check that the account you are using is in 'users' group.

Last edited by Mikhail_16; 03-05-2004 at 11:27 PM.
 
Old 03-06-2004, 05:42 AM   #3
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHAS, Kubuntu, Solaris, TRU64
Posts: 381

Rep: Reputation: 31
Sometimes "automount"/"supermount" file-systems forbid to mount them by hand, also.
 
Old 03-06-2004, 09:59 AM   #4
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Code:
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,users,ro
you might try this also........
 
Old 03-06-2004, 10:41 PM   #5
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Original Poster
Rep: Reputation: 15
No go! Added "owner", checked account was in "users" group... no good

Maybe it is the automount thing.... Is there any way I can check if it is the automount thing you suggested pablob?

Thanks!
 
Old 03-06-2004, 11:17 PM   #6
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
try just doing mount /dev/cdrom or mount /mnt/cdrom

if you leave some blanks, mount will search your fstab for appropriate entries and use those optitions you specified; otherwise, explicitly telling mount where and what to mount ignores fstab

also, if that above doesn't work, try changing "users" to "user" in your fstab options line
 
Old 03-07-2004, 03:26 AM   #7
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Original Poster
Rep: Reputation: 15
Holy moly - just doint mount /mnt/cdrom worked! Ive never seen that advice anywhere else - you have ended my many-houred search! Thank you - You indeed are the OneAndOnlySM!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting an nfs share - Permission Denied doctorwebbox Linux - Networking 5 05-30-2005 02:45 AM
smbmount works but I get permission denied when access the drive jeickal Linux - Networking 0 12-17-2004 12:22 PM
NFS :: Permission denied after mounting, root works.. Devils_Guardian Linux - Networking 1 11-17-2004 11:40 AM
NFS mounting : Permission denied Bahador Linux - Networking 3 07-18-2003 05:33 AM
permission denied when mounting nfs directory keirobyn Linux - Networking 3 01-29-2002 01:43 AM


All times are GMT -5. The time now is 03:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration