LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-27-2011, 01:42 AM   #1
ziphem
Member
 
Registered: Feb 2004
Location: US / EU
Distribution: Fedora 20
Posts: 129

Rep: Reputation: 18
Mounting VFAT as user in Fedora 14


I can't seem to mount my local VFAT partition with username ownership; it is consistently mounted as daemon. I've tried to CHOWN and CHGRP the mount point of /media/SHARED (its location), but that doesn't work. I should include the reason in case you have other suggestions that are alternative to changing ownership on the mounted VFAT drive:

In my old Fedora 9, I ran Eudora under Wine. The program lived on my VFAT partition. I could hence run Eudora under both Windows and Fedora, which was really nice - even though I hardly boot into Windows anymore. While I did notice the username and group name were the same as they are under Fedora 14 fstab mounting - daemon - it still worked without a hitch. To note, the partition was also automounted in Fedora 9 in fstab.

I just upgraded to Fedora 14. When I automount the drive through fstab, Eudora will not launch. Yet when I manually mounted the drive (and I noticed that the username and group are my local username, not daemon), Eudora launches fine. So while my solution, mounting the drive manually when Fedora 14 starts, does in fact work, it is a bit of a pain. Luckily I don't reboot too often!

In any case, I wanted to see if anyone has any suggestions. Maybe it's just a mounting syntax issue; but as for mounting syntax in fstab, I used the same line as my F9 fstab.

The line I used was: /dev/sda3 /media/SHARED vfat umask=0000,dmask=0000,uid=0002,gid=users,users 0 0

Thanks very much for any help!!
 
Old 01-27-2011, 06:50 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Here's a brief excerpt from my /etc/fstab on Fedora 14.
Code:
# Removable Drives
/dev/cdrom              /media/cdrom            udf,iso9660 user,noauto,exec,utf8       0 0
/dev/dvdrom             /media/dvdrom           udf,iso9660 user,noauto,exec,utf8       0 0
/dev/cdrw               /media/cdrw             udf,iso9660 rw,user,noauto,exec,utf8    0 0
/dev/dvdrw              /media/dvdrw            udf,iso9660 rw,user,noauto,exec,utf8    0 0
/dev/sr0                /media/cd               udf,iso9660 rw,user,noauto,exec,utf8    0 0
# USB Sticks
UUID=944B-D24E          /Kingston               vfat    defaults,noauto 0 0
UUID=5cc8325d-dacd-4140-8eff-2c5e4d291003 /Toshiba ext3 defaults,noauto 0 0
# USB 200GB drive
UUID=aa86fb2d-784b-42da-a3d1-b352ec3b8141 /USB_Fedora/boot ext3 defaults,noauto 0 0
UUID=64DC5A0FDC59DBBC   /XP                     ufsd    defaults,rw,noauto 0 0
UUID=6A5F-1690          /XP/Recovery            vfat    defaults,noauto 0 0
UUID=F090155F90152D9A   /XP/Extra               ext3    defaults,rw,noauto 0 0
UUID=5B1D63E8395D1623   /Temp                   ntfs-3g rw,defaults,noauto 0 0
Note the defaults option on the XP drive access stuff, and the users option on the /media lines. (The noauto is because all of those devices are removable.) Look at man mount for option details.

<edit>
Oh, check out the suid to permit the uid= and gid= options in fstab to be used to set the owner anf group of a FAT file system. (Those are FAT specific options, so you need to look at the FAT section of the man page.
</edit>

Last edited by PTrenholme; 01-27-2011 at 07:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9: Read-only access to non-root user on a vfat partition tacman08 Linux - Newbie 4 08-30-2008 01:04 PM
problems in mounting vfat volume with the right user permisisons knudsen83 Linux - Hardware 4 12-22-2007 03:46 PM
Mounting vfat Kupo Linux - Newbie 8 04-26-2007 01:12 PM
Mounting Vfat paradoxlight Linux - Software 4 01-15-2002 06:29 PM
Mounting with Vfat garr71 Linux - General 4 11-29-2001 04:19 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration