LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-25-2007, 10:54 PM   #1
Kupo
Member
 
Registered: Nov 2003
Location: Hell (AZ, USA)
Distribution: FC6/Centos
Posts: 87

Rep: Reputation: 15
Mounting vfat


im trying to mount my win created vfat partition, and im at a loss of what to input into the fstab file, is it possible to mount without editing this file? i have root access just not a clue what to do with the file, ive tried this,

[root@localhost kupo]# mount -t vfat /dev/sda2 /mnt/sda2
mount: mount point /mnt/sda2 does not exist

whereas sda2 is my vfat partition
fstab reads
[root@localhost kupo]# more /etc/fstab
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/sda2 /mnt/sda2

any help is appreciated, i know its probably a dumb question but ive read the man pages and found no answer. Thanks
 
Old 04-25-2007, 11:04 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
The error you're getting means that the directory /mnt/sda2 does not exist. Running mkdir -p /mnt/sda2 will fix that. You could set up your /etc/fstab with this line to simplify your mount command:
Code:
/dev/sda2  /mnt/sda2  vfat  users,exec,rw,umask=0000  0  0
 
Old 04-25-2007, 11:05 PM   #3
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
The message:

mount: mount point /mnt/sda2 does not exist

means that you need to create the mountpoint (directory) where the filesystem will be mounted. You do this with:

mkdir /mnt/sda2

You can then:

mount -t vfat /dev/sda2 /mnt/sda2

Your fstab entry is incorrect. Remove "/dev/sda2 /mnt/sda2" and replace it with:

/dev/sda2 /mnt/sda2 vfat defaults 0 0
 
Old 04-25-2007, 11:10 PM   #4
mechdave
Member
 
Registered: Apr 2007
Location: Adelaide, Australia
Distribution: Ubuntu 8.10 and 7.10 server
Posts: 95

Rep: Reputation: 15
Post RE: Mounting vfat

Your mount command is correct, you have just forgotten to make the directory /mnt/sda2

To add the mount point to /etc/fstab put this following line in /etc/fstab

/dev/sda2 /mnt/sda2 vfat user 0 0

Make sure you have a blank line at the end of /etc/fstab otherwise mount will complain!
 
Old 04-25-2007, 11:24 PM   #5
Kupo
Member
 
Registered: Nov 2003
Location: Hell (AZ, USA)
Distribution: FC6/Centos
Posts: 87

Original Poster
Rep: Reputation: 15
Thanks for the fast replys, worked like a charm
ive got another newbie question, on the gnome xwindow system, how do you make it so when you open folders, it dosnt open a new window, rather just use that same window in a new directory. whenever i use the x system to browse my directorys i end up with nine thousand windows to close (estimate)
 
Old 04-26-2007, 12:13 AM   #6
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
In one of the open windows, select menu Edit->Preferences. Click on the Behavior tab, and check the box that says "Always open in browser windows". Close the windows. Next time you open a folder, it will stay in single window mode.
 
Old 04-26-2007, 12:16 AM   #7
mechdave
Member
 
Registered: Apr 2007
Location: Adelaide, Australia
Distribution: Ubuntu 8.10 and 7.10 server
Posts: 95

Rep: Reputation: 15
Is there any way you can make the window open folders without opening a new one and without browser mode?
 
Old 04-26-2007, 09:38 AM   #8
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Quote:
Originally Posted by mechdave
Is there any way you can make the window open folders without opening a new one and without browser mode?
Yes, you can hold down the shift key while double-clicking on a folder. This will close the parent when the new folder opens.
 
Old 04-26-2007, 02:12 PM   #9
eugen.serban
LQ Newbie
 
Registered: Apr 2007
Posts: 22

Rep: Reputation: 15
i have something else to ask:
i'd like to make a shortcut on my desktop at the folder /ceu/Documents and Settings/Serban/My Documents, but i'm not alowed.
when i try to acces this folder from command promt it reads the command until the first space so it gives me error. what can i do?

Last edited by eugen.serban; 04-26-2007 at 02:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting problem VFAT FS Robert Diggs Linux - Newbie 4 12-21-2006 01:56 PM
mounting vfat fs mcd Linux - Newbie 11 08-25-2003 10:51 PM
VFAT mounting problem NumbThumb Linux - General 2 08-18-2003 04:26 PM
Mounting Vfat paradoxlight Linux - Software 4 01-15-2002 07:29 PM
Mounting with Vfat garr71 Linux - General 4 11-29-2001 05:19 AM


All times are GMT -5. The time now is 10:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration