LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2004, 11:19 PM   #1
dwmorton
LQ Newbie
 
Registered: Apr 2004
Location: Illinois, USA
Distribution: Fedora 12 & 13, x86_64
Posts: 20

Rep: Reputation: 0
Mounting two bootable Linux drives on the same system


I have two hard drives - one that I am actively using in my Fedora Core 2 64-bit system. The other is an old Linux install that is still bootable.

I would like to mount my old Linux disc in my system, copy some files onto my new disc, then reformat the old disc and use it for storage.

The problem is that when I try to boot with both discs installed, the system invariably ends up booting from and mounting the old Linux disc but with the swap partition on the new Linux disc. I have changed boot order. I have even tried telling BIOS to ignore the old disc. Nothing seems to change.

My question: Is there a graceful way (i.e., something short of unplugging my current system disc and using my Fedora rescue CD to wipe out the boot partition on the old disc) that will allow me to mount my old disc under my new system to copy files and then reformat?

System: SK8V, Opteron 142, 1 GB Ram, 160 GB SATA, Radeon 9800 pro

Last edited by dwmorton; 09-26-2004 at 11:24 PM.
 
Old 09-26-2004, 11:44 PM   #2
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,872

Rep: Reputation: 88
If your BIOS, hard drive jumpers, hard drive cables, and boot manager are set up right that should not be happening.
An easy workaround would be to tell the BIOS to ignore your Old Linux hard drive.
The PC should ignore it but Linux will still find it.
 
Old 09-26-2004, 11:53 PM   #3
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
Tell us what bootloader you're using, and show us the bootloadedr config. That might explain things.
 
Old 09-27-2004, 09:18 PM   #4
dwmorton
LQ Newbie
 
Registered: Apr 2004
Location: Illinois, USA
Distribution: Fedora 12 & 13, x86_64
Posts: 20

Original Poster
Rep: Reputation: 0
I'm using grub...

Here is my grub.conf file:

----------------------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hdg2
# initrd /initrd-version.img
#boot=/dev/hdg
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.6.8-1.521)
root (hd0,0)
kernel /vmlinuz-2.6.8-1.521 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.8-1.521.img
title Fedora Core (2.6.7-1.494.2.2)
root (hd0,0)
kernel /vmlinuz-2.6.7-1.494.2.2 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.7-1.494.2.2.img
title Fedora Core (2.6.5-1.358)
root (hd0,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img
-------------------------

I have a single disc SATA as my primary system drive with /boot, / and swap partitions.

The second drive (i.e., old linux drive) is a PATA drive configured as slave (shows up as hdb1/2/3 for boot, / and swap partitions).

It doesn't seem to matter what BIOS choices I make. I can tell BIOS to IGNORE the PATA drive. It still shows up and acts as the boot drive! The only thing that makes it disappear is to unplug the drive.
 
Old 09-27-2004, 09:26 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,963

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Does the old disk have a RH or Fedora distro on it? If so I would guess that having multiple partitions with the same label is causing problems. Have you seen any errors during the boot process?

You can use the tune2fs utility to change the labels on the old drive to something besides / and boot.

The advantages to labels is that you can move partitions around with out having to change the bootloader or the /etc/fstab file.

I do not know if you will need to boot a rescue disk to perform to change the labels or not.

Last edited by michaelk; 09-27-2004 at 09:27 PM.
 
Old 09-27-2004, 09:28 PM   #6
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,872

Rep: Reputation: 88
I will bow out as I have no idea how SATA devices affect boot up behavior.
Setting the problem drive to none in the BIOS should leave it unfound.
Good Luck.
 
Old 09-27-2004, 10:40 PM   #7
dwmorton
LQ Newbie
 
Registered: Apr 2004
Location: Illinois, USA
Distribution: Fedora 12 & 13, x86_64
Posts: 20

Original Poster
Rep: Reputation: 0
There is an error when I boot, when linux tried to mount other partitions, it complains there are two boot partitions and fails to mount the second boot partiton.

It looks like tune2fs might be my best option. I'll give it a try...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting linux drives on mac os x littlewing Linux - General 5 04-25-2005 11:24 PM
mounting sata drives in ubuntu linux nathj72 Linux - Hardware 0 01-16-2005 10:59 PM
mounting 2 linux hard drives milesstandish Linux - Hardware 4 03-31-2004 07:31 AM
Mandrake Linux - mounting new drives... TippyToes Linux - General 3 11-18-2003 11:50 PM
New Linux User Mounting Win Drives ? NauticX Linux - Newbie 6 08-13-2003 10:10 PM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration