LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-05-2006, 12:49 AM   #1
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Rep: Reputation: 0
Mounting reiserfs partition


Using FC5. Machine also has Suse 10.1 on it, which is using reiserfs. I have no problems mounting and accessing the Fedora partitions from Suse, but I can't get to Suse from Fedora because it won't mount or can't read it. My Fedora fstab is "/dev/sdb7 /mnt/suse reiserfs defaults 0 0"

Isn't there some way to do this?

Thanks
Robert
 
Old 09-05-2006, 01:04 AM   #2
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
you could take a look at /etc/mtab in suse.
What does it say if you try to mount it manually?
 
Old 09-05-2006, 01:32 AM   #3
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
FC5 doesn't support reiserfs fedora release FAQ
But if you want to install FC5 using reiserfs then you can use this at the 1st Install prompt
Code:
linux selinux=0 reiserfs
 
Old 09-06-2006, 09:07 PM   #4
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by oskar
you could take a look at /etc/mtab in suse.
What does it say if you try to mount it manually?
Looking at mtab in Fedora (that is what I am having a problem with, mounting the suse partition so I can see it from FC5) the suse partition isn't mounted or listed, despite the fact that I have the following line in the FC5 fstab:
/dev/sdb7 /mnt/suse reiserfs defaults 0 0

Oddly enough I can mount it manually and it works fine.

Why doesn't it mount when it boots up?

Thanks
Robert
 
Old 09-06-2006, 09:10 PM   #5
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by odcheck
FC5 doesn't support reiserfs fedora release FAQ
But if you want to install FC5 using reiserfs then you can use this at the 1st Install prompt
Code:
linux selinux=0 reiserfs
Everything is installed and working, I don't want to install FC using resierfs, I just want to be able to mount and read the suse partition which uses reiserfs.

For some reason it won't mount at boot up despite the fstab entry but I can mount it manually and it works fine.
 
Old 09-07-2006, 12:09 AM   #6
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
I would have been very suprised if it didn't support reiserfs.

I asked for the mtab in suse, because I wanted to see how it looks if it's working... try "mount -a" this executes the fstab, and post the result.
 
Old 09-07-2006, 12:26 AM   #7
rahulk
Member
 
Registered: Mar 2006
Posts: 110

Rep: Reputation: 16
Quote:
Originally Posted by wolferd1
Looking at mtab in Fedora (that is what I am having a problem with, mounting the suse partition so I can see it from FC5) the suse partition isn't mounted or listed, despite the fact that I have the following line in the FC5 fstab:
/dev/sdb7 /mnt/suse reiserfs defaults 0 0

Oddly enough I can mount it manually and it works fine.

Why doesn't it mount when it boots up?

Thanks
Robert

hmm, you may try mount -a to check if the mount point is properly declared in /etc/fstab. You can also check "dmesg" to find any mounting error during boot-time.

If your problem is not resolved, try to add the "manual mount command (as you have been using)" to /etc/rc.local. this rc.local script is run after all booting scripts finish up there job. try re-booting afterwards, it should come up.

Hope it helps,
Rahul.
 
Old 09-07-2006, 07:05 AM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,926

Rep: Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824Reputation: 1824
As rahulk stated it could be an error in the /etc/fstab entry or the reiserfs module in not in the inital ramdisk (initrd). If the module is not in the initrd then the partition will not mount at boot since the module will load after the OS mounts partitions via fstab. Also as stated you can add a line to the rc.local file or add the module to the initrd.
 
Old 09-07-2006, 09:11 AM   #9
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by oskar
I would have been very suprised if it didn't support reiserfs.

I asked for the mtab in suse, because I wanted to see how it looks if it's working... try "mount -a" this executes the fstab, and post the result.
This is the suse mtab:

/dev/sdb7 / reiserfs rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sdb1 /mnt/fc5boot ext3 rw 0 0
/dev/sdb3 /mnt/fc5 ext3 rw 0 0
/dev/sdb5 /mnt/fc5home ext3 rw 0 0
/dev/sdb9 /mnt/mandriva2006 ext3 rw 0 0
/dev/sdb11 /mnt/ubuntu ext3 rw 0 0
/dev/sdb2 /mnt/shared vfat rw,uid=1000,umask=0022,utf8=true 0 0
/dev/sda1 /mnt/DellUtil vfat rw 0 0
/dev/sda2 /mnt/windowsXP ntfs rw,umask=0222 0 0
/dev/sda3 /mnt/DellSysRestore vfat rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0

Suse is mounted at /dev/sdb7.

I ran mount -a in FC5 since that is where I have having the problem getting the suse mounted. (All the other partition mount properly in suse) When I did, it mounted the suse partition, though it didn't at initial boot.
 
Old 09-07-2006, 09:25 AM   #10
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rahulk
hmm, you may try mount -a to check if the mount point is properly declared in /etc/fstab. You can also check "dmesg" to find any mounting error during boot-time.

If your problem is not resolved, try to add the "manual mount command :)(as you have been using)" to /etc/rc.local. this rc.local script is run after all booting scripts finish up there job. try re-booting afterwards, it should come up.

Hope it helps,
Rahul.
Running mount -a causes it to mount as it should with no error messages, it just doesn't mount on the initial boot.

I have a dmesg error that probably explains this - though I can't figure out what I would have to do to resolve the error on boot up.

ReiserFS: sdb7: found reiserfs format "3.6" with standard journal
ReiserFS: sdb7: using ordered data mode
ReiserFS: sdb7: journal params: device sdb7, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sdb7: checking transaction log (sdb7)
ReiserFS: sdb7: Using r5 hash to sort names
audit(1157634256.255:4): avc: denied { search } for pid=1377 comm="mount" nam e="/" dev=sdb7 ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:obj ect_r:unlabeled_t:s0 tclass=dir
ReiserFS: sdb7: warning: xattrs/ACLs enabled and couldn't find/create .reiserfs_ priv. Failing mount.

I guess I can probably just add
mount /dev/sdb7 /mnt/suse
to rc.local to get it to mount. Does the dmesg error offer a solution to get it to mount when the fstab is executed at initial boot?

Thanks,
Robert
 
Old 09-08-2006, 12:12 AM   #11
rahulk
Member
 
Registered: Mar 2006
Posts: 110

Rep: Reputation: 16
Quote:
Originally Posted by wolferd1
Running mount -a causes it to mount as it should with no error messages, it just doesn't mount on the initial boot.

I have a dmesg error that probably explains this - though I can't figure out what I would have to do to resolve the error on boot up.

ReiserFS: sdb7: found reiserfs format "3.6" with standard journal
ReiserFS: sdb7: using ordered data mode
ReiserFS: sdb7: journal params: device sdb7, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sdb7: checking transaction log (sdb7)
ReiserFS: sdb7: Using r5 hash to sort names
audit(1157634256.255:4): avc: denied { search } for pid=1377 comm="mount" nam e="/" dev=sdb7 ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=system_ubj ect_r:unlabeled_t:s0 tclass=dir
ReiserFS: sdb7: warning: xattrs/ACLs enabled and couldn't find/create .reiserfs_ priv. Failing mount.

I guess I can probably just add
mount /dev/sdb7 /mnt/suse
to rc.local to get it to mount. Does the dmesg error offer a solution to get it to mount when the fstab is executed at initial boot?

Thanks,
Robert

there is a hidden directory on a ReiserFS file system used for XATTRs which is unlabeled. This is a known issue with reiser FS. there were some C programs written to patch this problem. the reiserfs xattr attributes must be ported to generic xattr interface. go to this URL for more information.

"http://suse.osuosl.org/people/jeffm/reiserfs/xattr-rework/08-reiserfs-use-generic-xattr-handlers.diff"

For temporary fix, you must add the mount command to rc.local. It will work since it runs after all the boot scripts finish up there job, thus providing Linux with the default attributes and xattr error wont occur.
 
Old 09-08-2006, 09:09 AM   #12
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rahulk
For temporary fix, you must add the mount command to rc.local. It will work since it runs after all the boot scripts finish up there job, thus providing Linux with the default attributes and xattr error wont occur.
I can mount it manually with "mount /dev/sdb7 /mnt/suse" But for whatever reason it won't mount automatically even when I add that to rc.local.
 
Old 09-08-2006, 09:16 AM   #13
rahulk
Member
 
Registered: Mar 2006
Posts: 110

Rep: Reputation: 16
Quote:
Originally Posted by wolferd1
I can mount it manually with "mount /dev/sdb7 /mnt/suse" But for whatever reason it won't mount automatically even when I add that to rc.local.
can you put the following line and try again ?

mount -t reiserfs /dev/sdb7 /mnt/suse
 
Old 09-08-2006, 11:22 AM   #14
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rahulk
can you put the following line and try again ?

mount -t reiserfs /dev/sdb7 /mnt/suse
I already did, no help.

I am apparently missing something since the same command that mounts it manually won't mount it in /etc/rc.local. There isn't more than one rc.local is there?
 
Old 09-08-2006, 11:39 AM   #15
wolferd1
LQ Newbie
 
Registered: Jan 2005
Location: NC, USA
Distribution: Suse10.1, FC5, Ubuntu, Mandriva2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rahulk
can you put the following line and try again ?

mount -t reiserfs /dev/sdb7 /mnt/suse
And just to try it I also tried "mount -a" to no avail.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting reiserfs partitiions hep3005 Linux - General 1 03-24-2006 05:48 AM
reiserfs mounting slowly Nightfrost Linux - General 4 12-22-2004 04:06 PM
second reiserfs partition not mounting after upgrading from 2.4 to 2.6 kernel greenmuzz Linux - General 1 05-12-2004 08:13 AM
Mounting ReiserFS Problems? Jaw3000 Linux - Newbie 2 10-22-2003 05:29 AM
Help changing partition to ReiserFS Gates1026 Linux - Newbie 7 09-18-2003 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration