LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-09-2004, 02:15 PM   #1
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Rep: Reputation: 15
mounting problems? HELP!?


Hi, i wasn't sure where to post this but here goes... i recently installed slackware 9.1 and i managed to mount my cd drive ( i have two, my cdwriter is an ATAPI-CD ROM DRIVE 50 MAX SPEED, and my cd drive is a TEAC CD W54E) hdc is my cd writer and I have no idea what my other cd drive is. I would like both of them mounting and hdc as a cd writer if possible. I have used the following command

Code:
mount /dev/hdc /mnt/cdrom
and also
Code:
mount -t iso9660 /dev/hdc /mnt/cdrom
both have returned the following error, but when i try to use the command, the light on my cd writer flashes as if its trying to read.
Code:
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       or too many mounted file systems
I also need some help mounting my NTFS tab, my friend told me that he did it and is using the same version of slackware as me i have been using the following:

Code:
root@soxbox:/dev# mount -t NTFS /dev/hda /mnt/windows
mount: fs type NTFS not supported by kernel
mount: probably you meant ntfs
root@soxbox:/dev# mount -t ntfs /dev/hda /mnt/windows
mount: wrong fs type, bad option, bad superblock on /dev/hda,
       or too many mounted file systems
here is what my current Fstab looks like:


Code:
/dev/hda3        swap             swap        defaults         0   0
/dev/hda2        /                reiserfs    defaults         1   1
/dev/hdc         /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
/dev/hda         /mnt/windows     NTFS       noauto,user,ro   0   0
I read somewhere about people asking for the following output, so its here, i hope it helps you to help me, i will be really grateful.

ls -il output
the output was too long to post so it can be found at the following web address (i cant post urls not enough posts)
giz.reloadedhosting.com/lsil.txt

thanks again everyone.

thanks to anyone whos read this and anyone who can help me, i really dont know what im doing wrong. Thanks again.
Mr.Gizm0
 
Old 05-09-2004, 02:29 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
I assume you have a CD in the drive when you are mounting it?

You should be able to see which drives are which with:
dmesg | grep "^hd"

Your ntfs partition is probably /dev/hda1 not /dev/hda ("hda" is the drive - "1" is the first partition of that drive). You will also need to use lowercase ntfs.

Last edited by david_ross; 05-09-2004 at 02:30 PM.
 
Old 05-09-2004, 03:11 PM   #3
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Original Poster
Rep: Reputation: 15
thank you for your help, my ntfs partition is now mounted, but I am still having problems with my cd drives (both have audio cds in them at the moment)

i used the "dmesg | grep "^hd"" command and heres the outcome
Code:
hda: Maxtor 6Y060L0, ATA DISK drive
hdc: CD-W54E, ATAPI CD/DVD-ROM drive
hdd: ATAPI-CD ROM-DRIVE-52MAX, ATAPI CD/DVD-ROM drive
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 120103200 sectors (61493 MB) w/2048KiB Cache, CHS=7476/255/63, UDMA(100)
hdc: attached ide-cdrom driver.
hdc: ATAPI 32X CD-ROM CD-R/RW drive, 1280kB Cache, DMA
hdd: attached ide-cdrom driver.
hdd: ATAPI 52X CD-ROM drive, 128kB Cache, UDMA(33)
so i created a new directory for my cd writer in the mnt directory called "cdwriter"

i then tried to mount the devices (both cd drives) and this is what happened (i did add a line for the each the cd devices in fstab).

Code:
root@soxbox:/mnt# mount /dev/hdc /mnt/cdwriter
/dev/hdc: Input/output error
mount: block device /dev/hdc is write-protected, mounting read-only
/dev/hdc: Input/output error
mount: you must specify the filesystem type
root@soxbox:/mnt# mount -t iso9660 /dev/hdc /mnt/cdwriter
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       or too many mounted file systems
root@soxbox:/mnt# mount /dev/hdd /mnt/cdrom
/dev/hdd: Input/output error
mount: block device /dev/hdd is write-protected, mounting read-only
/dev/hdd: Input/output error
mount: you must specify the filesystem type
root@soxbox:/mnt# mount -t iso9660 /dev/hdd /mnt/cdrom
mount: block device /dev/hdd is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdd,
       or too many mounted file systems
root@soxbox:/mnt#
any suggestions?
 
Old 05-09-2004, 03:17 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you're trying to mount an audio cd? to mount a device you need a file system. audio cd's do not contain file systems.
 
Old 05-09-2004, 03:26 PM   #5
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Original Poster
Rep: Reputation: 15
huh? i can't listen to audio cds then? there are audio cds in my cd drives. It worked for a short time once, i was playing a cd with Xms or whatever its called, then things stopped working. *looks really confused*
 
Old 05-09-2004, 03:31 PM   #6
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
you don't mount audio cds or movie dvds. you open up your cd or dvd player software to play them. there is no mounting involved. some players are kscd and xmms. you can also use cd rippers like grip or ripperx to listen to cds.

Last edited by megaspaz; 05-09-2004 at 04:50 PM.
 
Old 05-09-2004, 03:33 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
You can use audio CDs - you just don't need to mount them. The cd player will access the disc directly.
 
Old 05-11-2004, 12:07 PM   #8
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Original Poster
Rep: Reputation: 15
Hi, after investigation it is xmms I have the problem with there is a cd player in kde that works perfectly (thats for your help) if you insert an audio cd while running xp and look on my computer and click the cd once it gives you "details" one of these is "File system: CDFS" that and not being able to play cds with xmms is what confused me, do i need to do anything with xmms to enable it to let me play audio cds? I clicked "play location" I had an audio cd in hdc and type /dev/hdc, and then ok, nothing happened
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting problems ssabljic Slackware 3 11-25-2005 04:27 AM
Mounting problems sri_hassan Linux - Newbie 3 10-07-2005 08:22 PM
mounting problems eo697 Linux - Hardware 1 07-04-2003 06:05 AM
problems mounting ewto Linux - Newbie 18 04-11-2003 03:34 AM
Mounting problems tsitras Linux - Newbie 3 03-23-2003 03:40 PM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration