LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-26-2001, 05:19 PM   #1
Chalky723
LQ Newbie
 
Registered: Oct 2001
Location: St Neots
Distribution: SuSE 7.3
Posts: 5

Rep: Reputation: 0
Angry Mounting Problems!


Not what it sounds like - Honest!!

I've just installed SuSE 7.3 & this may be a silly question - I cannot mount any of my disk's (CD, DVD, Zip & Floppy) - SuSE has put shortcuts to all of them on my desktop but they do nothing.

My /etc/fstab is this:-

/dev/hda7 / reiserfs defaults 1 1
/dev/hda5 /boot ext2 defaults 1 2
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
devpts /dev/pts devpts defaults 0 0
/dev/dvd /media/dvd auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs defaults,noauto 0 0
/dev/hda1 /windows/C vfat auto,user 0 0
/dev/sda4 /media/zip auto noauto,user 0 0
/dev/hda6 swap swap pri=42 0 0

If I change "noauto" to "auto" for the CD, DVD & Zip it mounts them at startup - but only if there is a disk inserted, if there isn't I can't mount no matter what I do.

Changing to "auto" for the floppy makes no difference at all!

This is one of those little things that can drive you mad - I'm a newbie to Linux (tried Red Hat a few years ago, but gave it up as non user-friendly) and trying hard!!

Thanks in advance,

Chalky
 
Old 10-26-2001, 05:47 PM   #2
cuzin lumin
LQ Newbie
 
Registered: Oct 2001
Posts: 2

Rep: Reputation: 0
Have you tried on the command line

mount /dev/cdrom /mnt/cdrom

the first part (/dev/cdrom) may not be completely correct - check the directory /dev & look for something starting with cdr.

The same principle should apply for zip disks, floppy disks & the dvd - look for something similar in the /dev/ directory - the floppy will probably be /dev/fda or similar. Also, make sure that the mount path /mnt/cdrom or whatever exists. If not, create the directory (mkdir /mnt/cdrom or /floppy or whichever).

You may not be able to remove cd's by pressing the eject button. If not, type umount /dev/cdrom to get them out.
 
Old 10-26-2001, 07:06 PM   #3
Chalky723
LQ Newbie
 
Registered: Oct 2001
Location: St Neots
Distribution: SuSE 7.3
Posts: 5

Original Poster
Rep: Reputation: 0
Unhappy

Right, I've just had a dabble, the mount point is /media/floppy (or whatever), if i type mount /media/floppy - it does. Same with the other drives. I've checked the properties of the shortcuts & they're all pointing to the right mount points & devices. If I right click on the cd & dvd icons & hit eject it does!

The thing that's driving me mad is that the wretched icons ain't doing as they should! I don't fancy letting my (youngish) kids mess around in the Konsole either which is why I'd like the icons to do their job!

Trouble is I know enough to trash the system & not enough to know what I'm doing in it!

Is it going to be the setting in the /etc/fstab, why does the floppy have "auto" & then "noauto" in the same line? If I change the other drives to "auto" it works (as long as the media you want to use is in the machine!)

Oh, almost forgot, whenever I click any of the icon's it opens a browser window with an error box - the error is "Unsupported Action listdir" - I don't know if this helps!


Thanks a lot for the help so far - I've learnt something so its not a wasted effort!!

Chalky
 
Old 10-27-2001, 12:12 AM   #4
gummi
LQ Newbie
 
Registered: Oct 2001
Location: CA
Distribution: Debian
Posts: 10

Rep: Reputation: 0
It sound like you are not having problems mounting, so you might be better of just deleting the icons and making new icons (presuming you want to have the icons in the first place).

Personally I use either a terminal or 'gkrellm' (the swiss army knive of process monitors).

The format of /etc/fstab you can find out through the 'man fstab' command. It sound wrong to put auto in the third field but I might be wrong.

Anyways, explore and learn.
 
Old 10-27-2001, 11:44 AM   #5
Chalky723
LQ Newbie
 
Registered: Oct 2001
Location: St Neots
Distribution: SuSE 7.3
Posts: 5

Original Poster
Rep: Reputation: 0
Red face

Cheers for the help guys,

I've done a bit of dabbling & have discovered that I can mount/unmount from the terminal. It appears to be a problem with the icons, I've created new one's & they make no difference - I still can't mount/unmount from the icon. If I mount via the terminal then I can use the icon to open the disk/media.

So I've found where the problem is, just got to try & get the icons up & running as they should. (I'd like to keep the kids away from terminal windows for a year or 2 yet!!)

Thanks again for the help,

Chalky
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting problems ssabljic Slackware 3 11-25-2005 05:27 AM
Mounting problems sri_hassan Linux - Newbie 3 10-07-2005 09:22 PM
mounting problems eo697 Linux - Hardware 1 07-04-2003 07:05 AM
problems mounting ewto Linux - Newbie 18 04-11-2003 04:34 AM
Mounting problems tsitras Linux - Newbie 3 03-23-2003 04:40 PM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration