LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2005, 09:04 AM   #1
atom
Member
 
Registered: Feb 2004
Location: Slovenia
Distribution: archlinux
Posts: 271

Rep: Reputation: 31
mounting NTFS filesystems rw


Hi!

I'm trying to mount my NTFS windows drive rw and it won't let me, plus it would only allow root to read (i want at least myself to be able to read it)

I have kernel gentoo-dev-2.6.10-r4, with ntfs write support compiled into the kernel.

my fstab file:
Code:
atom@saturn / $ cat /etc/fstab
# /etc/fstab: static file system information.
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.14 2003/10/13 20:03:38 azarah Exp $
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail and tail freely.

# <fs>                  <mountpoint>    <type>          <opts>                  <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda2               /boot           ext3            defaults,noatime                1 1
/dev/sda5               /               reiserfs        noatime                         0 1
/dev/sda6               /home           reiserfs        noatime                         0 1
/dev/sda3               none            swap            sw                              0 0
/dev/sda7               /mnt/win1       ntfs            noatime,users,rw,umask=0000     0 0
none                    /proc/bus/usb   usbfs           defaults                        0 0
#/dev/fd0               /mnt/floppy     auto            noauto                          0 0
/dev/sdb                /mnt/cdrom/     auto            noauto,user                     0 0
# NOTE: The next line is critical for boot!
none                    /proc           proc            defaults                        0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none                    /dev/shm        tmpfs           defaults                        0 0
help!

Gasper
 
Old 01-24-2005, 09:15 AM   #2
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
This may help you, or at least give you links to usefull stuff:
http://www.inside-security.de/insert_en.html

Yves.
 
Old 01-24-2005, 09:17 AM   #3
atom
Member
 
Registered: Feb 2004
Location: Slovenia
Distribution: archlinux
Posts: 271

Original Poster
Rep: Reputation: 31
excuse me but how does this help me? I just need some settings configured! Thanks for the link but i can't have two kernels running at once, so that does not really solve my problem .
 
Old 01-24-2005, 09:44 AM   #4
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
NTFS support in Linux kernel is not as good as you would like. And this URL gives a link to an alternate driver called "captive". You could try to use it...
 
Old 01-24-2005, 12:02 PM   #5
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
To read ntfs, add this in fstab: umask=000. this'll make it accessible for all users (earlier I was asking the same question)
E.g.: /dev/hda1 /mnt/ntfs ntfs umask=000 1 0
______________
AFAIK, you can only overwrite existing files (with no changing its lengths (?)) on NTFS
______________
Additional few info is available when you recompile kernel. I.e. you go to /usr/src/linux. type 'make mrproper'. type 'make menuconfig' or (if u're in gui) 'make xconfig'. You'll have to choose what you need in your kernel. And while this "choosing", "help" on what you choose is avilable. It describes what u choose. U may underst&...

Last edited by kornerr; 01-24-2005 at 12:08 PM.
 
Old 01-25-2005, 10:29 AM   #6
atom
Member
 
Registered: Feb 2004
Location: Slovenia
Distribution: archlinux
Posts: 271

Original Poster
Rep: Reputation: 31
Captive seems to work... And it can even be installed from portage! emerge captive did it. Thanks guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB doesn't recognize my NTFS filesystems TroelsSmit Linux - Newbie 1 02-06-2005 09:58 AM
changing partitions filesystems and mounting them? dr_zayus69 Linux - Hardware 7 12-28-2004 08:22 PM
Mounting NTFS Filesystems with Read-Write privs' apocolipse Slackware 2 12-20-2003 03:29 PM
::mounting filesystems and autostarting programs!!:: XxAndyxX Linux - Software 3 05-14-2003 07:00 PM
Mounting filesystems jimmmac Linux - Newbie 4 01-05-2003 07:41 AM


All times are GMT -5. The time now is 03:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration