LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-14-2005, 07:19 AM   #1
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Rep: Reputation: 15
mounting NTFS/fat32 partitioned hard drive (win2k) /when fedora4 runs on seperate HD


hi all. having trouble mounting my windows hard drive. since i'm a newbie and this is hardware related, i posted the same post in both.

i installed linux about 2 months ago for the first time, upgraded it, didn't use it much, and then the family moved, so getting back to it, my brain is a bit fuzzy on the exact details. hence, my hesitation.


I have 2 hard drives. 1 for linux and 1 for windows. the windows hard drive, for linux, is A, the linux Hard drive, for linux, is B. Grub is on A1.

I do believe that A1 in linux for me is my windows C partitioned drive - this is NTFS file system
I do believe that A2 in linux for me is my windows D partitioned drive - this says FAT32 for the file system.

when i run the mount command in linux, I type in what they tell me to type in.
"mount -a"
to mount everythign (and checking that fstab file in question, i don't see any reference to my windows hard drive in there. ) That didn't work. I also tried to mount with the
"mount -t vfat /dev/hda1 /dosc"
command. That didn't work. Realizing the drive was ntfs anyway, I replaced vfat in my command line with ntfs. that didn't work. i also tried
"mount -t vfat /dev/hda2/dosd"
command. no dice. i replaced the vfat in that command line with fat32, and then with just plain old fat. again, no dice. in each case, when i write the command line with the vfat in there , I get something coming back to me that essentially says that no such file system is found. i check the log, and it says the same thing essentially. that's understandable b/c i don't infact have vfat. but according to linux admin for beginners, an old osbourne book that has linux redhat 7 to go with it, fat32 and fat are other valid options to type in the command for where it asks for file system types. but when i type in fat32, fat, the response that comes back to me is no such file system, and
"don't you mean vfat?"
when i type in ntfs, it doesn't recognize that as a file system, period.


I NEED to mount my windows hard drive. 1 partition will have to do if there is absolutely no other option, but i'd much rather mount both partitions, if there is any way possible.

PLEASE HELP!

Thnx.
 
Old 12-14-2005, 08:54 AM   #2
philipvarghese
Member
 
Registered: Dec 2005
Posts: 36

Rep: Reputation: 21
bowie dont get turned off,
Linux is something that the more you dig, the more you get and its your choice threre are no limits.
before you mount your NTFS partition please be warned that writing to it from linux can corrupt partion.
if you prefer to mount your win partitions automatically in read/write mode please follow carefully.

open a console
change to root
and in the prompt use your fav editor.

# kwrite /etc/fstab
then when the editor opens your fstab file you add these lines exactly as it is.

/dev/hda1 /mnt/C ntfs users,auto,umask=000 0 0
/dev/hda5 /mnt/D vfat users,auto,umask=000 0 0
/dev/hda* /mnt/E vfat users,auto,umask=000 0 0

look I have used asterix for your third partion hope you get the idea keep addind 6, 7... and in /mnt F, G... so on as per your available windows partions
also dont forget to press return for free blank line in the end and save file, exit.

also as root change to /mnt
and create directories C, D, and so on for all the mount optins you have listed in the fstab file.

that it
then you can mount all the partions as a normal user by typing
# mount -a
 
Old 12-14-2005, 08:55 AM   #3
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 725

Rep: Reputation: 33
You didn't tell us your distro.
But most of distro don't support ntfs.
You will have to recompile the kernel to make it support ntfs.
But recompile kernel is a very long tasks, you may prefer this link:
http://linux-ntfs.sourceforge.net
 
Old 12-14-2005, 09:01 AM   #4
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
give me some examples of distrobutions and how do i find that out?

i'm using fedora core 4.


as for the first reply, i'll try that out when i get home in 8 hours . (it's the home computer)
 
Old 12-14-2005, 09:01 AM   #5
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 14.1
Posts: 1,138

Rep: Reputation: 55
I didn't understand your post clearly. Anyway, please post output of the command
Code:
fdisk -l
The above command will only run as root

The command will show you what hard drives you have and what are the partition types with their respective numbers.

Quote:
when i run the mount command in linux, I type in what they tell me to type in.
"mount -a"
to mount everythign (and checking that fstab file in question, i don't see any reference to my windows hard drive in there. ) That didn't work. I also tried to mount with the
"mount -t vfat /dev/hda1 /dosc"
command. That didn't work. Realizing the drive was ntfs anyway, I replaced vfat in my command line with ntfs. that didn't work. i also tried
"mount -t vfat /dev/hda2/dosd"
command. no dice. i replaced the vfat in that command line with fat32, and then with just plain old fat. again, no dice.
Did you confirm the /dev/hda1 is indeed has fat32 filesystem. Does your /dosc directory exist? Also the you have to use vfat as the fs-type option in mount command. It will not recognize fat32. Can you tell us what kind of errors you got?

Tux,
 
Old 12-14-2005, 09:12 AM   #6
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
now i'm at the work computer, so i can't type those commands in until i get home. later today. but..., i confirmed, through windows, checking in the properties of each drive, that C is ntfs, and D is fat32. that's what windows told me. yes, the /dosc and /dosd directory exists. it is comepletely empty, but it does exist. i checked that right beofre i left for work.

the error, i can't reproduce exactly. but it essentially said it didn't exist, or no such type, or something like that, and then, it asked me

"don't you mean vfat?"
or "are you sure you don't mean vfat?"

it didn't ask for my response, it then said check the logs. and a check of the logs said pretty much the same thing.


but of course, the first stab i took at it, i tried it with vfab. i tried it for both drives, and it said that vfab was the wrong fs type.

Last edited by bowie101; 12-14-2005 at 09:14 AM.
 
Old 12-14-2005, 09:35 AM   #7
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 14.1
Posts: 1,138

Rep: Reputation: 55
Quote:
i confirmed, through windows, checking in the properties of each drive, that C is ntfs, and D is fat32. that's what windows told me.
Windows info won't help. You have to do
Code:
fdisk -l
and find out the exact disc/partition-number to be able to mount it. You get those errors mostly likely because you are trying to pass fs-type option to a wrong partition.

for example, if my /dev/hda1 partition is ntfs and I do
Code:
mount -t vfat -o rw /dev/hda1 /mnt/windows
it will give me the same error of wrong fs-type since my correct fs-type is ntfs.

Here's how I mount my vfat drive (manually via command line)
Code:
mount -t vfat -o rw /dev/sda3 /mnt/winshare
Here's my /etc/fstab entry...does the same

Code:
/dev/sda3 /mnt/winshare vfat users,rw,umask=000 0 0
Mine is a SATA disc, hence sda3 but yours would be different.

Hope that helps,
Tux,

Last edited by tuxrules; 12-14-2005 at 09:36 AM.
 
Old 12-14-2005, 09:40 AM   #8
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
and you use vfat even if it's fat32? what about these threads that someone pointed out to me?

http://www.linux-ntfs.org/content/view/127/63/
http://www.linux-ntfs.org/content/view/128/64/



btw, the master plan here is probably important to spell out.

i'm trying to get my newly aquired (but used and bought on ebay) US Robotics Sportster v.92 56k external modem to work with my linux HD so that I have internet access while in linux. to do that, I have to install the drivers. to do that, I downloaded some drivers via internet access on my windows HD. (and yes, the external modem is working fine with windows). so then i have to mount the drive, to access the drivers, and that's why i'm doing all this. but also, mounting my windows HD will probably come in handy very soon down the line.

but my immediate need is to get the modem to work in linux. and I assume that i need those drivers immediately, so i haven't even tried anything else when it comes to the modem. but maybe i should just do a fresh reinstall of fedora core 4 with the external modem all hooked up? and then it will automatically detect it?

i have no info to lose at this point, doing it that way. i've not done anything with my home box of linux yet. what do you think?

Last edited by bowie101; 12-14-2005 at 09:42 AM.
 
Old 12-14-2005, 09:51 AM   #9
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 725

Rep: Reputation: 33
Quote:
Originally Posted by bowie101
give me some examples of distrobutions and how do i find that out?

i'm using fedora core 4.


as for the first reply, i'll try that out when i get home in 8 hours . (it's the home computer)
No example is needed, you distro, the same as mine, is not support ntfs by default.
Visit linux-ntfs.sourceforge.net to see the help.
Vfat is the way linux call all type of fat, FAT16, FAT32, is call as vfat.
If your partition (partition not drive) is vfat, you don't need to specified -t vfat options, mount can realize that.
 
Old 12-14-2005, 09:57 AM   #10
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
ok, TruongAn. Thanks for that bit.
 
Old 12-14-2005, 10:17 AM   #11
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 14.1
Posts: 1,138

Rep: Reputation: 55
Check this out...I think your modem works in Linux without any driver. In any case, just do a google search for your modem on www.google.com/linux. That way you can be sure whether you need drivers for it.

Also those two links are for ntfs support in linux (in your case, Fedora). If you dont intend to read ntfs partition, you don't need it. I should tell you that Linux only has experimental write support NTFS file system so I would not recommend you to write to NTFS (reading is fine). That is the reason, people recommend a FAT32 partition since both Linux and Windows can read/write to it flawlessly.

Tux,
 
Old 12-14-2005, 10:25 AM   #12
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
yeah. thanks for that. the modem is at home, so again.. but it is the standard one that every one seems to use, i believe. so i'll check that out. i never knew that google link just for linux. wow.

but i do intend to read ntfs, so i'll continue.
 
Old 12-14-2005, 01:46 PM   #13
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
OK, so I'm going to ask my wife over the phone to go into linux (her first time) as root, (yes i trust her) and do the uname command to give exact configs. and give me the result. any other commands i should ask her to do?
 
Old 12-14-2005, 01:57 PM   #14
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 14.1
Posts: 1,138

Rep: Reputation: 55
Quote:
OK, so I'm going to ask my wife over the phone to go into linux (her first time) as root, (yes i trust her) and do the uname command to give exact configs. and give me the result. any other commands i should ask her to do?
exact configs??? uname command will only give you info about the type, name or architechture of the system. My guess is you want to know about partitions, if so then refer to my previous posts.

Tux,
 
Old 12-14-2005, 03:25 PM   #15
bowie101
Member
 
Registered: Nov 2005
Distribution: FC4 & RHES
Posts: 105

Original Poster
Rep: Reputation: 15
ok, so as best I could, I copied what she told me down...

there was apparently a lot of output when typing in fdisk -l, right? so, the first line is :

disk /dev/hda: 40.0 gb, 40020664320 bytes 255 heads, 63 sectors /track, 4865 cylanders


moving ahead to wherever it said "fat" or "ntfs" , i asked her to read that..

devise boot dev/hda5 start 4355 end 4864 blocks 4096543+ id B system Win95 Fat32

and then the other line..

dev/hda1 * start 1 end 4354 blocks 34973473+ id 7 system HPFS/ntfs

-------

so that's it for that. odd, b/c it's a windows 2000 OS, not 95.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting NTFS/fat32 partitioned hard drive (win2k) /when fedora4 runs on seperate HD bowie101 Linux - Hardware 4 12-14-2005 03:42 PM
NTFS - Mounting Hard Drive DarkD45 Linux - General 12 12-15-2004 12:58 PM
Hard drive partitioned and cannot view files Johnny2003 Linux - Newbie 4 01-20-2004 07:22 PM
Mounting an NTFS hard drive harperonline Linux - General 2 03-12-2003 11:11 AM
Mounting a FAT32 Hard Drive in Red Hat 7.2 using KDE egh128 Linux - General 1 03-17-2002 09:49 PM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration