LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-27-2004, 08:25 AM   #1
nowaydown1
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
Mounting NTFS drives on Fedora


Hello everyone:

I have a question regarding my Fedora installation and a small annoyance I have regarding it. I installed the rather popular NTFS module for my kernel version for Fedora Core 1 so I could mount my two IDE hard drives. No problems there. The module went in great, reads the drives fine. However, I'm fairly new to the linux scene so I'm not sure how to get those drives to mount as a user other than root. I edited my /etc/fstab to allow the user flag for mounting, but now they just automount under root. How can I configure my system so all users have access to these NTFS volumes and not just root? Thanks very much!
 
Old 04-27-2004, 08:51 AM   #2
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
If you still have the mount option "default" in there, than that may be causing your problem. I've been having headaches trying to give myself permissions to mount the drives, and what I learned so far is that the best things to have in your fstab's mount options are ro,user and sometimes noauto if you don't mind mounting your NTFS drive whenever you need it.

I'm just curious, what does your fstab for the NTFS drive look like?

edit

jeepers, I think I might need that NTFS driver myself. thanks for the idea. I'll try that tonight.


Last edited by ben_build#2.1.0; 04-27-2004 at 09:02 AM.
 
Old 04-27-2004, 09:08 AM   #3
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Try adding umask=0 to the list of options for your ntfs partitions in /etc/fstab then remount them
 
Old 04-27-2004, 06:25 PM   #4
nowaydown1
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Adding umask=0 to the drive options worked like a charm. Thanks for the input! Here's the /etc/fstab entry for those drives:

/dev/hdc1 /mnt/storage auto user,umask=0
/dev/hdd1 /mnt/storage2 auto user,umask=0

Thanks a lot!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting NTFS drives in SuSE Dunkalis Linux - General 3 08-03-2005 06:16 PM
how to mount NTFS drives on fedora core 2? laiju Linux - General 3 11-21-2004 04:51 PM
How to access NTFS/FAT drives from Fedora Core 2 lapierrem Linux - Newbie 4 06-16-2004 10:54 AM
Need help mounting drives in Fedora Core 1, please. mannymann Linux - Newbie 9 05-06-2004 11:40 PM
error when mounting ntfs drives ab84h Linux - Hardware 6 12-01-2002 02:47 PM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration