LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-13-2003, 03:59 AM   #1
lookformeb
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1 with KDE
Posts: 12

Rep: Reputation: 0
Mounting Issues


I hate to ask this question because I've noticed it arising often when I searched but I could not find a straight answer. I am just a few days old to the linux experience.

I was trying to make it to files I wrote on a floppy disk during a linux session could be viewed on a Windows session but after many different tried at editing the fstab, I gave up and reverted back to normal. Or should I say, what I thought was default. Now when boot up, it tells me there is an error on line 7 (the line I've been editing).

1. Can someone tell me what the trick is to transfering files over from Linux to Windows (vise versa) via floppy disk?
2. Please help me fix my fstab errror? Here is my fstab:

Code:
/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdb5 /mnt/archive vfat umask=000,defaults 0 0
none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0 fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdb1 /mnt/windows vfat umask=000,defaults 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0

Last edited by lookformeb; 11-13-2003 at 04:01 AM.
 
Old 11-13-2003, 04:28 AM   #2
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
Hi!
I see, you use the supermount feature.. I don't, but try this:
* comment the line 7 (add a '#' in the beginning of this line)
* add a line like this one (the one I have concerning to floppy):
Code:
/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,umask=0,sync,exec,codepage=850,noauto 0 0
now, when you need to use a floppy you can&must 'mount' it with
Code:
mount /dev/fd0
(for instance)
then do what you like and, when you've finished type
Code:
umount /dev/fd0
I believe this works; if not tell us (I cannot check it now )
I hope it helps
Regards
 
Old 11-13-2003, 04:32 AM   #3
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
...and also, you can visit the documentation: 'man fstab', 'man mount' and 'man supermount'
good luck
 
Old 11-13-2003, 05:20 AM   #4
lookformeb
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1 with KDE
Posts: 12

Original Poster
Rep: Reputation: 0
thanks Y0jiMb0 , that works perfectly!

does this solve the Linux to Windows issue too?
 
Old 11-13-2003, 05:45 AM   #5
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
I'm glad to hear it worked. It seems, it fixed the fstab problem, doesn't it?
Quote:
does this solve the Linux to Windows issue too?
Well, when I said...
Quote:
I believe this works; if not tell us (I cannot check it now )
... I was talking about the 'Linux to Windows issue'.
So, check it and post your results
Regards
 
Old 11-13-2003, 09:33 AM   #6
Lostman
Member
 
Registered: Nov 2003
Location: Chicago, IL
Posts: 238

Rep: Reputation: 30
What is Supermount? And how do I disable it/enable it? I'd like mount/unmount on my own to get in the habbit of it.
 
Old 11-13-2003, 09:43 AM   #7
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
Take a look on 'man supermount'; quite short and clear
Regards
 
Old 11-13-2003, 10:05 AM   #8
lookformeb
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1 with KDE
Posts: 12

Original Poster
Rep: Reputation: 0
Y0jiMb0 , it does appear to have solved the issue. I put a simple document from Linux onto a floppy and Windows read it fine. I see no reaason why it wouldn't work the other way around so thank you very much for helping me get this issue resolved so quickly!
 
Old 11-13-2003, 10:15 AM   #9
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
Great! It's a pleasure to help... when is possible.
Don't doubt, lookformeb; ask when you have troubles (well, after checking the man pages and searching in the forum )

Best regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to linux, so so lost, auto mounting issues, permissions issues slowhand22 Linux - Newbie 2 02-10-2005 10:41 AM
Issues mounting a HD moeru Linux - Hardware 5 07-03-2004 05:56 PM
mounting issues varunbihani Linux - Software 3 06-20-2004 04:43 PM
Mounting Issues MasterKin8T Linux - Software 3 09-06-2003 11:07 PM
cd mounting issues fractal_chaos Linux - Newbie 25 09-03-2003 07:32 PM


All times are GMT -5. The time now is 05:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration