LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-13-2007, 12:03 PM   #1
fultron
LQ Newbie
 
Registered: Apr 2005
Posts: 27

Rep: Reputation: 15
Mounting Hard drive partition as writable with -rw swich using mount command


I've been having problesm mounting /dev/hda2 as a read/write filesystem. I am pretty sure i am doing this right, and I have read the man file and googled for more information. Here is what i tried:

sudo mkdir /mnt/hda2
sudo mount /dev/hda2 /mnt/hda2 -rw
sudo chmod 777 /mnt/hda2

When I run the third command, I am told that the filesystem is mounted read only. Didn't the -rw switch mount it as read/write? What am I doing wrong?
 
Old 02-13-2007, 12:22 PM   #2
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Rep: Reputation: 30
hi,
-r switch for read only
-w switch for read/write

dont give both
so either give -w or -o rw

regards,
Tom.
 
Old 02-13-2007, 12:28 PM   #3
fultron
LQ Newbie
 
Registered: Apr 2005
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by nirmaltom
hi,
-r switch for read only
-w switch for read/write

dont give both
so either give -w or -o rw

regards,
Tom.

Thanks for the response tom.

However, mount /dev/hda2 /mnt/hda2 -w still only mounts the partition read only. same with -o rw

Is there any UI in UBUNTU to do this?

Last edited by fultron; 02-13-2007 at 12:41 PM.
 
Old 02-13-2007, 12:47 PM   #4
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Rep: Reputation: 30
hi,
is the filesystem ntfs?
if not,give the mount command as

mount -t <fstype> -o rw <devicename> <mountpoint>

if ntfs,u have to download ntfs-3g driver.
regards,
Tom.
 
Old 02-13-2007, 12:47 PM   #5
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
system - administration - disks.

Most of the time the auto detection feature works, but when in doubt specify the filesystem, like:
mount -t vfat ...
for example
 
Old 07-14-2012, 01:26 AM   #6
edcompsci
LQ Newbie
 
Registered: Jul 2012
Posts: 12

Rep: Reputation: Disabled
just a note about mounting sd cards

I was having nothing but trouble for the longest time mounting my sd cards with my usb card reader and thought it was either my internal hardware or just Linux to blame. Even after I switched to a newer motherboard (to take advantage of hardware virtualization) the usb card reader didn't work well. I also often suspected the usb hub I use was to blame but then trying bypassing it I could still have trouble.

So what hasn't giving me any trouble at all with the card reader is I got an internal 3.5" card reader which includes a usb port on it, and every single time I plug my card reader into the usb port on the internal card reader it picks it up in a matter of seconds. Still, though on this new internal card reader, the actual sd card reader included on it doesn't seem to want to read any sd cards. Still, I am happy, no more toying for minutes to hours trying just to access my files, and yes I was trying to mount command and the different switches, and chown and chmod and ls /dev | grep sd and df and getting pretty frustrated.


This is on Ubuntu Lucid 64bit.

Last edited by edcompsci; 07-14-2012 at 01:30 AM.
 
Old 08-14-2013, 01:30 PM   #7
bcyork
LQ Newbie
 
Registered: Dec 2010
Location: Chicago, IL
Distribution: Linux Mint 11 / Debian 6
Posts: 29

Rep: Reputation: 1
I'm trying to do the same thing and keep getting read-only file system

Have mounted the drive with:
mount -t hfsplus -o rw /dev/sde2 /mnt/machd
mount -t hfsplus /dev/sde2 /mnt/machd -rw
(The MAN documents specify rw as for read/write not w by itself under the 'Mount Options')

I've tried chmod 777 the mounted drive and still get a read-only directory. Logged in as root, Debian 6. Any solution that doesn't involve using fstab?

Thanks
Brian
 
Old 08-14-2013, 02:47 PM   #8
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,156

Rep: Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625
I don't use Debian but you might take a look at the link below. It's more likely a matter of not having the right programs installed to do this as Apple is notoriously proprietary. If the link below doesn't do it, I got a number of results from google with "hfsplus filesystem debian linux".

http://raamdev.com/2008/mounting-hfs...ess-in-debian/
 
Old 08-14-2013, 02:50 PM   #9
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,299

Rep: Reputation: 395Reputation: 395Reputation: 395Reputation: 395
Quote:
Originally Posted by fultron View Post
Thanks for the response tom.

However, mount /dev/hda2 /mnt/hda2 -w still only mounts the partition read only. same with -o rw

Is there any UI in UBUNTU to do this?
if the automagically mounter did not detect the drive then no.

what type of drive is this? hda is typically IDE connection.

what is the file system type? ext2/3/4, NTFS, FAT32, other?

answer those questions and we will be more then happy to help troubleshoot what is going on.

also have you verified that the device is labeled /dev/hda# either via fdisk -l or by monitoring /var/log/messages as you connect the drive if it is external, if it is internal you will still find it there, but you will have to dig much deeper to locate the data.
 
Old 08-14-2013, 06:13 PM   #10
bcyork
LQ Newbie
 
Registered: Dec 2010
Location: Chicago, IL
Distribution: Linux Mint 11 / Debian 6
Posts: 29

Rep: Reputation: 1
Hfs+ formatted 2.5" usb external drive
 
Old 08-14-2013, 08:11 PM   #11
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,299

Rep: Reputation: 395Reputation: 395Reputation: 395Reputation: 395
Quote:
Originally Posted by bcyork View Post
Hfs+ formatted 2.5" usb external drive
ok so its formatted for OSx.

As you have not stated the flavor of linux you are using but you are issuing sudo commands im guessing you are running Ubuntu:

Code:
1) sudo apt-get install hfsplus hfsprogs hfsutils

2) mount -o force -t hfsplus /dev/XXX /mnt/foo

3) Enjoy
a fast google search for Hfs+ mount read write in Ubuntu came up with the above answer.
 
Old 08-15-2013, 04:09 PM   #12
bcyork
LQ Newbie
 
Registered: Dec 2010
Location: Chicago, IL
Distribution: Linux Mint 11 / Debian 6
Posts: 29

Rep: Reputation: 1
Quote:
Originally Posted by lleb View Post
As you have not stated the flavor of linux you are using but you are issuing sudo commands im guessing you are running Ubuntu:
Did in my first post. Debian 6. Perhaps I shouldn't hijack an old thread that came up in searches to be helpful for someone later.

Already tried the -o force option and even though it worked. It killed SSH and couldn't connect after.

Last edited by bcyork; 08-15-2013 at 04:12 PM.
 
Old 08-16-2013, 06:56 AM   #13
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,299

Rep: Reputation: 395Reputation: 395Reputation: 395Reputation: 395
Quote:
Originally Posted by bcyork View Post
Did in my first post. Debian 6. Perhaps I shouldn't hijack an old thread that came up in searches to be helpful for someone later.

Already tried the -o force option and even though it worked. It killed SSH and couldn't connect after.
yes always a bad idea to hijack an other thread. well i will say this, HFS+ support in linux is more experimental then NTFS ever has been. i just use a mac and scp or rsync the data around that way i dont have to fight with the issues you are dealing with now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting USB drive as writable via Samba connections. SkipDaddy Slackware 1 10-03-2006 05:05 AM
Making a hard drive only writable to certain users, ro to everyone else. jon_k Linux - Software 3 05-23-2005 05:42 AM
mounting hard drive partition write for normal users jojotx0 Linux - Hardware 1 04-19-2005 12:10 PM
Having trouble mounting a vfat partition on my slave hard drive eyebrowsoffire Linux - General 27 10-10-2004 08:45 PM
Troubles with mounting hard-drive. Cannot even mount or access in root. eBopBob Linux - Hardware 4 08-19-2004 06:09 AM


All times are GMT -5. The time now is 03:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration