LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2004, 02:23 PM   #1
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Rep: Reputation: 30
Mounting fd0 in Slack 10


I feel sort of foolish for having to ask what seems the most basic of questions, but I've searched for the last 45 minutes and haven't found jack.

I've tried, oh....

# mount -t vfat /dev/fd0 /mnt/floppy
# mount fd0
# mount -t ext2 /dev/fd0 /mnt/floppy
...

and just about anything else I could think of, and it just spits out:

mount: wrong fs type, bad option, bad superblock on /dev/fd0, or too many mounted file systems

Is there something I'm doing wrong (I hope)?

Hopefully this will be a quick 1 user in and out question, I appreciate any help you can give!

Oh, and right now the floppy I have in the drive is the install.1 image off the slack 10 ftp CD ISO which I intend to format and transfer the swaret installer from this XP box to my linux one, if the filesystem make a difference.
 
Old 07-26-2004, 02:37 PM   #2
mijenks
Member
 
Registered: Mar 2004
Location: NY
Distribution: Gentoo
Posts: 112

Rep: Reputation: 15
try a 'mount -t auto <insert rest here>'

alternatively, see if there's an entry for fd0 in your fstab. if there is, just 'mount /dev/fd0' and you should be fine.
 
Old 07-26-2004, 02:47 PM   #3
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
# mount -t auto /dev/fd0 /mnt/floppy

/dev/fd0: Inupt/output error
mount: you must specify the filesystem type


fstab entry:

Code:
/dev/fd0     /mnt/floppy     auto     noauto,owner     0   0
I don't know what's up...

# mount /dev/fd0
gives the same error as above
 
Old 07-26-2004, 02:53 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Is it possible that your disk is corrupt? Maybe try loading it into another computer...
 
Old 07-26-2004, 03:11 PM   #5
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
could be... I put in a different disk, and the same thing happened....

well, got the

/dev/fd0: input/output error

line, and it's currently hanging....
 
Old 08-05-2004, 12:53 AM   #6
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
Exclamation

Still doesn't work...any help???
 
Old 08-05-2004, 01:06 AM   #7
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
'mount /mnt/floppy' should suffice when fstab is set up right.. Try umounting first. May be you switched disks on it and are trying to mount an already mounted device, though it usually freaks out more when you do that, if I recall.
 
Old 08-05-2004, 01:13 AM   #8
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Quote:
Originally posted by Diademed


Code:
/dev/fd0     /mnt/floppy     auto     noauto,owner,rw     0   0

Uh, try giving it read/write permissions!!
 
Old 08-28-2004, 08:32 PM   #9
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
Will that help?

Even when in the Dropline GUI, the Floppy doesn't seem to react to the dblClick on the floppy icon.....though extrapolating a bit, that seems like it doesn t matter... if it doesn't work in console, why should it in GUI?

ahh the noob I am.

could it be that the floppy drive is defective? I'm fairly certain that I have tried swapping out floppy drives on this computer, to no avail.

Right now I'm having some problems loading the kernel, but when I get that licked, I'll give it read/write permissions....but isn't it just the same as my CDROM entries? I think the read/write permissions are the same......

what could cause those errors though?

-dia

Last edited by Diademed; 08-28-2004 at 08:51 PM.
 
Old 08-30-2004, 12:43 AM   #10
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
(bump!)?? nobody?
 
Old 08-30-2004, 01:16 AM   #11
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
OK -- this is strange and it's time to start trying last ditch efforts. You say you've swapped floppy drives, so maybe try that again. Also try a different floppy cable in the rare event of a cable failure.
 
Old 08-31-2004, 01:56 AM   #12
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
haha, what luck. the Freak Linux Error 984412.127

must be a PEBCAK..

anyway, thanks, everyone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/fd0 not mounting linetnew Linux - Newbie 3 05-24-2008 01:14 PM
Mounting /fd0 in Mandrake 10.01 gmag Linux - Newbie 3 02-04-2005 05:10 AM
re: filesystem for mounting fd0 ergo_sum Linux - Newbie 4 11-08-2003 05:08 PM
Unexpected interrupt when mounting fd0 ugenn Linux - Newbie 0 04-24-2002 11:31 AM
mounting the fd0 noisejunkie Linux - Newbie 4 02-04-2001 01:12 PM


All times are GMT -5. The time now is 04:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration