LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2003, 03:47 AM   #1
subnet
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Rep: Reputation: 0
Mounting fat drives in fstab..


I have 2 fat drives (dualbooting windows) i want to mount correctly in fstab so my one user and root will have access on startup, so i dont have to mount these again....

What do i write in fstab???
 
Old 10-09-2003, 03:53 AM   #2
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Re: Mounting fat drives in fstab..

Quote:
Originally posted by subnet
I have 2 fat drives (dualbooting windows) i want to mount correctly in fstab so my one user and root will have access on startup, so i dont have to mount these again....

What do i write in fstab???
I don't know what distro you're using, but try something like:

/dev/hda1 /mnt/disk2 vfat auto,users 0 0

Means:

Mount hardisk 1 at partition 1 at mountpoint /mnt/disk2 with filesystem fvat, automatically at boot, and users are able to mount this device.

Hope this helps,
 
Old 10-09-2003, 04:59 AM   #3
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Here is an example for /etc/fstab:

Code:
/dev/hda6      /mnt/hd/games       vfat     auto,owner,rw,uid=0,gid=306,umask=0022,fmask=0133,dmask=0022,noexec  0  0
the 'uid' and 'gid' are the user-id, and group-id numbers. Use "id <username>" to get the value of a certain user, or inspect /etc/passwd and /etc/group yourself.

The umask the inverse of a file mask. (it's a mask )
0 = all allowed
1 = no execute (file) or browse (directories)
2 = no write
4 = no read
2 + 4 = 6 = no read+write

the fmask and dmask doesn't seam to work though for some reason, the files at the vfat drive are always marked as executable. (that's why I have the 'noexec' flag enabled too)

"man fstab" (console), or "man:fstab" (konqueror) could be a great help too
 
Old 10-10-2003, 04:02 AM   #4
subnet
LQ Newbie
 
Registered: Sep 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Well i think ill try both of the solutions on 2 differents fat drives...

thx for the help guys..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
having fstab-sync mount fat case-insensitive eliotstock Linux - General 9 06-05-2005 01:55 PM
/etc/fstab MOUNTING FAT PARTITION cb951303 Slackware 7 08-30-2004 09:07 PM
FreeBSD+fstab+fat partition krajzega *BSD 4 08-09-2004 04:05 PM
/fat-c permissions in fstab Ops Slackware 2 07-08-2004 11:43 AM
Automatically mounting drives with FSTAB caesius_01 Linux - Newbie 6 10-21-2003 12:10 PM


All times are GMT -5. The time now is 03:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration