LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2008, 02:24 PM   #1
bulalakaw45
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Mounting cdrom on DSL


I successfully installed and booted Damn Small Linux dsl-4.3.iso into a Toshiba Satellite 1605CDS laptop. However I am unable to mount the cdrom. The fstab file reads as follows:
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
proc /proc proc defaults 0 0
/dev/cdrom /mnt/auto/cdrom is09660 defaults,ro,user,noexec,noauto 0 0
/dev/fd0 /mnt/auto/floppy vfat defaults,user,noauto,showexec,unmask=022 0 0
#Added by KNOPPIX
/dev/hda2 /mnt/hda2 auto noauto,users,exec 0 0
When I entered the following as root in the command line" "mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom", I get the following error message:
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems
What does it all mean and what should I now do to mount the cdrom?
 
Old 05-04-2008, 02:50 PM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
First, is that a typo in the fstab file?

/dev/cdrom /mnt/auto/cdrom is09660 defaults,ro,user,noexec,noauto 0 0

If so, fix that first..

Next, I would identify which device is actually referenced by the "/dev/cdrom" symlink, for future reference, and also for use in the fstab file, for clarity.
For example, on my Toshiba laptop, some Linuxes see the DVD drive as "/dev/hdc" while other Linuxes have seen it as "/dev/sr0".. Once this has been clarified, I use that real name, rather than the symlink, to do mount operations on it.

NOW.. Assuming you identified the drive, or are still using /dev/cdrom because it is pointing to the right drive for sure, let's try typing "mount" in a console. This will make sure that the device is not already mounted (which it likely is not) and will tell us what exactly IS mounted.

OK, getting right to the issue now: The error you got is telling us, among other things, that the filesystem is wrong. try adding "udf" as an alternate filesystem, in the fstab file, like:

/dev/cdrom /mnt/auto/cdrom iso9660,udf defaults,ro,user,noexec,noauto 0 0

and see if that helps. Not all discs are ISO9660; some are udf, depending on the format.
 
Old 05-04-2008, 04:37 PM   #3
bulalakaw45
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
The iso09660 is indeed a typo. Sorry about that.
I tried your advice. I changed the entry in the fstab and then I tried to mount the cdrom two-ways: using -t iso9660 and using -t udf. In both cases I still got the same error message: "mount: wrong fs type, bad option, bad superblock or /dev/cdrom, or too many mounted file systems"
By the way, when I ran the command mount, I got the following:
dev/hda1 on / type ext3 (rw,errors=remount-ro)
/proc on /proc type proc (rw)
/dev/pts on /dev/pts type devpts (rw)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
As you prediced there was no cdrom mounted.
I also read the /etc/filesystems file. This is what I found there
ext3
ext2
so9660
reiserfs
vfat
msdos
xfs
ntfs
minix
hfs
I did not find any udf.
I also read the /dev directory. I found entries for cdrom, sr0 and hdc.How do I know which of these refer to the cdrom? However when I used sr0 insted of cdrom in /dev/sr0 I got an error message.
Anything else you suggest I do? Thanks for your note.
 
Old 05-05-2008, 05:52 PM   #4
bulalakaw45
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Following the advice of GrapefruiTgirl, I permutated the various ways by which I may be able to mount the cdrom on a Toshiba105CDS laptop running Damn Small Linux dsl-4.3.iso. The following commands worked:
"mount -t auto -o ro /dev/scd0 /mnt/auto/cdrom" When I rat the command mount the following line showed that the cdrom was indeed mounted:
/dev/scd0 on /mnt/auto/cdrom type udf (ro).
When I checked the files, they were were visible with the file manager. In sum using "auto" as the file type, denoting the device as "scd0" and mounting at "/mnt/auto/cdrom" did the proverbial trick.
 
Old 05-05-2008, 08:48 PM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Excellent, good work

So, the actual device is /dev/scd0 and the mount point is /mnt/auto/cdrom. In my fstab file, if it were me, I would use the actual device /dev/scd0 name, rather than the /dev/cdrom or whatever symlink, though it's your choice; it just makes it simpler using the actual device, not to mention the issue of the permissions of each/every symlink in the path.
For the record, the mount point as you probably know, can be anywhere you want, as long as the folder exists before trying to mount something on it.
NOTE: using the 'auto' filetype works much of the time, but it *can* make mistakes. The typical usage for 'auto' is for a floppy drive, which might be vfat, fat16, msdos, or whatever else floppies could be; for CD and DVD, using "udf,iso9660" is the best IMHO, as these are the two main filetypes of this media.

Finally, it is worth mentioning that once a device is listed in the fstab file, you can mount it much easier. For example, if you have /dev/scd0 listed in your fstab file, you can simply type:
Code:
mount /dev/scd0
and the system will read the fstab file to determine what to do with that device. In other words, you need not specify the options, filetype, mount point, etc..

Cheers

Sasha
 
Old 05-12-2008, 09:06 AM   #6
bulalakaw45
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
How do I mount a cdrom with a read-write option?

I have a further question on mounting cdrom. Recall that I used the option -o ro (that is to say, read only). Now how do I go about making DSL recognize a read-write option. If I put the command "mount -t auto -o rw /dev/scd0 /mnt/cdrom" I get the message: "mount: block device /dev/scd0 is write protected, mounting read-only". What should I do now to remove the write protection to enable me to write to the cdrom? Thanks in advance for your further help.
 
Old 05-12-2008, 10:35 AM   #7
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Mounting a CD or DVD read-write is not as simple as one would like to have it, at least not initially.

Writing to a CD under Linux (and probably other OS's) happens at least two ways: "burning a CD" or by using "packet-writing".

Burning a CD is usually done with the 'cdrecord' command (which if I remember right, is part of the cdrw-tools package). When a CD or DVD is burned, it ends up having a iso9660 filesystem burned onto it. Some software, like K3B, provides a GUI frontend for the cdrecord command, but you may prefer to just use the cdrecord command from a command line.

Packet-writing is done using a special block device called a "packet device", which points to your CD-RW hardware. Packet-writing produces a UDF filesystem, and it produces a CD that can be mounted sort of like a floppy disk, which you can then read from, and write stuff to, and delete stuff from, by mounting it rw. The software needed to do packet-writing is included in the package "udf-tools".

Linux will not mount just any old CD or DVD read-write; it must be a UDF formatted packet-written disc.

I wrote a thread some time ago around here, about how I set up packet-writing on my Slackware system, and I will provide you the link. NOTE that your DSL may or may not include the udftools package by default, in which case you will want to download it and install it. Do that, and read the instructions and readme file(s) carefully, and thoroughly read my thread about setting up packet-writing devices.

If you do the above, and either get stuck or cannot figure something out, feel free to come back here and tell us what you have accomplished so far, and what the trouble seems to be, and I/we will try to get it sorted out with you.

Now, let me find that thread...
ok.. Here:
http://www.linuxquestions.org/questi...et+writing+udf

..and at post#5 is where I got it working. I doubt a whole whack has changed with packet-writing since that thread (and I still use my packet-writer the same way today) but check that out, and if you get confused or have trouble, let us know.

Sasha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM mounting problem => /dev/cdrom is not a valid block device Vizy Linux - Hardware 8 11-04-2010 05:46 PM
ecia dsl and usbfs mounting snitko Linux - Networking 0 01-21-2007 07:49 AM
Installing DSL on a TP560x w/o bootable CDROM/USB Jefcard DamnSmallLinux 12 12-13-2006 02:14 AM
Mounting cdrom adds2one Slackware 2 11-28-2005 05:41 AM
mounting cdrom binboy35 Debian 8 11-06-2004 12:22 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration