LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2005, 02:21 AM   #1
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Rep: Reputation: 0
mounting CD-rom on laptop linux


Hello,

I installed debian 2.2.20 v3.0 on my old Dell Latitude LM Laptop 166Mhz Pentium with MMX.

There's only one bay/slot for either the floppy drive or the CD-rom. If I want to use one or the other, I need to swap the drives after I shutdown my computer, then restart.

Here's the problem. I initially installed linux thru the internet using the floppy drive and an Ethernet connection, so the laptop works just fine with the floppy drive.

I can't seem to get the laptop to work with the CD-rom. I first simply swapped drives and rebooted to see what happens. The laptop seems to have mounted the CD-rom. A little CD-ROM 0 icon shows up on my Gnome GUI. If I double click that icon or right click to mount the device, I get the following message:

mount: special device /dev/cdrom does not exist

I'm a total newbie with linux, so I may be using the mount command wrong.

Ultimately, I'd like to have the laptop setup, so that it will recognize the floppy drive or CD-rom drive during boot.

Any assistance would be appreciated.

Thanks,

awu
 
Old 05-11-2005, 02:46 AM   #2
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
/dev/cdrom is probably not correct... but I have been wrong many times before...

Try to open a terminal and login a root:

$su
password:
#cat /etc/fstab

Here is a sample of my /fstab file. Look on your file for refrences to cdrom then at the begining of the line is the dev point like /dev/hdc or /dev/hdd:

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0

What ever yours is, use that to mount the cdrom like:

#mount /dev/hdc /mnt/cdrom
#exit

If you don't get any errors then you can go ahead and use the file mgrs to access the drive.

KC
 
Old 05-11-2005, 11:26 PM   #3
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by kencaz
/dev/cdrom is probably not correct... but I have been wrong many times before...

Try to open a terminal and login a root:

$su
password:
#cat /etc/fstab

gives me my fstab file:

<file system> <mount point> <type> <options> <dump> <pass>
/dev/hda2 / ext2 errors=remount-ro 0 1
/dev/hda3 none swap sw 0 1
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user, noauto 0 0
/dev/cdrom /cdrom iso9660 ro, user, noauto 0 0

the command

#mount /dev/cdrom

or

#mount /dev/cdrom /cdrom

gives me this error

mount: special device /dev/cdrom does not exist

anyone else have any ideas?

thanks in advance.
 
Old 05-11-2005, 11:45 PM   #4
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
This old LQ thread seems to address your problem...

http://www.linuxquestions.org/questi...04/11/2/204299

KC
 
Old 05-11-2005, 11:47 PM   #5
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Solus
Posts: 2,254

Rep: Reputation: 47
Ok, this may sound like a dumb question, but you do have a cdrom in the drive, right? I've seen this error when trying to mount an empty cdrom drive.

Barring that, the device does actually work? It sounds like it isn't reading.
 
Old 05-12-2005, 01:13 AM   #6
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Perhaps fstab is not referencing the correct device for your cdrom. Presuming you have the necessary kernel support installed, try booting your system with your cdrom in, then go to /proc:

#: cd /proc

Then look for your cdrom in the appropriate folder; presumably it will be under the ide folder.

For example, I am in the middle of configuring Slackware 10.1 on the infamous Sony PCG-C1XS (the really tiny one with the PCMCIA cdrom, the USB floppy, and the built-in camera) so let's see if we can find the floppy:

/proc#: cd scsi
/proc/scsi: dir
device_info scsi usb-storage/
/proc/scsi: cat scsi
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: Y-E DATA Model: USB-FDU Rev: 1.28
Type: Direct-Access ANSI-SCSI revieion: 02

This tells us that the floppy is on /dev/sda, so let's change the fstab to:

/dev/sda /mnt/floppy auto noauto, owner 0 0

Finding the cdrom will be fairly similar, but with one or two very important differences:

/proc#: cd ide
/proc/ide#: dir
drivers hda@ hde@ ide0/ ide2/

Notice the softlinks "hda" and "hde". Let's see what they're linked to (I'm going to leave out part of the listing because I have to enter this by hand):

/proc/ide#: dir -l
...2005-05-11 22:50 drivers
...2005-05-11 22:50 hda -> ide0/hda/
...2005-05-11 22:50 hde -> ide2/hde/
...2005-05-11 22:50 ide0
...2005-05-11 22:50 ide2

Obviously, "hda" is the harddrive. Let's see what "hde" is:

/proc/ide#: cd hde
/proc/ide/hde#: dir
driver identify media model settings
/proc/ide/hde#: cat media
cdrom

So the cdrom has been assigned to /dev/hde, and not to /dev/cdrom. We won't change fstab to reflect this assignment like we did with the floppy because many, if not most, of the audio cd players have been pointed to /dev/cdrom, so we'll avoid any possible problems by softlinking /dev/hde to /dev/cdrom (according to your posts, it appears that /dev/cdrom hasn't been created yet, if it has, rm it):

/proc/ide/hde#: ln -s /dev/hde /dev/cdrom

If we now go to /dev, we should see cdrom@ amongst the four hundred or so other devices.

We can now mount the cdrom by typing:

/proc/ide/hde#: mount /dev/cdrom

or

/proc/ide/hde#: mount /cdrom

Remember, we mount filesystems, not devices, so don't try to mount audio cd's, there's no filesystem to mount! You just point the cdplayer at the device and hit play!

Hope I helped.
 
Old 05-12-2005, 04:18 AM   #7
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by masonm
Ok, this may sound like a dumb question, but you do have a cdrom in the drive, right? I've seen this error when trying to mount an empty cdrom drive.

Barring that, the device does actually work? It sounds like it isn't reading.
all things are possible with a newbie.

i followed charred's directions below and got pretty far. to answer your question, if i try mounting the cdrom without a cd in the drive, i get the following error:

mount: no medium found

which sounds like the appropriate error.
 
Old 05-12-2005, 04:49 AM   #8
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Charred
Perhaps fstab is not referencing the correct device for your cdrom. Presuming you have the necessary kernel support installed, try booting your system with your cdrom in, then go to /proc:

Hope I helped.
thanks. following your suggestions i got pretty far. but i'm not quite there yet.

#dir /proc/ide
drivers hda hdb ide0

#dir /proc/ide -l
drivers
hda -> ide0/hda
hdb -> ide0/hdb
ide0

#dir /proc/ide/hdb
capacity driver identify media model settings
#cat /proc/ide/hdb/media
cdrom

so my cdrom appears to be assigned to /dev/hdb

i was able to softlink as described using the below command

/proc/ide/hdb#: ln -s /dev/hdb /dev/cdrom

when i tried to mount the drive with a fat32 file system (and then with a music CD) in it, i received the following error including the question in parenthesis:

#mount /cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems (aren't you trying to mount an extended partition instead of some logical partition inside?)

i started to check out the thread posted by kencaz in post#4 of this thread. i will post the interesting findings i just got with

#dmesg
 
Old 05-12-2005, 04:52 AM   #9
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 34
My first question is does /cdrom exist? It sounds like that is your mount point.

I'd try this:

Code:
mount /dev/hdb /cdrom
 
Old 05-12-2005, 05:18 AM   #10
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by kencaz
This old LQ thread seems to address your problem...

http://www.linuxquestions.org/questi...04/11/2/204299

KC
thanks for the link. i've just run the dmesg command and have some interesting verbose messages from during boot. I'll be editing/shortening the mesg as I'm typing the output. i haven't quite figured out why my cut-and-paste in terminal only pastes the first letter of my text selections. my own comments are in between the {} brackets.

#dmesg

{skipped some stuff}
hda: HITACHI DK23AA-60, ATA DISK drive
hdb: {crazy cyrillic text for model type}, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: HITACHI DK23AA-60, 5729MB w/512kB Cache, CHS=776/240/63
hdb: ATAPI 116X DVD-ROM drive, 65408kB Cache {i'm pretty certain my hardware is not a DVD-ROM drive}
Uniform CD-ROM driver Revision: 3.11
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
{skipped more stuff}
VFS: Disk change detected on device ide0(3,64)
{this appears to be where my computer is detecting that i swapped out the floppy drive with the cdrom drive}
Unable to identify CD-ROM format.
Unable to identify CD-ROM format.
ATAPI device hdb:
Vendor-specific Error: (reserved) -- (Sense key=0x0f)
(vendor sepcified error) -- (asc=0xff, ascq=0x01)
The failed "Test Unit Ready" packet command was:
"00 00 00 00 00 00 00 00 00 00 00 00 "
cdrom: open failed.
ATAPI device hdb:
Vendor-specific Error: (reserved) -- (Sense key=0x0f)
(vendor sepcified error) -- (asc=0xff, ascq=0x01)
The failed "Read Cd/Dvd Capacity" packet command was:
"25 00 00 00 00 00 00 00 00 00 00 00 "
VFS: Disk change detected on device ide0(3,64)
{skipped repeated detection attempts}
Unable to identify CD-ROM format.
Unable to identify CD-ROM format.
VFS: Disk change detected on device ide0(3,64)
hdb: command error: status=0x51 (DriveReady SeekComplete Error)
hdb: command error: status=0x54
end request: I/O error, dev 03:40 (hdb), sector 64
ATAPI device hdb:
Vendor-specific Error: (reserved) -- (Sense key=0x0f)
(vendor sepcified error) -- (asc=0xff, ascq=0x01)
isofs_read_super: bread failed, dev=03:40, iso_blknum=16, block=32
{skipped repeated detection attempts}

whew! that took a bit to type. this is rapidly getting very complicated, but i'd still like to stick this problem if anyone still has any suggestions.

thanks in advance.
 
Old 05-12-2005, 05:35 AM   #11
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by n0xvb
My first question is does /cdrom exist? It sounds like that is your mount point.

I'd try this:

Code:
mount /dev/hdb /cdrom
thanks. i just tried the command yielding this message:

mount: error while guessing filesystem type
mount: block device /dev/hdb is write-ptotected, mounting read-only /dev/hdb: Read-only file system
mount: you must specify the filesystem type

#mount /dev/hdb /cdrom -v
mount: error while guessing filesystem type
mount: you didn't specify a filesystem type for /dev/hdb. I will try all types mentioned in /etc/filesystems or /proc/filesystems
Trying msdos
mount: block device /dev/hdb is write-ptotected, mounting read-only /dev/hdb: Read-only file system
mount: you didn't specify a filesystem type for /dev/hdb. I will try all types mentioned in /etc/filesystems or /proc/filesystems
Trying msdos
Trying vfat
mount: you must specify the filesystem type

The CD-rom mechanism appears to spin and rev up as it tries to determine filetype, but I'm not certain if that's the problem or something in my dmesg is the source?

Last edited by awu72; 05-12-2005 at 05:36 AM.
 
Old 05-12-2005, 05:39 AM   #12
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 34
Quote:
Originally posted by awu72
thanks. i just tried the command yielding this message:

The CD-rom mechanism appears to spin and rev up as it tries to determine filetype, but I'm not certain if that's the problem or something in my dmesg is the source?
Cool. What kind of disc do you have in the drive?

Let's go the next step and specify a common cd type:
Code:
mount -t iso9660 /dev/hdb /cdrom
 
Old 05-12-2005, 05:54 AM   #13
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by n0xvb
Cool. What kind of disc do you have in the drive?

Let's go the next step and specify a common cd type:
Code:
mount -t iso9660 /dev/hdb /cdrom
i've tried two types of disk. one is just an audio CD, the other is a CD with partitionmagic on it. i think it's FAT32 or iso9660.

here's the mesg i get after the code with the partitionmagic CD:

#mount -v -t iso9660 /dev/hdb /cdrom

mount: block device /dev/hdb is write-ptotected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems (aren't you trying to mount an extended partition instead of some logical partition inside?)

the drive spins as it tries to execute the command. when using the audio CD (the corrs), i get the same message but the drive spins but doesn't rev up like with the other CD. without a disk in there, it expectedly reports:

mount: block device /dev/hdb is write-ptotected, mounting read-only
mount: medium not found


i'm gonna grab an hour or two if sleep. i'll check back on this later today. thanks for your help so far.
 
Old 05-12-2005, 07:12 AM   #14
n0xvb
Member
 
Registered: Sep 2004
Location: 127.0.0.1
Distribution: Slackware 13; openSUSE 11.2
Posts: 255

Rep: Reputation: 34
Well, I think that your hardware is not configuring correctly by the output of your dmesg command.

Here's a couple commands for you to try (put a cd in the drive first and you'll need to be root):

Code:
cd /dev
ls -la hdb
It should return something like this:
brw-rw---- 1 root disk 3, 64 2002-06-09 13:27 hdb

The date and time we don't care about, but the beginning of the line is important. The initial b indicates it is a block device, the major and minor numbers are 3 and 64.

If this is correct, then try this command:

Code:
cat /dev/hdb | od | more
Hopefully you'll get a formatted table of raw data.

If these worked then the problem is in the format of the disk. If either didn't work then we can try deleting and re-creating the dev file.
 
Old 05-12-2005, 09:48 PM   #15
awu72
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian 2.2.20
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by n0xvb
Hopefully you'll get a formatted table of raw data.

If these worked then the problem is in the format of the disk. If either didn't work then we can try deleting and re-creating the dev file.
/dev# ls -la hdb

gave me the correct output

brw-rw---- 1 root disk 3, 64 Mar 14 2002 hdb

cat /dev/hdb | od | more

gave me this

0000000

Re-creating the dev file may be the way to go, but I'm wondering if we get the cdrom drive to work, we may end up fouling up the floppy drive. Conceptually, I think part of the problem resides around the fact that the cdrom drive occupies the same physical space and connections as the floppy drive in this old laptop, so I think the solution revolves around getting the software to know what to do when it finds the cdrom where it expected to find the floppy. It shouldn't be any different (conceptually) than the laptop recognizing different USB or PC Card devices that have been swapped. Am I making any sense?

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux on laptop without cd-rom michaeltweak Linux - Laptop and Netbook 7 07-02-2004 03:58 PM
Install linux on a laptop with no CD-ROM? stickben Linux - Laptop and Netbook 3 05-03-2004 10:40 PM
Linux FOR old laptop 386/486 CPU w/ no CD rom drive studpenguin Linux - Laptop and Netbook 6 04-25-2004 10:57 PM
Installing Linux on a laptop w/ no floppy or CD-ROM? jordan0 Linux - Laptop and Netbook 9 04-11-2004 05:42 AM
I have an old laptop w/o a CD-ROM and I want to install Linux... HGeneAnthony Linux - Hardware 3 04-15-2003 09:40 PM


All times are GMT -5. The time now is 05:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration