LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-28-2004, 03:15 PM   #1
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Rep: Reputation: 0
Mounting CD problem : No dev/cdrom ?


HI,
I am trying to install fedora on virtual pc, and to get it running i need to copy some updated files i have on a cd. My problem is i cant seem to find out what to mount in order to get the CD working.

I know the drive is working, cuz i booted using rescue CD.

the files i needed copied is in my cd , labelled core3.iso

I used the command dmesg and found this :
hdc : Virtual CD, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI DVD-ROM drive, 128kB Cache, DMA

Now how do i mount this core3.iso?
Do i need to unmount the rescue CD first? but where is it located?

My root is currently ./mnt/sysimage
I understand the command is:
mount -t iso9660 /dev/cdrom (destination)

But there is no such a thing as /dev/cdrom

PLS help! i have been hammering at this for hours, i dont even remember what other commands i inputted...I think i even tried with the label :
mount -t iso9660 core3.iso /haha
and it returns with mount: special device core3.iso does not exist.

I am at my wits end, and I am a complete idiot in linux to boot with , so it doesnt help. I need a step by step suggestion...
thanks so much!
 
Old 11-28-2004, 03:57 PM   #2
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
You have loaded the rescue cd into the cd-rom drive and so you cannot umount it. To mount, it's like:

mount <device> <destination>...so it would be 'mount /dev/cdrom /mnt/cdrom' (make sure /mnt/cdrom exists)

-twantrd
 
Old 11-28-2004, 04:43 PM   #3
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Hi, thanks for the reply..

What doesnt seem to exist is /dev/cdrom .
I cant find /dev/hdc either.

So, the <device> doesnt seem to exist. But I know it does, cuz i booted from rescue CD.

any suggestion?
 
Old 11-28-2004, 09:29 PM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,887

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Examine the contents of /etc/fstab, which lists the partitions/devices to be automagically mounted on boot (or manually). If /dev/cdrom isn't listed, you won't be able to mount it. Add a line like this to fstab:

/dev/cdrom /mnt/cdrom auto ro,noauto,user,exec 0 0 (/dev/cdrom is the device to mount, and /mnt/cdrom is the mount point. If /mnt/cdrom doesn't exist, create it with the command 'mkdir /mnt/cdrom'. You will probably need root permission to do that).

If you're using SuSE, the prefered mount point is /media/cdrom instead of /mnt/cdrom.

Then, to manually mount the cd drive, open a term and give this command:

mount /dev/cdrom (the disk must be in the drive or you will get an error message).

Then go to your file manager and click on the /mnt (or /media folder if using SuSe) and click on the /cdrom folder to see the contents of the cd in the drive.

Last edited by bigrigdriver; 11-28-2004 at 09:33 PM.
 
Old 11-28-2004, 10:33 PM   #5
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
how to add a line to fstab?

I am sorry, complete newbie here...
How do I add a line to fstab?

thanks !

Ps: I am using fedora, and in rescue mode..so its all textbased.

Last edited by linuxdumbnoobie; 11-28-2004 at 10:35 PM.
 
Old 11-28-2004, 11:20 PM   #6
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
I don't know what commands you will be able to use in your rescue mode, but here is
what you can try:

First make sure you're root -- I imagine you already are, if you're, in effect, installing the system.

Then do this:

cp /etc/fstab /etc/fstab_good

(or use some other name; the idea is to copy the existing fstab file so you don't lose the existing contents
if you mess up somehow altering it as below)

Then try:

vi /etc/fstab

Or instead of vi it might be vim on your system. Chances are they're both there. This is a simple text editor
available on virtually every Linux distribution.

Once you see the contents of /etc/fstab in the editing window, press INSERT key to go into editing mode.

Then use the arrow keys to go to where you want to add the line suggested by the other poster.

Write it in, and be sure to hit RETURN at the end of the line to finalize that line.

Then if you're satisfied with what you did, press ESCAPE and then COLON and then the w key and then the q key.
This causes the editor to exit editing mode and to write (w) and then quit (q).

Now you should have your revised /etc/fstab file and you can try it out.

I hope this works for you.

(If you have to replace the altered fstab file, just go "cp /etc/fstab_good /etc/fstab" and say "y" if prompted
to agree to overwriting the altered file.)
 
Old 11-28-2004, 11:53 PM   #7
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
sniff. didnt work.

Thanks for the suggestions, but it didnt work. This is how my fstab looks like :


/dev/VolGroup00/LogVol00 ext3 defaults 11
Label=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol101 swap swap defaults 0 0

I added the line below the 3rd line..but when mounting, it returns:
mount: special device /dev/cdrom does not exist.


Last edited by linuxdumbnoobie; 11-28-2004 at 11:56 PM.
 
Old 11-29-2004, 12:18 AM   #8
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
try cd'ing into /dev and seeing if there is anything resembling a cdrom in there. i know in Gentoo it's /dev/cdroms/cdrom0 but i'm not sure about fc2. I also know fc3 uses /media/cdrom like SuSE.
 
Old 11-29-2004, 12:25 AM   #9
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Can you view the contents of your /dev directory and see if there's an entry for cdrom?

And is there an entry there for hdc?

And what do you get if you go: "ls /mnt/cdrom"? Does the directory /mnt/cdrom exist? It can be used as a mount point.

If not, you can mkdir /mnt/cdrom (assuming the /mnt directory exists...) or mkdir /mnt and then /mkdir /mnt/cdrom (if /mnt didn't exist beforehand) and then, assuming /dev/cdrom exists, you can try "mount -t iso9660 /dev/cdrom /mnt/cdrom" and see if that enables you to get your drive recognized. Or if the device "hdc" exists but "cdrom" doesn't, replace /dev/cdrom with /dev/hdc and see if that works.

That's about all I can think of to do at this point... You may have already tried all this.

(Edit: apparently bornhj and jonr had about the same idea at the same time, 25000 miles apart... )

Last edited by jonr; 11-29-2004 at 12:35 AM.
 
Old 11-29-2004, 01:59 AM   #10
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
thanks guys..

nope, there is no such thing as /dev/cdrom or /dev/hdc

When i do dmesg, i see that hdc: Virtual PC ATAPI CD-rom, but then a little below, it says, CD-ROM format not recognizable.
I am not sure how to make it recognizable, and i am not sure why its not recognizable, seeing i am booting from it.
Any way to make it recognizable?
thanks again guys
 
Old 11-29-2004, 02:29 AM   #11
bornhj
Member
 
Registered: Sep 2004
Location: Canberra, Australia
Distribution: Fedora Core 3, Ubuntu Hoary, Slack 10.1
Posts: 120

Rep: Reputation: 15
ok. are you using Microsoft Virtual PC or something else? look for the CDROM settings and poke around in there. i.e. in VMware there are settings concerning what type of CDROM it should be etc.

P.S. amazing how great minds think alike jonr!

Last edited by bornhj; 11-29-2004 at 02:30 AM.
 
Old 11-29-2004, 05:11 AM   #12
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Nope. I was reading about VMware and it seems to be more friendly in terms of linux.
I finally gave up and looked up some other distro.....suse worked on first try! wow. I think i will stick with this one until i am a bit more familiar with linux. Thanks for helping guys!
 
Old 11-29-2004, 08:20 AM   #13
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by linuxdumbnoobie
thanks guys..

nope, there is no such thing as /dev/cdrom or /dev/hdc

When i do dmesg, i see that hdc: Virtual PC ATAPI CD-rom, but then a little below, it says, CD-ROM format not recognizable.
I am not sure how to make it recognizable, and i am not sure why its not recognizable, seeing i am booting from it.
Any way to make it recognizable?
thanks again guys
Suse must be very different from Mandrake. If you're seeing a reference to "hdc" I would think a /dev/hdc HAD to exist. I'm completely puzzled.

Also, that "format not recognizable" makes me wonder if it's a problem with hardware recognition; I know various distros have had trouble with detecting the actual nature of some CD-ROM drives. (And there's the famous problem of Mandrake actually destroying a certain brand's firmware--by accident--a problem now resolved. There are numerous threads here about that; I can't remember the name of the drive.)

But it looks like your distro is seeing the drive OK but doesn't know what to make of it. While that still doesn't explain the absence of "hdc" in the device table, it's beginning to sound to me like something beyond file configuration...

Have you got a local Linux group you could take this to? Meanwhile, anybody else here, such as a moderator/guru with 10,000 posts to his/her credit, got any ideas?
 
Old 11-29-2004, 01:18 PM   #14
linuxdumbnoobie
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Nope,

i been asking around and posted this question in another forum as well. It seems no one really knows what to make out of it. I am sure not actually looking at my screen doesnt help diagnosing it either.

I think you are right, about my distro cant figure out what to make out of the cd-rom. I tried using floppy images, and they worked fine, I have fd0 in the dev, and it works just fine. Just the cd-rom is giving me a headache.

It would be great if someone can tell me how to fix it, I still have the installation in my virtual pc saved at the error spot (its the advantage of virtual pc, I can have several os going together at the same time and take snapshots of them at various stages), so i am open to any suggestions

thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 11:37 AM
CDROM mounting problem => /dev/cdrom is not a valid block device Vizy Linux - Hardware 8 11-04-2010 04:46 PM
mounting CD, CDRW... /dev/cdrom -> /dev/hda kersten78 Slackware 9 09-23-2004 11:53 PM
mounting 2 ide-scsi devices /dev/cdrom and /dev/cdrom1 issue penguin123 Linux - Hardware 3 09-26-2003 08:36 PM
Mounting dev/cdrom jeevana Linux - General 2 11-28-2001 05:49 PM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration