LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2003, 10:32 AM   #1
evilmonkey
Member
 
Registered: Jun 2003
Location: Toronto, Canada
Distribution: Ubuntu 10.04 LTS; CentOS 5.5
Posts: 199

Rep: Reputation: 30
Mounting CD-Devices


Hello.

I have just installed Mandrake 9.0 and i want to mount my CD Device. In the "Device" portion, I wrote /dev/scd0. I know this is correct because when I right-click the ico, and press "Eject", it works fine. However, when I click to browse the files, it's not showing any, but the cd is clearly inside. I don't see my CD light flashing or anything. What is wrong? Is it me?



Thanks.
 
Old 06-14-2003, 12:29 PM   #2
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
you can not mount an audio cd. it sounds like that's what your trying to do.

if you want to see what you have in it then use grip.

cheers.
 
Old 06-14-2003, 08:35 PM   #3
evilmonkey
Member
 
Registered: Jun 2003
Location: Toronto, Canada
Distribution: Ubuntu 10.04 LTS; CentOS 5.5
Posts: 199

Original Poster
Rep: Reputation: 30
Emitib: Uh-uh.

It's a data CD, in fact, it's a Linux native. Allow me to start from the beginning.

I'm in KDE (This is Mandrake 9.0). I right-click in an empty desktop area and press new CD-ROM device. I enter the name (shouldn't make a difference), and in "Device" I enter /dev/scd0. It creates me an icon on my desktop, which I can (theoretically) just click. I click it and Konqeror comes up. It tries to direct me to some website (for whatever reason). When I right click the icon and press eject however, it ejects fine. I try right-click>mount and nothing happens.

This is the exact same with my floppy and DVD.

Any ideas anyone?

Also, does Linux have Drive letters like Windows?

Cheers!
 
Old 06-14-2003, 09:13 PM   #4
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
No. Linux doesn't use drives like windows...
ok first try to post your fstab...


heres how:

gedit /etc/fstab
then copy paste
 
Old 06-14-2003, 10:05 PM   #5
contrasutra
LQ Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
have you tried manually mounting it:

"mount /dev/scd0" , if an error comes up, post what it is.
 
Old 06-14-2003, 11:10 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,266

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
Mandrake by default installs supermount where you don't have to use the mount / umount commands. Just stick in the CD or floppy and use Konqueror or whatever to browse.

The installer should of created an icon on the desktop called removable media. Inside that folder should be your icons for floppy cdrom and which is probably labeled as cdrom2.
 
Old 06-15-2003, 11:24 AM   #7
evilmonkey
Member
 
Registered: Jun 2003
Location: Toronto, Canada
Distribution: Ubuntu 10.04 LTS; CentOS 5.5
Posts: 199

Original Poster
Rep: Reputation: 30
Yes, I hear Mandrake 9.1 has that. I'm upgrading tommorrow. Till then, I'm back to Windoze. If I have any further problems, I'll post.

Thanks everyone.

Cheers!

~Jack.
 
Old 06-16-2003, 04:01 PM   #8
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Rep: Reputation: 15
biteme wut do u mean u can't mount audio cds? how do u play them and such then?? cause... actually... i can't mount mine but i can mount data cds fine. thanks
 
Old 06-16-2003, 07:00 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,266

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
eltongeoff:
You can not mount an audio CD because they do not contain a filesystem. Any CD player like xmms, set its configuration to your CDROM device and just play.

Last edited by michaelk; 06-16-2003 at 10:00 PM.
 
Old 06-16-2003, 11:04 PM   #10
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Mandrake 9.0 has supermount. No need to upgrade to 9.1. Mandrake 8.1 also has supermount.

In XMMS, use add a directory and select the /mnt/cdrom. All the tracks should show up. For audio CDs to be played you need the audio cable connected to the sound card.
 
Old 06-16-2003, 11:07 PM   #11
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
thanks michaelk.

eltongeoff, good catch. most people don't realize it that fast.

evil-monkey, what it sounds like is that you don't have permissioins to mount them. whether you have them automounted or not. check your fstab and see if it has nouser in it, if so then you'll have to get rid of it all together or just put in user. it could also be that you don't have supermount enabled, can't remember if mdk 9.0 had it or not.

hopefully you won't have any more problems with 9.1. if so please post back.

cheers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble mounting devices aje Linux - Newbie 10 10-24-2004 01:55 AM
Mounting various SCSI devices KePSuX Linux - Hardware 2 10-08-2004 05:05 PM
un/mounting loop devices box_l Linux - Software 4 08-05-2004 10:03 AM
Deny Mounting my devices... Gorbachov Linux - Software 5 11-06-2003 12:41 PM
Mounting SCSI devices MasterC Linux - Hardware 12 09-25-2002 03:06 AM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration