LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-21-2005, 08:03 AM   #1
resego
Member
 
Registered: Mar 2005
Posts: 37

Rep: Reputation: 15
mounting cd's , dvd's problems HELP!!!!!


how do i fix this error....
[myname@ip-0511 myname]$ mount /dev/hdc
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems

i get it when i try to mount a dvd on mandrake 10.1
 
Old 03-21-2005, 08:59 AM   #2
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 47
Is it a movie DVD? If so, you don't mount it, you just play it.

If it's a data disc, check what you have in /etc/fstab for hdc.
 
Old 03-21-2005, 09:19 AM   #3
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
the dvd is a data dvd
i get this message when i do /etc/fstab

[myname@ip-0511 etc]$ cd fstab
bash: cd: fstab: Not a directory

or i am doing something wrong.... i am new to linux....
 
Old 03-21-2005, 09:37 AM   #4
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
fstab is not a directory. It is a file. You are getting the error because of this.
And for mounting your DVD, read the man pages.

-Prasanta
 
Old 03-21-2005, 09:43 AM   #5
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
aaaah.......!!!!!!! sorry !!!! i am new to this linux thing....

where do i find the man page?????
i dont even know how to fix this problem.....
i dont get what the problem with my fstab is.......
maybe you could help me out........................
 
Old 03-21-2005, 09:58 AM   #6
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 47
run "cat /etc/fstab" and paste the output here. Then we can tell you if it's been set up to allow you to mount a DVD with the command you're using, or if you need to specify more details.
 
Old 03-21-2005, 10:05 AM   #7
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
thats the output from the command below.............

[name@ip-0511 name]$ cat /etc/fstab

/dev/hda6 / ext3 noatime 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hda5 /mnt/win_d ntfs umask=0,nls=iso8859-15,ro 0 0
none /proc proc defaults 0 0
/dev/hdc /mnt/cdrom iso9660 noauto,users,ro 0 0
 
Old 03-21-2005, 10:14 AM   #8
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 47
There's your problem!

You have two entries for /dev/hdc! Comment out the bottom one (by putting a # in front of it) and then try 'mount /mnt/cdrom'

(If /mnt/cdrom doesn't exist, then 'mkdir /mnt/cdrom' first)
 
Old 03-21-2005, 10:20 AM   #9
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
hello again ..................


how do i comment out the last entry???
could you give me the exact steps to follow......................
please put as much details in the as possible(newbie to linux)....................sorry!!!!!!!!!!!!!!!!!!!!!!!
 
Old 03-21-2005, 10:27 AM   #10
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
okay i managed to comment out the last entry and this is how it looks like

[name@ip-0511 name]$ cat /etc/fstab
/dev/hda6 / ext3 noatime 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hda5 /mnt/win_d ntfs umask=0,nls=iso8859-15,ro 0 0
none /proc proc defaults 0 0
#/dev/hdc /mnt/cdrom iso9660 noauto,users,ro 0 0


still i get this error!!!!!!!!!!!!!!!!!!!!!
[name@ip-0511 name]$ mount /dev/hdc
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
 
Old 03-21-2005, 10:30 AM   #11
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
as for this command............
mount /mnt/cdrom

i get this.......................
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
 
Old 03-21-2005, 10:33 AM   #12
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
i hope you saw my last tow replys that i put...................
 
Old 03-21-2005, 10:52 AM   #13
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
#mount -t iso9660 /dev/hdc /mnt/cdrom
hdc - secondary master

-Prasanta

Last edited by prasanta; 03-21-2005 at 10:56 AM.
 
Old 03-21-2005, 11:04 AM   #14
resego
Member
 
Registered: Mar 2005
Posts: 37

Original Poster
Rep: Reputation: 15
okay this is what i i get from the last command you sad i should try........

[root@ip-0511 name]# mount -t iso9660 /dev/hdc /mnt/cdrom
mount: block device /dev/hdc is write-protected, mounting read-only
[root@ip-0511 name]#
then it does open the dvd....
is there a way of correcting this............so that i can mount the dvd or cd without being root............
 
Old 03-21-2005, 11:30 AM   #15
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
If you want to pass parameters while using the command then you have to root. A normal user don't have the priviledge to pass parameters.
For a normal user to mount your cdrom one must have an entry in the /etc/fstab file.
It should look like this
/dev/hdc /mnt/cdrom iso9660 defaults,ro,user,noexec,noauto 0 0

-Prasanta
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Plextor 712a won't burn dvd's -----just cd's foodhater Linux - Hardware 12 07-21-2005 11:40 AM
k3b writes cd's but not dvd's petermcp Mandriva 5 02-15-2005 04:50 AM
Cd's work but DVD's wont... drzigman Linux - Hardware 0 01-05-2005 03:29 AM
problems mounting cd's corbis_demon Linux - Newbie 2 06-29-2004 01:33 AM
My dvd drive reads cd's but not dvd's malcolm Linux - Newbie 8 01-23-2003 05:35 PM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration