LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-03-2013, 10:07 AM   #1
amerkfan
LQ Newbie
 
Registered: Dec 2013
Posts: 2

Rep: Reputation: Disabled
Mounting a (wired) network attached storage


I have an Ubuntu 12.04 server set up and I want to create a mount point for the Corza NAS in fstab. Being a newbie I am having trouble finding the correct path to the device (on my network at 192.168.0.12). I tried \\192.168.0.12\root also \mnt\md1 and a couple others. I tried creating a credential file and mount-cifs, but still no luck.

I need to figure out the path to use to mount this NAS. I've tried the two above, including /public at the end, I've tried several variations (changing the ip to the device name, etc.) of 'mount -t ext3 //192.168.0.12:/NAS-2TB/public /mnt/nas2tb -o username=xxxxxx,passwordxxxx' and get the message: mount: special device 192.168.0.12:/NAS-2TB/public does not exist also /home/tom# 'mount -t cifs //192.168.0.12/public /mnt/nas2tb' got prompted for a password and received this: mount error(13): Permission denied. I am using the correct username/password combo, or at least the one I use to access the drive with Windows and to access the admin screens.

I am trying to get it to mount before I edit fstab, and I am at a loss. Any help or suggestions are greatly appreciated. I am setting this up as a backup device.
 
Old 12-03-2013, 02:06 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,402

Rep: Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654Reputation: 1654
Welcome to LinuxQuestions.

You must be root to mount a filesystem that does not have an entry in fstab. Since root is not enabled by default in Ubuntu you must use sudo. i.e.

sudo mount -t cifs //192.168.0.12/public /mnt/nas2tb ( I assume that public is the correct directory )

Now enter you Ubuntu password, then the NAS username,password at the next prompt. Make sure that the /mnt/nas2tb directory exists. You can also use Nautilus to access the NAS by selecting on network on the left side.
 
Old 12-11-2013, 07:30 AM   #3
amerkfan
LQ Newbie
 
Registered: Dec 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks for the reply, I tried your suggestion and it works. I also found that changing the admin user to the same name and password as the Ubuntu server helped. Not sure if that is required but using different users didn't. The NAS is an old one, so it may be a factor.I'll mark this as resolved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network attached storage. OS compatibility? samsom Linux - Networking 4 01-30-2010 11:58 AM
Network attached storage set up Txabuzer SUSE / openSUSE 5 12-29-2006 11:04 PM
Network Attached Storage - Project ?? radial Linux - Networking 3 06-13-2006 03:17 AM
help with Network Attached Storage debloxie Linux - Networking 3 09-12-2005 10:39 PM
Network Attached Storage - Project ?? radial General 0 08-20-2001 05:49 PM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration