LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-02-2009, 11:19 PM   #1
rcmonroig
Member
 
Registered: Mar 2007
Location: Chandler, AZ
Distribution: Fedora 10,12,and 14
Posts: 60
Blog Entries: 1

Rep: Reputation: 15
Unhappy Mounted NFS directory can't mkdir


Fedora 10 system. Mounted cislab:/public/cm449 ./fileserver

Mounted fine on client workstation. Can ls the directory no problem. But can't create a directory to save backup files from my client workstation. I get a permission denied message. What am I missing? Your help would be greatly appreciated.

Thanks,
rc

Last edited by rcmonroig; 11-02-2009 at 11:20 PM.
 
Old 11-03-2009, 12:32 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
With what options is the directory exported from the server? Have you checked if you have given right permissions for the remote systems to create files there?
 
Old 11-03-2009, 04:07 AM   #3
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 1,923

Rep: Reputation: 278Reputation: 278Reputation: 278
Look in the file /etc/exports. See if you have a proper netmask. It should look something like this:

/home/sam/stuff 192.168.0.1/255.255.255.0(root_squash,ro,sync,no_subtree_check,nohide)

The above line will allow export of /home/sam/stuff to all ip addresses in the 192.168.0.1-255 range. Also, try mounting the NFS drive like this:

sudo mount 192.168.0.23:/home/sam/stuff /mnt/stuff -t nfs
 
Old 11-03-2009, 07:54 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
You'll need to change the ro option to rw to be able to mkdir.
 
Old 11-04-2009, 12:36 PM   #5
rcmonroig
Member
 
Registered: Mar 2007
Location: Chandler, AZ
Distribution: Fedora 10,12,and 14
Posts: 60
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Smile options in /etc/exports

/public/cis126/cm449 192.168.1.0/24(rw,sync,no_root_squash)
 
Old 11-04-2009, 11:57 PM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
I think the permissions in the exports are not the only that count and the permissions on the directory also count. You need to allow write permissions on the directory as well.
 
  


Reply

Tags
mount, nfs, permissions


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
core dump file won't write to nfs-mounted directory rainzone Linux - Networking 5 08-25-2009 05:30 PM
file size limit exeeded for NFS mounted directory rizwan.cheema Red Hat 2 11-28-2006 05:52 AM
program run from nfs-mounted directory behaves badly jabel5 Other *NIX 3 10-05-2005 09:40 AM
NFS export of directory with mounted iso-images leipy SUSE / openSUSE 1 06-03-2005 09:12 PM
Mounted NFS directory (Read-Only) dunmarie Linux - General 3 08-04-2004 04:17 AM


All times are GMT -5. The time now is 05:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration