LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-19-2005, 11:18 PM   #1
guest
Member
 
Registered: May 2003
Distribution: CentOS 5 64 bit
Posts: 255

Rep: Reputation: 30
Mounted ISO image... but RHEL still asks for CD?


so I was able to mount successfully - like so...
mount -t iso9660 image.iso /mnt/whatever -o loop

but when i go into Add/Remove Application.. it still asks for RHEL CDs to install certain components.. is there a way around this? Thanks!
 
Old 03-19-2005, 11:22 PM   #2
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
export SETUP_CDROM=/mnt/mycrap

That will make your ENV think your CD is now in that device/directory.
 
Old 03-19-2005, 11:41 PM   #3
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
what he said

Last edited by masonm; 03-19-2005 at 11:42 PM.
 
Old 03-20-2005, 05:24 AM   #4
guest
Member
 
Registered: May 2003
Distribution: CentOS 5 64 bit
Posts: 255

Original Poster
Rep: Reputation: 30
thanks! btw.. is there a startup file i can edit so it launches that every time my computer starts?
 
Old 03-20-2005, 04:02 PM   #5
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
Add the line to /etc/rc.d/rc.local or /etc/rc.d/boot.local in other distro's.
 
Old 03-24-2005, 03:49 AM   #6
guest
Member
 
Registered: May 2003
Distribution: CentOS 5 64 bit
Posts: 255

Original Poster
Rep: Reputation: 30
hmm i tried

export SETUP_CDROM=/mnt/mycrap

and when i tried to install an RPM package.. it says:

Unable to access disk

The disk was unable to be accessed for reading. Please confirmt that it is in the drive and try again.


when i just type export alone.. it says
"declare -x SETUP_CDROM="/rheliso/rhel2"

along with tons of other lines...


how come it's not working?



Last edited by guest; 03-24-2005 at 03:51 AM.
 
Old 03-24-2005, 11:47 PM   #7
guest
Member
 
Registered: May 2003
Distribution: CentOS 5 64 bit
Posts: 255

Original Poster
Rep: Reputation: 30
Unhappy

anybody w/ the same problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virus or broken system? apt-get install asks to remove kernel image?? rakamaka Linux - Software 6 09-19-2005 10:31 PM
RHEL CDs: made iso, mounted iso, exported dir - still asks for CD :( guest Linux - Newbie 1 04-08-2005 01:37 PM
I export SETUP_CDROM=/mnt/mycrap but RHEL still asks for CD guest Linux - Newbie 0 03-31-2005 06:37 PM
How to create image using PQDI boot disk? (rhel v2.1) namgor Red Hat 1 06-25-2004 09:26 AM
rhel disk 2 iso problem Razgo Red Hat 2 02-06-2004 06:56 PM


All times are GMT -5. The time now is 11:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration