LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-03-2008, 11:49 AM   #1
User Name.
Member
 
Registered: Aug 2006
Distribution: Ubuntu 8.04
Posts: 178

Rep: Reputation: 30
"Mount: wrong file system type, bad option, bad superblock"


So I'm trying to mount two different cds and get the data from them, and I keep encountering this error:
Code:
$ sudo mount -t iso9660 /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
Does anyone have any ideas as to what this could be?
 
Old 09-03-2008, 01:14 PM   #2
trist007
Member
 
Registered: May 2008
Distribution: Slackware
Posts: 972

Rep: Reputation: 56
Yeah, well the first part about read only is fine because ur dealing with a cd. However, on the 2nd error the file system iso9660 isn't the right one. I had that problem also.

Does anybody know if there's a command that you can run that checks the media and returns its filesystem type?
 
Old 09-03-2008, 01:28 PM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Are you sure it's an iso9660 disc ?

Could it possibly be a packet written CD using the UDF file system ?

http://en.wikipedia.org/wiki/Packet_writing
http://packet-cd.sourceforge.net/

Quote:
The other major component to the packet writing process is support of the UDF (Universal Disk Format) filesystem. UDF provides a filesystem capable of understanding large amounts of storage space (such as that found on DVDs), and is far more optimal for use with packet writing than the ISO9660 format used with traditional Track-at-Once and Disc-at-Once methods. UDF support for Linux is under development by the Linux UDF project.
Personally I've never cared for packet writing.. I guess that stems from back in the days when packet written CD's wouldn't work in a lot of CDROM drives due to lack of hardware support.

Did you consider allowing Mount to auto-detect the filesystem ?

Last edited by farslayer; 09-03-2008 at 01:31 PM.
 
Old 09-03-2008, 02:13 PM   #4
User Name.
Member
 
Registered: Aug 2006
Distribution: Ubuntu 8.04
Posts: 178

Original Poster
Rep: Reputation: 30
It's not UDF:
Code:
$ sudo mount -t udf /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or s
I didn't see anything in the man page about the auto-guessing idea. How should I go about that?
 
Old 09-03-2008, 02:31 PM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,104
Blog Entries: 3

Rep: Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402
Hi,

'mount -t auto /dev/scd0 /mnt/cdrom' that simple;

Code:
excerpt 'man mount';

If  no  -t  option  is  given, or if the auto type is specified,
              mount will try to guess the desired type.  If mount was compiled
              with  the  blkid  library, the guessing is done by this library.
              Otherwise, mount guesses itself by probing  the  superblock;  if
              that  does  not turn up anything that looks familiar, mount will
              try to read the file /etc/filesystems,  or,  if  that  does  not
              exist,  /proc/filesystems.   All  of the filesystem types listed
              there will be tried, except for those that are  labeled  "nodev"
              (e.g.,  devpts,  proc  and  nfs).  If /etc/filesystems ends in a
              line with a single * only,  mount  will  read  /proc/filesystems
              afterwards.

Last edited by onebuck; 09-03-2008 at 03:12 PM. Reason: correct my ommission of the -t switch
 
Old 09-03-2008, 02:33 PM   #6
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
I usually just do..

Code:
mount /dev/scd0 /mnt/cdrom
I think you need the -t if you wish to use the auto type.
I could be mistaken since I usually don't bother with all that extra typing

Code:
mount -t auto /dev/scd0 /mnt/cdrom
What type of CD is this anyway ?
is it a CD-R that you created, or someone else gave you ?
is it an audio CD ?
is it an enhanced CD (Audio and Data) you purchased somewhere like BestBuy ?

Last edited by farslayer; 09-03-2008 at 02:35 PM.
 
Old 09-03-2008, 02:41 PM   #7
User Name.
Member
 
Registered: Aug 2006
Distribution: Ubuntu 8.04
Posts: 178

Original Poster
Rep: Reputation: 30
Code:
mount auto /dev/scd0 /mnt/cdrom
Prints out a help file; the same one as "mount -h"

Code:
$ mount /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: you must specify the filesystem type
and "mount -t auto ...." presented the same output.
 
Old 09-03-2008, 03:11 PM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,104
Blog Entries: 3

Rep: Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402
Hi,

The correct command is 'mount -t auto /dev/scd0 /mnt/cdrom' Sorry about my error. Do you have permissions on the device? You are root?
 
Old 09-03-2008, 03:17 PM   #9
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,104
Blog Entries: 3

Rep: Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402
Hi,

What is on the cd?
 
Old 09-03-2008, 03:40 PM   #10
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
So would you care to answer my other questions at the bottom of my previous post ? For all I know you are trying to mount blank CDR's......

I certainly can't tell from here More info please.

for grins try file -s on the device node.

Code:
it-etch:/# file -s /dev/hda
/dev/hda: UDF filesystem data (version 1.5) 'DVDVIDEO

Last edited by farslayer; 09-03-2008 at 03:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad mount of .mdf - "wrong fs type, bad option, bad superblock, on /dev/loop0" Maybe-not Linux - General 2 02-29-2008 01:30 PM
Can't mount samba server: "wrong fs type, bad option, bad superblock ..." Arla Linux - Networking 5 06-10-2007 01:53 PM
USB stick won't mount ("wrong fs type, bad option, bad superblock ...") Arla Linux - Hardware 4 06-01-2007 07:23 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 10:31 AM


All times are GMT -5. The time now is 06:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration