LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   "Mount: wrong file system type, bad option, bad superblock" (http://www.linuxquestions.org/questions/linux-newbie-8/mount-wrong-file-system-type-bad-option-bad-superblock-667319/)

User Name. 09-03-2008 11:49 AM

"Mount: wrong file system type, bad option, bad superblock"
 
So I'm trying to mount two different cds and get the data from them, and I keep encountering this error:
Code:

$ sudo mount -t iso9660 /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

Does anyone have any ideas as to what this could be?

trist007 09-03-2008 01:14 PM

Yeah, well the first part about read only is fine because ur dealing with a cd. However, on the 2nd error the file system iso9660 isn't the right one. I had that problem also.

Does anybody know if there's a command that you can run that checks the media and returns its filesystem type?

farslayer 09-03-2008 01:28 PM

Are you sure it's an iso9660 disc ?

Could it possibly be a packet written CD using the UDF file system ?

http://en.wikipedia.org/wiki/Packet_writing
http://packet-cd.sourceforge.net/

Quote:

The other major component to the packet writing process is support of the UDF (Universal Disk Format) filesystem. UDF provides a filesystem capable of understanding large amounts of storage space (such as that found on DVDs), and is far more optimal for use with packet writing than the ISO9660 format used with traditional Track-at-Once and Disc-at-Once methods. UDF support for Linux is under development by the Linux UDF project.
Personally I've never cared for packet writing.. I guess that stems from back in the days when packet written CD's wouldn't work in a lot of CDROM drives due to lack of hardware support.

Did you consider allowing Mount to auto-detect the filesystem ?

User Name. 09-03-2008 02:13 PM

It's not UDF:
Code:

$ sudo mount -t udf /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or s

I didn't see anything in the man page about the auto-guessing idea. How should I go about that?

onebuck 09-03-2008 02:31 PM

Hi,

'mount -t auto /dev/scd0 /mnt/cdrom' that simple;

Code:

excerpt 'man mount';

If  no  -t  option  is  given, or if the auto type is specified,
              mount will try to guess the desired type.  If mount was compiled
              with  the  blkid  library, the guessing is done by this library.
              Otherwise, mount guesses itself by probing  the  superblock;  if
              that  does  not turn up anything that looks familiar, mount will
              try to read the file /etc/filesystems,  or,  if  that  does  not
              exist,  /proc/filesystems.  All  of the filesystem types listed
              there will be tried, except for those that are  labeled  "nodev"
              (e.g.,  devpts,  proc  and  nfs).  If /etc/filesystems ends in a
              line with a single * only,  mount  will  read  /proc/filesystems
              afterwards.


farslayer 09-03-2008 02:33 PM

I usually just do..

Code:

mount /dev/scd0 /mnt/cdrom
I think you need the -t if you wish to use the auto type.
I could be mistaken since I usually don't bother with all that extra typing :)

Code:

mount -t auto /dev/scd0 /mnt/cdrom
What type of CD is this anyway ?
is it a CD-R that you created, or someone else gave you ?
is it an audio CD ?
is it an enhanced CD (Audio and Data) you purchased somewhere like BestBuy ?

User Name. 09-03-2008 02:41 PM

Code:

mount auto /dev/scd0 /mnt/cdrom
Prints out a help file; the same one as "mount -h"

Code:

$ mount /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: you must specify the filesystem type

and "mount -t auto ...." presented the same output.

onebuck 09-03-2008 03:11 PM

Hi,

The correct command is 'mount -t auto /dev/scd0 /mnt/cdrom' Sorry about my error. Do you have permissions on the device? You are root?

onebuck 09-03-2008 03:17 PM

Hi,

What is on the cd?

farslayer 09-03-2008 03:40 PM

So would you care to answer my other questions at the bottom of my previous post ? For all I know you are trying to mount blank CDR's......

I certainly can't tell from here :) More info please.

for grins try file -s on the device node.

Code:

it-etch:/# file -s /dev/hda
/dev/hda: UDF filesystem data (version 1.5) 'DVDVIDEO



All times are GMT -5. The time now is 09:45 AM.