LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mount Windows Hard drive in Linux (http://www.linuxquestions.org/questions/linux-newbie-8/mount-windows-hard-drive-in-linux-1117/)

burtongeek 03-02-2001 12:31 AM

Does anyone know how to mount a windows hard drive in Linux. I am using Red Hat 7.0 with Gnome if that helps. I would just like to be able to use my mp3z, movies, etc that are on my windows drive...

thanks

CragStar 03-02-2001 03:40 AM

Where is the partition you want to mount. /dev/hda1? If so you need to edit the file /etc/fstab. This is where all the partitions are mounted when Linux boots.

The file sometimes has different entries for different systems, so you can use this command at a terminal to mount windows c:

# mount /dev/hda1 /windows -t vfat

You need to have a folder called /windows which is available and the filesystem on the c: needs to be fat32. to unmount it:

# umount /dev/hda1 /windows -t vfat

Altough you may not need to enter the whole line all the time:

# umount /dev/hda1

will do.

jadeski 03-12-2001 06:00 PM

Mount Shared Windows Dir on Different Machine
 
If your windows is on another machine and is connected into your LAN (where your linux box is also connected), you can use the smb command:

#smbmount //win-machine-name/shared-dir-name /mount-point

If shared-dir-name is password protected, then you would need to type-in the password.

tdnik 01-06-2002 05:20 PM

I'm having troubles mounting my windows drives and haven't seen a scenario like mine posted:

I have three drives. 1 ide for linux only. 2ide in RAID0 for windows only....when i boot, linux boots, if I press esc at the right time during bios, i get boot menu and can select the proper device to boot windows.

windows and linux are not on the same drive.....can i mount my windows drive from linux? I would like to to transfer files between OS's with out using a second computer to temporarliy store files while I reboot my other box.


Thanks,
CK

[BHBS]=TK 01-07-2002 05:39 PM

usually hard drives nad cd-roms go like this

hda1-hda4 #the numbers being partitions
hdb
hdc
hdd
hde
hdf
hdg
etc

trial and error

mkdir /mnt/windows #if it doesn't exist

mount -t vfat /dev/hda1 /mnt/windows

tdnik 01-07-2002 06:49 PM

ok, thanks... i'm making progress, but I've hit another obstacle.

this is what seems to work, almost.:

# mount -t vfat /dev/hdc1 /win

but i get this error --

mount: block device /dev/hdc1 is write-protected, mounting read-only

mount: cannot mount block device /dev/hdc1 read-only


what can i try next? must I configure something differently in windows?

any other device type gives me an error of "wrong fs type, bad option, bad superblock, blablabla....

thanks,
CK

theFuzzyOne 01-07-2002 07:14 PM

IDE RAID
 
some reference material to search:
http://www.research.att.com/~gjm/linux/ide-raid.html

proopnarine 01-08-2002 01:09 AM

progress
 
It's not necessarily a good idea to try to write to your Windows drive; some systems seem to encounter severe difficulties with this. So perhaps that why read-only is automatically on. However, are you trying to write as a user, or as root? If as a user, you can add yourself to the disks group.

Roop

tdnik 01-08-2002 11:50 AM

Re: progress
 
Quote:

Originally posted by proopnarine
It's not necessarily a good idea to try to write to your Windows drive; some systems seem to encounter severe difficulties with this. So perhaps that why read-only is automatically on. However, are you trying to write as a user, or as root? If as a user, you can add yourself to the disks group.

Roop


I'm only trying to access windows files from linux, i don't intend to write to windows.
I've been trying in root user, but finally figured out my problem.
I need to use /dev/hdg1............my windows drives are on the 3rd adn 4th ide port as a raid0 config. I found the device name by looking in partitioning information in WEBMIN.


thanks for the input!
CK

mikkh 01-15-2003 07:31 PM

Having the same problem on Red Hat 8

I want to see my windows D partition (hda5) to play mp3's etc as well
but I want it auto mounted at startup

Tried amending mtab and fstab files, but obviously haven't got the syntax correct, because it just comes up with errors :(

sibu_rajappan 05-28-2004 02:08 AM

auto mounting ur hard drive
 
any probs in auto mounting .................
then check the dev name is correct or not i correct then edit the fstab as this

/dev/hda<whatever name it is> /mnt/<create a dir urself> auto defaults 0 0

this gives u all the permissions to access the files this is what i felt wen mountn this causes no probs........

try it if any suggestions pls do telll

DaFrawg 06-21-2004 03:13 AM

Okay, I have a problem mounting an NTFS-partition. If I say

# mount -t ntfs /dev/hda1/ /mnt/hda1/

the kernel says that ntfs is not supported, but the help files of Red Hat 9 say that it IS supported.

dingo_aus 06-27-2004 11:27 PM

The fstab line that worked for me was:

/dev/hdb5 /disks/g_drive auto user 0 0


BTW I also tried to (as root) chmod 777 /dev/hdb5

This allows me to read and write to a FAT32 volume

ujjwals 07-02-2004 11:09 PM

Can we Mount NTFS partation !!!
 
Guys :

I have a dual boot system with hda1 and hda5 as my windows drives C: and D:

but these are NTFS partations NOT FAT32

can i mount these NTFS partations to my LINUX part .

ujjwals 07-11-2004 10:28 PM

mounting an NTFS-partition.
 
I tried mounting an NTFS-partition.

like this only ...
# mount -t ntfs /dev/hda1/ /home

the kernel says that ntfs is not supported,
but the help files of Red Hat 9 say that it IS supported.

Plz help..


All times are GMT -5. The time now is 02:04 AM.