LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-06-2011, 12:23 PM   #1
ust
Senior Member
 
Registered: Mar 2003
Location: fasdf
Distribution: Debian / Suse /RHEL
Posts: 1,130

Rep: Reputation: 30
mount usb HD


I have a USB external HD has plug to the linux server , I tried mount /dev/sda1 /mountpoint but pop the error .

mount: /dev/sda1 : No such file or directory

I don't know why pop the error, can advise how can I mount ?

Thanks.
 
Old 09-06-2011, 12:29 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Can you post the exact command you used to mount, please? Are you sure you're using the correct device? Also, does the mount point exist?
 
Old 09-06-2011, 01:27 PM   #3
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
Well. You obviously use incorrect device filename. Check dmesg immediately after you plug your external HD in to find correct device filename.
E.g.
Code:
[ 4006.427334] sd 2:0:0:0: Attached scsi generic sg2 type 0
[ 4008.416458] sd 2:0:0:0: [sdb] 3903488 512-byte logical blocks: (1.99 GB/1.86 GiB)
[ 4008.419445] sd 2:0:0:0: [sdb] Write Protect is off
[ 4008.419452] sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 4008.425443] sd 2:0:0:0: [sdb] No Caching mode page present
[ 4008.425451] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 4008.444442] sd 2:0:0:0: [sdb] No Caching mode page present
[ 4008.444450] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 4008.450522]  sdb: sdb1
[ 4008.468444] sd 2:0:0:0: [sdb] No Caching mode page present
[ 4008.468453] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 4008.468459] sd 2:0:0:0: [sdb] Attached SCSI removable disk
This is output of dmesg after I plug my flash drive in. It shows, that device filename of my drive is /dev/sdb1
 
Old 09-06-2011, 07:20 PM   #4
ust
Senior Member
 
Registered: Mar 2003
Location: fasdf
Distribution: Debian / Suse /RHEL
Posts: 1,130

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Samotnik View Post
Well. You obviously use incorrect device filename. Check dmesg immediately after you plug your external HD in to find correct device filename.
E.g.
Code:
[ 4006.427334] sd 2:0:0:0: Attached scsi generic sg2 type 0
[ 4008.416458] sd 2:0:0:0: [sdb] 3903488 512-byte logical blocks: (1.99 GB/1.86 GiB)
[ 4008.419445] sd 2:0:0:0: [sdb] Write Protect is off
[ 4008.419452] sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 4008.425443] sd 2:0:0:0: [sdb] No Caching mode page present
[ 4008.425451] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 4008.444442] sd 2:0:0:0: [sdb] No Caching mode page present
[ 4008.444450] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 4008.450522]  sdb: sdb1
[ 4008.468444] sd 2:0:0:0: [sdb] No Caching mode page present
[ 4008.468453] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 4008.468459] sd 2:0:0:0: [sdb] Attached SCSI removable disk
This is output of dmesg after I plug my flash drive in. It shows, that device filename of my drive is /dev/sdb1
thx ,

I didn't find sda , sdb...etc in /dev , the usb drive should be use device sd* ?

I just found the below message in dmesg

umass0: detached
umass1: at uhub0 port 2 (addr 3) disconnected
 
Old 09-07-2011, 01:33 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
*Sigh*. Could you post the last 10 or so lines from dmesg, after plugging the device in?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Make removable USB hdd mount at fixed mount point ctkroeker Linux - General 13 08-11-2009 09:49 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 08:16 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 1 12-24-2005 05:25 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 03:15 AM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 12:50 PM


All times are GMT -5. The time now is 08:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration