LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2004, 10:21 PM   #1
baseballtwin86
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
Mount permissions with iPod


I finally got my ipod mounted (after recompiling my kernel and all that fun stuff). The ipod mounts, and I can read the file system when logged in as root, but cannot read it as a regular user. I have chmod'ed the /mnt/ipod but it still doesn't allow me to access it as a regular user. Any idea?

Thanks

Last edited by baseballtwin86; 10-13-2004 at 12:03 PM.
 
Old 10-12-2004, 11:26 PM   #2
Harpune
Member
 
Registered: Sep 2002
Location: Seattle, WA
Distribution: Ubuntu
Posts: 101

Rep: Reputation: 15
How are you mounting your Ipod? Do you have a /mnt/ipod entry in your /etc/fstab file or are you just typing the command 'mount /dev/sda1 /mnt/ipod'?

If you have an entry in your fstab for the ipod, add the options 'uid=<your user id>,gid=<your group id>

for instance, if the line originally looks like this:
/dev/sda1 /home/shriver/usb vfat defaults 0 0
try something like this:
/dev/sda1 /home/shriver/usb vfat uid=1000,gid=1000,users,owner 0 0
(for explanations of the option type 'man mount')

If you mount the ipod with the mount command, add those options like this:
'mount -o uid=1000,gid=1000,owner,users /dev/ipod /mnt/ipod'

that should set the mounted partition as being owned by the specified user.

Good luck.
 
Old 10-13-2004, 12:03 PM   #3
baseballtwin86
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Hmm, the problem seems to have gotten more complicated:

When I run
Code:
mount /dev/sda2 /mnt/ipod
I am able to mount the ipod and explore the file system as root but cannot access the file system as a regular user.

When
Code:
/dev/sda2 /mnt/ipod vfat uid=1000,gid=1000,user,root 0 0
is in fstab and I run
Code:
mount /mnt/ipod
I get

Code:
wrong fs type, bad option, bad superblock on /dev/sda2, or too many mounted file systems
The same error occurs when I type
Code:
mount -o uid=1000,gid=1000,root,kennethleiter, -t  vfat /dev/sda2 /mnt/ipod
directly into the terminal. However, I am sure of the filesystem type: here is the partition table from fdisk:

Code:
Disk /dev/sda: 20.0 GB, 20000268288 bytes
255 heads, 63 sectors/track, 2431 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1           5       40131    0  Empty
/dev/sda2   *           6        2431    19486845    b  W95 FAT
 
Old 10-13-2004, 04:31 PM   #4
misophist
Member
 
Registered: Aug 2003
Location: here
Distribution: suse 8.2
Posts: 169

Rep: Reputation: 30
If I remember correctly, vfat is for newer win98 machines and uses 32 bit words. Fat, which is what the table shows, is 16 bit. Try changing the fstab to fat. You may need to load the fat module.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount permissions RTT Linux - Newbie 5 03-08-2004 12:13 PM
mount permissions KMcD Slackware 1 02-09-2004 06:48 AM
Mount Permissions Camasii Linux - General 2 12-08-2003 05:26 AM
Mount Permissions Odd_Bloke Linux - Newbie 2 08-26-2003 01:00 PM
mount permissions FNC Linux - Software 3 05-30-2001 03:16 AM


All times are GMT -5. The time now is 06:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration