LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2016, 12:09 PM   #1
bornplaydie
LQ Newbie
 
Registered: Jan 2016
Posts: 5

Rep: Reputation: Disabled
mount NTFS partition for windows 8 use in Mint 17


Recently installed Mint 17 on an HP 2000 laptop with a 300+ GB HDD as dual boot with Windows 8. Besides the Win and Mint partitions I had a 150 GB partition formatted as NTFS I mount as "Data" at start up.

Code:
/etc/fstab entry:
/dev/disk/by-uuid/3BC5713C5EA51826 /media/mark/Data auto nosuid,nodev,nofail 0 0
All files perms at Data are shown as
Code:
-rwxrwxrwx 1 root root
. I do have access to the root files as user mark. I can remove and modify them, so it seems to work. When I exec
Code:
sudo chown -R mark: /media/mark/Data
it takes a while but files perms have not changed. I have read something about NTFS not supporting file perms.

I have a external USB drive as well. It is magically mounted when connected. No entry in /etc/fstab and I do not know where the mount info is. All files on this drive are
Code:
-rw------- 2 mark mark
. I cannot chown or chmod these files either.

So I guess my question are:

Should I format my drive differently?

If not, what do I need to use in /etc/fstab to mount the Data partition to result in file perms
Code:
-rw------- 2 mark mark
?

Side note: spent a couple days trying to get this to work. There is no lack of info out there, probably too much info for me to sort it all out. Lots of suggestion like ntfs-3g formatting that is not even listed in the man page for fstab. So I think I just need a little direct help on this one.
 
Old 01-04-2016, 10:07 AM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,984

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Standard Linux permission aren't understood by windows so you need to use umask, dmask or fmask options in fstab. The link below is to the Ubuntu forums and the first post has a very detailed explanation and also some examples.

http://ubuntuforums.org/showthread.php?t=1604251
 
Old 01-04-2016, 11:48 PM   #3
bornplaydie
LQ Newbie
 
Registered: Jan 2016
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thank you. Exactly what I was looking for. Unfortunately I didn't search for the right terms so this never came up. Thanks for taking the time to reply. My partition is now working great!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mint mount ntfs partition for all users ilesterg Linux - General 13 08-15-2012 12:56 PM
how mount mount ntfs partition of windows xp kashif2131971 Linux - Newbie 3 07-07-2009 07:34 PM
cannot mount Windows (NTFS) partition SharX Linux - General 14 06-21-2006 04:12 AM
How to mount Windows NTFS partition?? crash_override_me Ubuntu 13 12-10-2005 02:40 PM
Can I mount my windows NTFS partition from Linux? jdruin Fedora 14 04-21-2004 12:49 PM


All times are GMT -5. The time now is 09:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration