LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-29-2003, 09:14 PM   #1
gonavy
LQ Newbie
 
Registered: Nov 2003
Location: MD
Distribution: Mandrake
Posts: 2

Rep: Reputation: 0
mount drives from user instead of root


New guy here, running Mandrake9.2 on a HP ze4365 laptop, dual-booting with XP via LILO.

Trying to get my usb floppy to automount to the user account; put this in fstab (not really knowing what I was doing, just adapting the line that was already there for my CDRW drive):

none /mnt/floppy supermount dev=/dev/sda,fs=vfat user 0 0

The 1st time I booted back into Mdk the floppy icon showed up in KDE, and the drive was mounted and I could R/W to it as user. Thought I was set, until I restarted again later. Now it does not show up. I can go in as root and "mount /dev/sda /mnt/floppy", and R/W to it as root, but I can never get it to mount again as user. What gives? It seemed to be perfect that one time.

Since then I have tried variations on the lines I see posted around:

/dev/sda mnt/floppy auto noauto,user 0 0

With that I cannot even mount it from root.

I have this as the last line in fstab- does that affect things?

I am also trying to get user R/W access to a partition I want to share between XP and Mdk (/dev/hda10, mounted to /var/dmz). I can R/W to it as root, but cannot mount it as user. Here's my fstab entry:

/dev/hda10 /var/dmz vfat user,exec,dev,suid 0 0

any thoughts? thanks.
 
Old 11-29-2003, 09:33 PM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 52
you can try adding umask=000 to your options
like noauto,user,umask=000

the order in fstab only matters for filesystems needed at boot

/dev/sda is the first scsi hard drive.

i would think a usb device would be a little different.
is your /dev/floppy linked to some usb device?

i'm a little overmedicated from migraine meds, so if i typed something
stupid, don't worry about it.

Last edited by whansard; 11-29-2003 at 09:37 PM.
 
Old 11-29-2003, 09:53 PM   #3
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
It is a usb floppy, so it probably has scsi emulation, hence the 'sda'.
Instead of:
Quote:
none /mnt/floppy supermount dev=/dev/sda,fs=vfat user 0 0
Try:
Quote:
none /mnt/floppy supermount dev=/dev/sda,fs=auto,--,iocharset=iso8859-1,codepage=850,sync,umask=0 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
mount smb drives as non-root user? cdhgee Linux - Software 5 09-05-2007 08:38 AM
Unable to mount Cd-drives when not in root jginger Suse/Novell 4 11-15-2004 11:08 AM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
how do i keep from having to su to root to mount drives? yimboli Linux - Newbie 1 02-08-2004 07:22 PM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration