LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2009, 04:12 AM   #1
fwc
LQ Newbie
 
Registered: Dec 2008
Posts: 19

Rep: Reputation: 0
mount disk on startup


Hello,
I would like to mount two of my partitions on startup, can someone please help me figure it out.

My current fstab is
Quote:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda8
UUID=af57d691-48c3-4f07-a864-ae408a015c75 / ext3 relatime,errors=remount-ro 0 1
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
and my current fdisk is
Quote:
Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x86c386c3

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3824 30716248+ 7 HPFS/NTFS
/dev/sda2 3825 19457 125572072+ f W95 Ext'd (LBA)
/dev/sda5 3825 7648 30716248+ 7 HPFS/NTFS
/dev/sda6 7649 12110 35840983+ 7 HPFS/NTFS
/dev/sda7 12111 16708 36933403+ 7 HPFS/NTFS
/dev/sda8 16709 19457 22081311 83 Linux

Disk /dev/sdb: 2029 MB, 2029518848 bytes
243 heads, 32 sectors/track, 509 cylinders
Units = cylinders of 7776 * 512 = 3981312 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 510 1981936 b W95 FAT32
Partition 1 has different physical/logical endings:
phys=(249, 242, 32) logical=(509, 184, 32)
I would like to mount sda1 and sda5 in the media folder and Im not sure of a good permissions setting. Thanks very much and I hope its not too difficult
 
Old 02-15-2009, 08:33 AM   #2
fwc
LQ Newbie
 
Registered: Dec 2008
Posts: 19

Original Poster
Rep: Reputation: 0
I have a new problem

by looking through the help files, I found out how but for some reason when I try to mount as a user and not as super user it won't allow me. It gives the message
cannot mount the device using FUSE library or something
Can someone please help, thanks very much
 
Old 02-15-2009, 11:07 AM   #3
digerati1338
Member
 
Registered: May 2007
Location: CO
Distribution: Ubuntu
Posts: 152
Blog Entries: 1

Rep: Reputation: 18
Make sure you have the package ntfs-3g installed. For filesystem type, put ntfs-3g on both drives. After that, see if you still get the error messages.
 
Old 02-15-2009, 02:03 PM   #4
lassik
LQ Newbie
 
Registered: Feb 2009
Posts: 6

Rep: Reputation: 0
Try this

In the terminal type
Code:
vim /etc/fstab
add the lines

Code:
/dev/sda1               /media/disk-1           ntfs-3g    defaults        0 0
/dev/sda5               /media/disk-2           ntfs-3g    defaults        0 0
save the fstab file

Then mount all with this command
Code:
mount -a
make sure you create the directories disk-1 and disk-2 in the media directory before doing this.


EDIT: also do what digerati1338 says as well.

Last edited by lassik; 02-15-2009 at 06:07 PM. Reason: update
 
Old 02-15-2009, 02:32 PM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Don't use /media for that. /media is where hal creates and deletes directories when automounting removable drives. If /dev/sdb is a removable device, then you don't want it mounted when you boot. You can't count on it having the same device node the next time, and if it isn't plugged in, booting will fail. You need to use the &quot;noauto&quot; option for removable drives.

Read the mount man page and the mount.ntfs manpage. You will want to use the &quot;uid&quot;, &quot;gid&quot;, &quot;fmask&quot; options so that you will be able to access the NTFS filesystem. You need the 'x' bit set on directories to be able to enter them. You don't want the 'x' bit set for files on an NTFS partition. The permissions of all of the directories and all of the files are the same, and determined at boot time.

Last edited by jschiwal; 02-15-2009 at 02:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to view/mount separate disk -- move /home to second disk Spearhead40 Ubuntu 12 11-03-2007 03:37 PM
Need a Linux Startup Disk dudeman41465 Linux - Software 2 07-29-2005 11:02 PM
slackware mount disk at startup android6011 Linux - General 2 06-07-2005 08:08 PM
How do you do startup disk for linux? jsnch Linux - Software 2 05-29-2005 11:57 PM
Windows startup disk philfighter General 3 07-23-2001 12:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration