LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   mount /dev/hdc /dev/cdrom doesn't work (http://www.linuxquestions.org/questions/linux-newbie-8/mount-dev-hdc-dev-cdrom-doesnt-work-104170/)

ShrikesHarvest 10-15-2003 06:33 AM

mount /dev/hdc /dev/cdrom doesn't work
 
Hi,

Am new Linux adventurer. Have installed RedHat 9. Managed to get my USB cable Model working and can now get internet (Yeee haa!!). But I just can't get my DVD working!! Red Hat installed off it so it must be possible to access the thing!

[root@qld mnt]# mount -t iso9660 /dev/hdc /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

*****************
To provide further info
*****************

[root@qld ide]#cat hdc/model
PIONEER DVD-RW DVR-104
[root@qld dev]# ls cdrom
ls: cdrom: No such file or directory
[root@qld mnt]# ls
A C cdrom
[root@qld mnt]# eject /dev/hdc
eject: unable to eject, last error: Invalid argument
[root@qld etc]# cat grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd2,0)
# kernel /vmlinuz-version ro root=/dev/hdd2
# initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=10
splashimage=(hd2,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd2,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img
title Windows
rootnoverify (hd0,0)
chainloader +1
[root@qld etc]# cat fstab
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdd3 swap swap defaults 0 0
/dev/hda1 /mnt/C vfat defaults 0 0
/dev/hdc /mnt/cdrom iso9660 ro,noauto,user 0 0
[root@qld etc]# ln -s /dev/hdc /dev/cdrom
ln: `/dev/cdrom': File exists
[root@qld etc]# mount /dev/cdrom
mount: can't find /dev/cdrom in /etc/fstab or /etc/mtab

I'm probably doing something really dumb. BUt I can't see it. Anybody got any ideas!

Thanx in advance

aqoliveira 10-15-2003 06:40 AM

howzit

type mount /dev/cdrom /mnt/cdrom this will mount your cd. To unmount type umount /mnt/cdrom

chow

ShrikesHarvest 10-15-2003 06:42 AM

aqoliveira, thanks for replying so quick, unfortunately no joy:

[root@qld etc]# mount /dev/cdrom /mnt/cdrom
mount: special device /dev/cdrom does not exist

waddyareckon

aqoliveira 10-15-2003 06:48 AM

howzit

try this to id the hardware cdrecord -scanbus it should reply what it see it as then try mounting it as that type of device. e.g /dev/sda1

chow

TigerOC 10-15-2003 06:54 AM

You see this line;
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
this means that /dev/hdc (cdrom) is now following scsi emulation and would therefore probably be /dev/scd0 . Go into /var/log/dmesg or syslog and look down the listings and see what the system has called it. It will have a message to the effect that your specific branded cd/dvd has been loaded. You may to go to /etc/fstab and specifically add the info or at least check that there is a line there to this effect.
here's mine as an example;
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hdd1 / ext3 errors=remount-ro 0 1
/dev/hdd5 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
#/dev/cdrom /mnt/cdrom iso9660 noauto,ro,user,exec 0 0
#/dev/hdb /mnt/cdrom iso9660 noauto,ro,user,exec 0 0
/dev/hda1 /mnt/C: vfat defaults,umask=000 0 0
/dev/hda5 /mnt/E: vfat defaults,umask=000 0 0
/dev/scd0 /cdrom auto ro,noauto,user,exec 0 0

ShrikesHarvest 10-15-2003 06:56 AM

aqoliveira,

Getting somewhere probably:

[root@qld root]# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c 1.75 02/10/21 Copyright 1997 J. Schilling').
scsibus0:
0,0,0 0) 'PIONEER ' 'DVD-RW DVR-104 ' '1.40' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
[root@qld mnt]# mount /dev/scsibus0 /mnt/cdrom
mount: special device /dev/scsibus0 does not exist

Does this help?

Thanx in advance

michaelk 10-15-2003 06:57 AM

Your DVD writer is configured for SCSI emulation and it should show up as /dev/scd0. You can also create a link from /dev/scd0 to /dev/cdrom.

aqoliveira 10-15-2003 06:59 AM

Howzit

Follow the last few posts that was mentioned ........:cool:

chow

malcidragon 10-15-2003 06:59 AM

OK, first of all in your boot you will notice hdc=ide-scsi
This means that linux will use hdc as a scsi device, not as an
ide device.
This is so that cd recording will work correctly, (yes there are
ways round this)
First of all try 'mount /mnt/cdrom'
If this doesn't work it means that there is an entry missing
in /etc/fstab

probably 'mount /dev/scd /mnt/cdrom' will work.

/dev/cdrom is a symbolic link to the real device file.
If the above mount worked then just create a symbolic link
'ln -s /dev/scd /dev/cdrom'

You should have a line like this in /etc/fstab...

/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0

If you don't create one, then you should be able to do
u/mount /mnt/cdrom
and be able to see the cd in gnome/kde

ShrikesHarvest 10-15-2003 07:00 AM

Bingo!!! scd0 was the correct device name.

Thankyou TigerOC, michaelk & aqoliveira for taking the time to solve problem, much appreciated.

alMubarmij 02-21-2009 07:05 AM

I have a near of this problem:
http://linuxquestions.org/questions/...-discs-706344/


All times are GMT -5. The time now is 01:11 PM.