LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-15-2003, 06:33 AM   #1
ShrikesHarvest
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
mount /dev/hdc /dev/cdrom doesn't work


Hi,

Am new Linux adventurer. Have installed RedHat 9. Managed to get my USB cable Model working and can now get internet (Yeee haa!!). But I just can't get my DVD working!! Red Hat installed off it so it must be possible to access the thing!

[root@qld mnt]# mount -t iso9660 /dev/hdc /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

*****************
To provide further info
*****************

[root@qld ide]#cat hdc/model
PIONEER DVD-RW DVR-104
[root@qld dev]# ls cdrom
ls: cdrom: No such file or directory
[root@qld mnt]# ls
A C cdrom
[root@qld mnt]# eject /dev/hdc
eject: unable to eject, last error: Invalid argument
[root@qld etc]# cat grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd2,0)
# kernel /vmlinuz-version ro root=/dev/hdd2
# initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=10
splashimage=(hd2,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd2,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img
title Windows
rootnoverify (hd0,0)
chainloader +1
[root@qld etc]# cat fstab
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdd3 swap swap defaults 0 0
/dev/hda1 /mnt/C vfat defaults 0 0
/dev/hdc /mnt/cdrom iso9660 ro,noauto,user 0 0
[root@qld etc]# ln -s /dev/hdc /dev/cdrom
ln: `/dev/cdrom': File exists
[root@qld etc]# mount /dev/cdrom
mount: can't find /dev/cdrom in /etc/fstab or /etc/mtab

I'm probably doing something really dumb. BUt I can't see it. Anybody got any ideas!

Thanx in advance
 
Old 10-15-2003, 06:40 AM   #2
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
howzit

type mount /dev/cdrom /mnt/cdrom this will mount your cd. To unmount type umount /mnt/cdrom

chow
 
Old 10-15-2003, 06:42 AM   #3
ShrikesHarvest
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Original Poster
Rep: Reputation: 0
aqoliveira, thanks for replying so quick, unfortunately no joy:

[root@qld etc]# mount /dev/cdrom /mnt/cdrom
mount: special device /dev/cdrom does not exist

waddyareckon
 
Old 10-15-2003, 06:48 AM   #4
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
howzit

try this to id the hardware cdrecord -scanbus it should reply what it see it as then try mounting it as that type of device. e.g /dev/sda1

chow
 
Old 10-15-2003, 06:54 AM   #5
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
You see this line;
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
this means that /dev/hdc (cdrom) is now following scsi emulation and would therefore probably be /dev/scd0 . Go into /var/log/dmesg or syslog and look down the listings and see what the system has called it. It will have a message to the effect that your specific branded cd/dvd has been loaded. You may to go to /etc/fstab and specifically add the info or at least check that there is a line there to this effect.
here's mine as an example;
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hdd1 / ext3 errors=remount-ro 0 1
/dev/hdd5 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
#/dev/cdrom /mnt/cdrom iso9660 noauto,ro,user,exec 0 0
#/dev/hdb /mnt/cdrom iso9660 noauto,ro,user,exec 0 0
/dev/hda1 /mnt/C: vfat defaults,umask=000 0 0
/dev/hda5 /mnt/E: vfat defaults,umask=000 0 0
/dev/scd0 /cdrom auto ro,noauto,user,exec 0 0
 
Old 10-15-2003, 06:56 AM   #6
ShrikesHarvest
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Original Poster
Rep: Reputation: 0
aqoliveira,

Getting somewhere probably:

[root@qld root]# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c 1.75 02/10/21 Copyright 1997 J. Schilling').
scsibus0:
0,0,0 0) 'PIONEER ' 'DVD-RW DVR-104 ' '1.40' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
[root@qld mnt]# mount /dev/scsibus0 /mnt/cdrom
mount: special device /dev/scsibus0 does not exist

Does this help?

Thanx in advance
 
Old 10-15-2003, 06:57 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,969

Rep: Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752
Your DVD writer is configured for SCSI emulation and it should show up as /dev/scd0. You can also create a link from /dev/scd0 to /dev/cdrom.
 
Old 10-15-2003, 06:59 AM   #8
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
Howzit

Follow the last few posts that was mentioned ........

chow
 
Old 10-15-2003, 06:59 AM   #9
malcidragon
Member
 
Registered: Feb 2002
Location: Leeds UK
Distribution: Fedora Core 3
Posts: 67

Rep: Reputation: 15
OK, first of all in your boot you will notice hdc=ide-scsi
This means that linux will use hdc as a scsi device, not as an
ide device.
This is so that cd recording will work correctly, (yes there are
ways round this)
First of all try 'mount /mnt/cdrom'
If this doesn't work it means that there is an entry missing
in /etc/fstab

probably 'mount /dev/scd /mnt/cdrom' will work.

/dev/cdrom is a symbolic link to the real device file.
If the above mount worked then just create a symbolic link
'ln -s /dev/scd /dev/cdrom'

You should have a line like this in /etc/fstab...

/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0

If you don't create one, then you should be able to do
u/mount /mnt/cdrom
and be able to see the cd in gnome/kde
 
Old 10-15-2003, 07:00 AM   #10
ShrikesHarvest
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Bingo!!! scd0 was the correct device name.

Thankyou TigerOC, michaelk & aqoliveira for taking the time to solve problem, much appreciated.
 
Old 02-21-2009, 07:05 AM   #11
alMubarmij
Member
 
Registered: Dec 2005
Posts: 140
Blog Entries: 1

Rep: Reputation: 16
I have a near of this problem:
http://linuxquestions.org/questions/...-discs-706344/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom! Dmalic Linux - Hardware 13 11-18-2005 07:11 PM
/dev/hdc....CDROM? wombat53 Linux - Hardware 3 06-14-2005 11:02 PM
no /dev/hdc or /dev/cdrom bobr Linux - General 3 02-18-2005 10:30 AM
/dev/cdrom & /dev/hdc missing! Lord_Devi Slackware 4 06-25-2004 09:17 AM
kernel 2.6.3: cdrom isn't running....also not as /dev/hdc ...RH9 pablovschby Linux - General 8 02-25-2004 10:26 AM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration