LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-25-2009, 02:12 PM   #1
foampile
Member
 
Registered: Feb 2009
Posts: 50

Rep: Reputation: 15
mount: Could not find any loop device


i was able to create a Fedora 9 Amazon Web Service EC2 image from scratch. however, when i launched an instance of it and added more crap to it and wanted to rebundle the image, this time from the existing AMI, i got the following error:

mount: Could not find any loop device. Maybe this kernel does not know
about the loop device? (If so, recompile or `modprobe loop'.)
execution failed: "mount -o loop /tmp/image /mnt/img-mnt"
ec2-bundle-vol failed.

i tried 'modprobe loop' but got the following:

FATAL: Could not load /lib/modules/2.6.16-xenU/modules.dep: No such file or directory

any ideas ?

thanks.

P.S.: i also posted this on the AWS EC2 forum but this might be a lower level problem and i usually get quicker responses here. in other words, you guys rock
 
Old 02-25-2009, 04:31 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Run "sudo /sbin/depmod -a". That will create a modules.dep file unless you have something more serious wrong, like not /lib/modules/$(uname -r) directory.
 
Old 02-25-2009, 04:33 PM   #3
foampile
Member
 
Registered: Feb 2009
Posts: 50

Original Poster
Rep: Reputation: 15
thanks but i still get

FATAL: Could not open /lib/modules/2.6.16-xenU/modules.dep.temp for writing: No such file or directory
 
Old 02-25-2009, 07:52 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
What is in /lib/modules/2.6.16-xenU/ ? Is that the kernel release you are running? If not include the kernel release as an argument:
sudo /sbin/depmod -a 2.6.16-xenU

Last edited by jschiwal; 02-25-2009 at 07:59 PM.
 
Old 09-25-2009, 10:28 AM   #5
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Rep: Reputation: 18
Sorry to bring this up again....

but I recently got the same problem on a "build from scratch" ec2 instance with centos

I installed (with yum) kernel-xen-devel.i686 kernel-xen.i686 kernel-headers.i386 all on version 2.6.18-164.el5; but no matter what it still have the error...

then... no matter what kernels are installed; I've found that the kernel running is 2.6.16

Code:
# uname -a
Linux domU-12-31-39-04-05-25 2.6.16-xenU #1 SMP Mon May 28 03:41:49 SAST 2007 i686 i686 i386 GNU/Linux
I restarted the instance ofcourse and it still loads 2.6.16...


I ended up looking for 2.6.16 modules after all....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount loop device ? waelaltaqi Linux - Software 8 12-02-2008 12:15 PM
Trying to mount loop device during boot: permission denied openSauce Linux - Newbie 5 10-06-2008 01:07 PM
How to increase tmp partition - mount loop device grim2 Linux - Server 2 03-10-2008 09:27 AM
can't mount iso 'could not find any loop device' dethree Slackware 1 06-23-2005 02:14 AM
Cannot mount more than 8 iso image files as loop device marsim Debian 4 11-09-2004 05:05 AM


All times are GMT -5. The time now is 04:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration