LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2003, 02:10 PM   #1
Aerlock
LQ Newbie
 
Registered: Oct 2003
Location: Earth
Distribution: Mandrake 9.2
Posts: 29

Rep: Reputation: 15
Mount and User permission issues


As you can guess by the title I have 2 questions.

First I'm having some issues with mounting my floppy and dvd/cdrw combo drive. I am running a fresh install of Mandrake 9.2 I have removed the references to supermount from /etc/fstab due to Konquerer freezing everytime I tried to view the /mnt directory. Now I'm having issues getting the drives to mount. what should I put in my //etc/fstab to make them work? This is what I have in there right now:

none /mnt/cdrom dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy dev=/dev/fd0,fs=ext2:vfat,--,sync,codepage=850,umask= iocharset=iso8859-1 0 0

And now my second question. This came up when I started having fun with mount. I am trying to make my login account able to do almost everything root can. I keep running into things that I can't do even though I've got my permissions and privlidges set as close to root as I can. For example after I removed the supermount options I tried to go and manually mount the cd drive but I got this error:

Could not mount device.
The reported error was:
mount: must be superuser to use mount

What am I doing wrong? TIA

--Aerlock

Last edited by Aerlock; 10-17-2003 at 02:12 PM.
 
Old 10-17-2003, 02:40 PM   #2
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
none /mnt/cdrom dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy dev=/dev/fd0,fs=ext2:vfat,--,sync,codepage=850,umask= iocharset=iso8859-1 0 0
These lines look like they were formatted for use with supermount. Change them to this:
Code:
/dev/cdrom /mnt/cdrom auto         ro,--,iocharset=iso8859-1 0 0
/dev/fd0   /mnt/floppy vfat,ext2   sync,codepage=850,umask=0,iocharset=iso8859-1 0 0

Last edited by aaa; 10-17-2003 at 02:42 PM.
 
Old 10-17-2003, 02:55 PM   #3
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
This is what I have in my /etc/fstab:

/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0

I have never seen the format that your /etc/fstab is in, but I have also never used supermount. The man pages are, of course, your best friend. Try 'man fstab'.

To be able to mount the cdrom as a user, put the option "user" in the cdrom's line in /etc/fstab.

If you are trying to make your regular user account be able to do a lot of the things root can do, you should check out the 'su' command.
 
Old 10-17-2003, 03:01 PM   #4
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Question

Why not use supermount? It works pretty well anyway. I do hate having to close the window to get it to eject though.

Just curious.

 
Old 10-17-2003, 10:24 PM   #5
Aerlock
LQ Newbie
 
Registered: Oct 2003
Location: Earth
Distribution: Mandrake 9.2
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by aaa
These lines look like they were formatted for use with supermount. Change them to this:
Code:
/dev/cdrom /mnt/cdrom auto         ro,--,iocharset=iso8859-1 0 0
/dev/fd0   /mnt/floppy vfat,ext2   sync,codepage=850,umask=0,iocharset=iso8859-1 0 0
aaa:

Yes they were originally set up for supermount, I just went in with a text editor and removed the word supermount from each line because I couldn't get supermount to work to have it disable itself.
Will this change let me mount and unmount as a regular user? Also will this try to automatically mount the cd and floppy on boot-up? if so how do I make it not auto-mount the cd and floppy?

Quote:
Originally posted by hussar
This is what I have in my /etc/fstab:

/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0

I have never seen the format that your /etc/fstab is in, but I have also never used supermount. The man pages are, of course, your best friend. Try 'man fstab'.

To be able to mount the cdrom as a user, put the option "user" in the cdrom's line in /etc/fstab.

If you are trying to make your regular user account be able to do a lot of the things root can do, you should check out the 'su' command.
hussar:

Mandrake 9.2 automatically uses supermount so I unfortunately didn't get the choice of not using it. I did try 'man fstab' but I couldn't find the information on how to set up a dvd/cd-rw combo drive. Will your settings work for a combo drive? Also I noticed you had 'users' in your cd settings line, will this let any user mount and unmount or do I have to use 'user'?
With the 'su' command will that last a whole session or just while I have the terminal instance that I typed it in open. Also I was hoping to set up a power user account that i could do most of my maintenance/install work with without having to logout and log root in every time I want to install a program.


Quote:
Originally posted by dalek
Why not use supermount? It works pretty well anyway. I do hate having to close the window to get it to eject though.

Just curious.

dalek:

I don't want to use supermount because Konquerer has issues with my /mnt directory when I have supermount enabled. It may just be because I am using KDE but right now I'm still too much of a newbie to get GNOME installed.

Thanks for the help guys.
 
Old 10-18-2003, 04:12 AM   #6
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Mine works fine in KDE, I use it mostly, but works in Gnome and in the Ice Desktop. Supermount can be flakey sometimes though. May sometimes be something to do with different hardware issues I guess.

If you don't mind, what does it do wrong? Just curious.

You may want to just uninstall supermount. If it is not there it will be disabled for sure. Not sure how to get rid of it though.

Later

 
Old 10-18-2003, 07:53 AM   #7
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
Aerlock,

What I normally do is login in on my user account, and then if I want to do something that requires root privileges I will enter the command 'su' in the console or an xterm and provide the root password. I will do what I need to do, and when I am finished, I type 'exit' which returns me to my normal permissions. You don't need to login and logout every time. It's pretty handy.

I would not recommend becoming root and then just using the machine. If you make a mistake as root, it is possible to completely disable your system. I learned that the hard way. I was deleting a bunch of files while I had root privileges, and I accidentally deleted my entire /etc directory. All those configuration files gone. Had to reinstall. Ugly.

The user option will allow users to mount the drive. The users option will let users mount the drive, and it will also let a user other than the one that mounted the drive unmount the drive.

For setting up the combo drive, I recommend making a link from /dev/cdrom to /dev/hdc and from /dev/dvd to /dev/hdc. Then when configuring apps that look for either the cdrom/dvd drive you can enter either /dev/cdrom or /dev/dvd. Actually, it would surprise me if those links weren't already there. What do you get when you enter 'ls -l /dev/cdrom' or 'ls -l /dev/dvd'?

Are you trying to play individual files on the dvd, or are you trying to play a pre-recorded commercial dvd?
 
Old 10-18-2003, 07:59 AM   #8
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
Talking

You deleted your /etc directory too huh? That was pretty silly of us wasn't it?

We live, we learn. Thank goodness for the /home directory.

Later

 
Old 10-18-2003, 03:20 PM   #9
Aerlock
LQ Newbie
 
Registered: Oct 2003
Location: Earth
Distribution: Mandrake 9.2
Posts: 29

Original Poster
Rep: Reputation: 15
Ok I think I've got the mount thing down now.

Quote:
Originally posted by dalek
If you don't mind, what does it do wrong? Just curious.
dalek

With supermount enabled every time I try to view the /mnt directory Konquerer, or any other program I happen to be using, freezes.

I'm still having issues with my user permissions though. When I try to use 'su' this is what I get:

[aerlock@localhost etc]$ su
Password:
su: cannot set groups: Operation not permitted

I still wnat to know how I can set up an account to be a "power user" account. Something with enough permissions to install/uninstall programs, change settings in files like fstab, and anything else along those lines. I don't need permissions that will let me delete system files/directories.
 
Old 10-19-2003, 03:21 AM   #10
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
The problem with su might be that it is not setuid root. Enter the command 'ls -l /bin/su' and you should see something like this:

-rws--x--x 1 root bin 32496 Jun 24 01:40 /bin/su

The "s" after the "-rw" indicates that su is setuid to its user, in this case root. This means that when 'su' is used, it has the permissions of its user. If your su does not have the "s" and you see an "x" in that spot instead, then as root enter the command 'chmod u+s /bin/su'. Try to su after that and see if it works for you.

One way to create "power users" is to use su, /etc/suauth and /etc/sudoers. Take look at the man pages for suath and sudoers, and they will show you how to set these files up. Using these files you can control who can su and which password they need to enter when they su. You can also define specific commands they can use.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 12:34 PM
how to remove permission for a user for using mount command vineet7kumar Linux - Newbie 1 09-11-2005 06:55 AM
user permission issues with /dev/ (sound and cdrom) ngan_yine Slackware 3 11-03-2004 06:09 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
permission issues. neuroX Linux - Software 7 02-17-2004 07:40 AM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration