LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2012, 01:19 PM   #1
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Rep: Reputation: Disabled
mount and display a floppy


Hello,
After verifying that the recommended line for /etc/fstab is
correct as stated in another website...something like
/dev/fd0 /media/floppy0 auto rw,..............etc.
and rebooting so that it should have been executed.
And then issuing the command
udisks --mount /dev/fd0
I get this error message explaining the failure:
"could not mount.../dev/fd0 is not a valid block device.

bill@happy1:/sbin$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:07.0 Network controller: RaLink RT2561/RT61 802.11g PCI
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01)
bill@happy1:/sbin$ uname -r
2.6.35-32-generic

Any help would be appreciated.
 
Old 03-15-2012, 01:41 PM   #2
evilputty
LQ Newbie
 
Registered: Mar 2012
Posts: 18

Rep: Reputation: Disabled
Try 'dmesg | grep -i floppy'

post output here

also what type was the floppy formatted in?
 
Old 03-15-2012, 02:01 PM   #3
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
bill@happy1:~$ dmesg | grep -i floppy
[ 1.411894] Floppy drive(s): fd0 is 1.44M

The floppy was created as a Windows bootable, so my guess is vfat
 
Old 03-15-2012, 02:05 PM   #4
evilputty
LQ Newbie
 
Registered: Mar 2012
Posts: 18

Rep: Reputation: Disabled
try this with the disk in

mount -t vfat /dev/fd0 /mnt/floppy0
 
Old 03-15-2012, 02:27 PM   #5
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
I put the Windows bootable floppy in the drive, then:

bill@happy1:/mnt$ sudo mount -t vfat /dev/fd0 /mnt/floppy0
mount: /dev/fd0 is not a valid block device
 
Old 03-15-2012, 02:31 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,391

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
What distribution/version are you running?
The floppy module may not be loaded.

As root try:
modprobe floppy
 
Old 03-15-2012, 02:56 PM   #7
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
bill@happy1:/mnt$ sudo modprobe floppy
[sudo] password for bill:
bill@happy1:/mnt$
....there was no output from this command.....

I am running Ubuntu 10.10 with kernel 2.6.35-32-generic
 
Old 03-15-2012, 02:59 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,391

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
No output is a good thing.
Try to mount your floppy
 
Old 03-15-2012, 03:00 PM   #9
evilputty
LQ Newbie
 
Registered: Mar 2012
Posts: 18

Rep: Reputation: Disabled
thats normal now try

sudo mount -t vfat /dev/fd0 /mnt/floppy0

might want to add it to your /etc/modules list just enter floppy

Last edited by evilputty; 03-15-2012 at 03:02 PM.
 
Old 03-15-2012, 03:17 PM   #10
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
bill@happy1:/mnt$ sudo mount -t vfat /dev/fd0 /mnt/floppy0
mount: block device /dev/fd0 is write-protected, mounting read-only

Added "floppy" (sans quotes) to /etc/modules

However, directory /mnt/floppy0 is still empty.
 
Old 03-15-2012, 03:28 PM   #11
evilputty
LQ Newbie
 
Registered: Mar 2012
Posts: 18

Rep: Reputation: Disabled
perhaps try mount -t auto /dev/fd0 /mnt/floppy0 after unmounting

also are you positive there is contents within the disk?

Last edited by evilputty; 03-15-2012 at 03:31 PM.
 
Old 03-15-2012, 03:28 PM   #12
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,391

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
It appears the floppy is mounted.
Did you write protect the disk on purpose?
What is supposed to be on the disk?
How was it created?
 
Old 03-15-2012, 03:47 PM   #13
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
I recently read the disk using Windows and it has many files, so I'm
pretty sure of the floppy's integrity.

bill@happy1:/mnt/floppy0$ umount /dev/fd0
umount: /dev/fd0 is not mounted (according to mtab)
bill@happy1:/mnt/floppy0$ sudo mount -t auto /dev/fd0 /mnt/floppy0
[sudo] password for bill:
mount: block device /dev/fd0 is write-protected, mounting read-only
bill@happy1:/mnt/floppy0$ dir
----directory has no contents-----
----then I shifted the write-protect tab on the floppy to off-----
bill@happy1:/mnt/floppy0$ sudo mount -t auto /dev/fd0 /mnt/floppy0
mount: /dev/fd0 is not a valid block device

Sacre Bleu...did it mount or did it not ?? I dunno...
 
Old 03-15-2012, 03:52 PM   #14
Bill Burkett
LQ Newbie
 
Registered: Mar 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
By using "Windows" I mean another operating system on this same computer,
so it's using the same hardware now, only under Ubuntu 10.10
 
Old 03-15-2012, 03:57 PM   #15
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,391

Rep: Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652Reputation: 1652
You can not mount or unmount a file system if the current working directory is the mount point in this case /mnt/floppy0). Move up a directory to /mnt (FYI the short cut is cd ..) and try mounting it again. The output of the mount command without any options will display a list of all currently mounted file systems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Floppy drive doesn't display files schachwizard Ubuntu 6 09-03-2010 02:15 PM
[SOLVED] can't mount floppy hearthstone Linux - Newbie 6 03-05-2010 09:53 PM
Cannot mount my Floppy drive while creating driver floppy gobs04 Linux - Newbie 2 09-23-2009 07:43 PM
Why can I not mount floppy? mpajoh Fedora 5 01-08-2007 12:25 PM
MINIX mount: Can't mount /dev/fd0 on floppy: Invalid argument jcaser1948 Other *NIX 2 10-04-2006 11:38 AM


All times are GMT -5. The time now is 08:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration