LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-11-2002, 10:30 PM   #1
Slinger
LQ Newbie
 
Registered: Nov 2002
Posts: 22

Rep: Reputation: 15
Question Mosfet Liquid compile Not going well - error


Fairly new, but can anyone point me in a direction of what might be wrong based on the below msg? Got when I did the make install.

In file included from liquid.cpp:4:
embeddata.h: In function `QImage liquid_findImage(const QString&)':
embeddata.h:655: `qUncompress' undeclared (first use this function)
embeddata.h:655: (Each undeclared identifier is reported only once for each
function it appears in.)
liquid.cpp: In member function `virtual void
LiquidStyle::drawControl(QStyle::ControlElement, QPainter*, const QWidget*,
const QRect&, const QColorGroup&, unsigned int, const QStyleOption&) const':
liquid.cpp:1151: no matching function for call to `QPushButton::
backgroundOffset() const'
liquid.cpp: In member function `virtual void
LiquidStyle::drawComplexControl(QStyle::ComplexControl, QPainter*, const
QWidget*, const QRect&, const QColorGroup&, unsigned int, unsigned int,
unsigned int, const QStyleOption&) const':
liquid.cpp:1527: no matching function for call to `QWidget::backgroundOffset()
const'
make[1]: *** [liquid.lo] Error 1
make[1]: Leaving directory `/root/downloads/mosfet-liquid0.9.6pre1/widget-engine'
make: *** [install-recursive] Error 1
 
Old 11-14-2002, 05:54 PM   #2
Demosthenes
LQ Newbie
 
Registered: Nov 2002
Location: Random
Posts: 1

Rep: Reputation: 0
Taken from http://www.mosfet.org/liquid.html

Version 0.9.6pre1 requires KDE3.1beta2
Version 0.9.5 requires KDE3.0.x

My guess is you are installing 0.9.6pre1 on an "older" version of KDE. I am running the "old" KDE3.0.x and tried making the new version of liquid and encountered the error you got. So, get the older version or update KDE.

Respectfully,

Demosthenes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compile error: #error unknown processor family kmack2001 Linux - Newbie 0 02-14-2004 12:52 PM
RedHat 8.0 with Kde 3.1 and Mosfet rmartine Linux - Software 0 05-30-2003 02:55 AM
mosfet liquid on Mandrake 9.1 asianboi2k Linux - Software 2 05-04-2003 09:46 AM
mosfet liquid installation exigent Linux - Software 4 11-11-2002 04:17 AM
hi performance liquid and mosfet? vance Linux - Software 0 09-10-2002 12:01 AM


All times are GMT -5. The time now is 08:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration