LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2011, 10:09 AM   #1
Aidan_H
LQ Newbie
 
Registered: Aug 2011
Posts: 11

Rep: Reputation: Disabled
Monitor Resolution


Hi I am new to Linux but have many years experience on Windows. I have a full HD monitor 1920x1080 which just works automatically on Windows 7 however under Ubuntu 11.04 the only options I get are 1024x768, 800x600, 848x480 and 640x480. It has defaulted at the highest 1024x768 but this is distorted and the presentation is too big leading to insuffient data on a single display. My graphics card is Nvidia NV28 GeForce T1 4200 AGPx8 rev A1. I would very much like to get a higher resolution in the proper aspect ratio. Any help will be greatly appreciated.Regards Aidan_H
 
Old 08-23-2011, 07:27 PM   #2
Arelatensis
Member
 
Registered: Oct 2010
Location: Russian Federation, Udmurtia
Distribution: CentOS, Aptosid, Mageia, OpenMandriva, Ubuntu
Posts: 48

Rep: Reputation: 2
You need install proprietary (but free of charge) driver "nv" or its clone "nouveau" for graphic card. Brows ubuntu repositories. Use synaptic or another PackageKit. Ubuntu isn't a disto, that well equipped with drivers and firmware by default. The packet must be named nvidea173* or nvidia 195*. You can also download official driver from http://www.nvidia/Download/index.aspx? for you model of graphic card. But installation in the latter case must be done manually.

P. S. May be it need be done some customization in tuning of the graphic adapter and monitor.
 
Old 08-23-2011, 07:48 PM   #3
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
Getting the derivers might help, its worth a try. If its not the drivers, then its EDID.

Quote:
Originally Posted by Arelatensis View Post
You need install proprietary (but free of charge) driver "nv" or its clone "nouveau" for graphic card.
No. Neither the .nv driver, or nouveau driver are proprietary.

Quote:
Originally Posted by Arelatensis View Post
The packet must be named nvidea173* or nvidia 195*. .
No. nVidia-current did have the 195.XX drivers with earlier versions of ubuntu, but with 11.04 nvidia-current is 270.41.06-

http://packages.ubuntu.com/natty/nvidia-current

nVidia-current, or the 173.XX drivers will NOT work with the Gf Ti 4200. That card needs the 96.XX drivers.

@ Aidan_H- if only the 96.XX drivers that ubuntu packaged worked with 11.04, things would be eaiser. But as far as I know, the packaged version with 11.04 will not work, you need to either add a PPA or manually install the the drivers. If you get the drivers manually, then make sure you get version 96.43.20 or higher.

Maunal install instructions-
https://help.ubuntu.com/community/NvidiaManual
 
Old 08-24-2011, 04:39 AM   #4
Aidan_H
LQ Newbie
 
Registered: Aug 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Aidan_H

Hi Thank you for your reply, but it sounds too involved for me at this time as I only started to use Linux in May this year. I guess I am stuck with the current situation until it becomes available as a standard downloadable from Ubuntu software or from some other easier method other than the manual system which I looked at.
Regards Aidan_H
 
Old 08-24-2011, 06:39 AM   #5
Arelatensis
Member
 
Registered: Oct 2010
Location: Russian Federation, Udmurtia
Distribution: CentOS, Aptosid, Mageia, OpenMandriva, Ubuntu
Posts: 48

Rep: Reputation: 2
Quote:
Originally Posted by Aidan_H View Post
I only started to use Linux in May this year. I guess I am stuck with the current situation until it becomes available as a standard downloadable from Ubuntu software or from some other easier method other than the manual system which I looked at.
Regards Aidan_H
May be you try another distro, with better hardware support. I also used ubuntu for a year in pure iron with the similiar problems, but after understoos, that it is not mine. Now I vote for Open Suse Mandriva? or pure Debian.
And let's me a question. Where are you from? Some Local Communities make respines of Ubuntu. So Russian respine, named Runtu is distinguished by better support of hardware and media codecs out of the box, than original Ubuntu.
 
Old 08-25-2011, 05:55 AM   #6
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
There is a way to get the EDID info, but its not much easier than doing a manual nVidia install (which I dont think is that hard, the ubuntu site makes it seem more complex than it is)

Probably what would be easiest is to make a xorg.conf and then put 1920x1080 into the xorg.conf file-

http://ubuntuforums.org/showthread.php?t=1755586

http://www.grenage.com/xorg.html
 
Old 08-29-2011, 07:53 AM   #7
Aidan_H
LQ Newbie
 
Registered: Aug 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi Thank you for your efforts, however I still didn't get it to work as I don't understand most of the text and commands that are perhaps normal to Linux guys. What I did try was to connect my monitor direct to the Linux PC and bingo it automatically came up in 1920x1024. I have a KLKvmUSB2 by NEWLINK for switching between Windows 7 and Ubuntu Linux and I discovered that the Monitor type was only passed through one of the VGA ports making Windows work fine and Linux with the resolution problem. When I reversed the connections Linux work fine @ 1920x1024 and windows didn't work at all so I am back to the same problem. QUESTION does anyone know of a VGA usb switch that passes the Monitor type through ports so I might have both my systems working at the 1920x1024 resolution.
Regards Aidan_H
 
Old 08-30-2011, 01:42 AM   #8
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
1920x1080,not 1920x1024.

KVMs have been known to cause that problem. The easiest solution I know is to create an xorg.conf file. Just hook up the monitor (without the KVM), then run this command-

sudo Xorg -configure

Once you have saved yoru resolution, it should work even going through the KVM.
 
Old 09-19-2011, 09:43 AM   #9
Aidan_H
LQ Newbie
 
Registered: Aug 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hello I have now upgraded to Ubuntu 11.10 with the hope of getting my screen resolution sorted but the Xorg command didn't do the trick as I got the sane response as with 11.04. as below;-


aidan@aidan-Linux:~$ Xorg -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the The X.Org Foundation support
at http://wiki.x.org
The instruction to remove /tmp/.X0-lock is something I don't know how to do as I can't find any remove command.
Any help would be greatly appreciated.
Regards Aidan_H
 
Old 09-19-2011, 04:33 PM   #10
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
Hmm....seems you have shut down xserver for Xorg -configure to work.

Try hitting Ctrl+Alt+F1 to drop back to terminal only, then run Xorg -configure

After that, either 'startx' to restart xserver or reboot.
 
Old 09-19-2011, 04:52 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Changing to a VT with Ctrl+Alt*F1 will not stop the X-server, you have to actually really stop it. Since Ubuntu uses upstart it should be this commands to make that working
Code:
sudo service gdm stop
sudo Xorg -configure
sudo cp xorg.conf.new /etc/X11/xorg.conf
sudo service gdm start
 
Old 09-19-2011, 05:07 PM   #12
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
Opps.

Thanks for that TobiSGD, I should remember that at 6:30 AM after a sleepness night I'm technically incompetent.

Last edited by cascade9; 09-20-2011 at 07:12 AM. Reason: typo
 
Old 09-20-2011, 07:08 AM   #13
Aidan_H
LQ Newbie
 
Registered: Aug 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Thanks for your efforts, however I seem to be still out of luck as I get unrecognised service to gdm.
see terminal text below.


aidan@aidan-Linux:~$ sudo service gdm stop
[sudo] password for aidan:
gdm: unrecognized service
aidan@aidan-Linux:~$ sudo Xorg -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.

ddxSigGiveUp: Closing log
aidan@aidan-Linux:~$
Regards AidanH
 
Old 09-20-2011, 10:56 AM   #14
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Sorry, I forgot that 11.10 has changed to LighDM, so try it again, but use lightdm instead of gdm in those commands.
 
Old 09-20-2011, 11:42 AM   #15
Aidan_H
LQ Newbie
 
Registered: Aug 2011
Posts: 11

Original Poster
Rep: Reputation: Disabled
Thank you for the revised input, however I think I am going down hill and gathering speed as when I did the recommended commands the system crashed giving the following messages:-

* Starting kernel Oops catching service kernel Oops
* Starting CPU interrupts balancing daemon
* Speech-dispatcher disabled ; edit/etc/default/speech-dispatcher
Checking for running unattended upgrades:
* Stopping anac(h)ronistics cron
* Stopping kernel messages
* Starting CUPS printing spooler/service
* Starting bluetooth
* PulseAudio configured for per user sessions
saned disabled; edit/stc/default/saned
*starting mount network filesystem
* Stopping mount network filesystem
* checking battery system state

The only way way I could get the system back was to do ctr alt del which restarted the system

Regards Aidan_H
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
monitor resolution samsim Linux - General 4 05-07-2005 05:24 PM
Monitor resolution magicmaster Linux - Newbie 6 12-23-2004 04:50 PM
monitor resolution nobu Slackware 2 04-04-2004 08:11 AM
Monitor problems -- changing resolution back w/o monitor Jiawen Linux - Hardware 5 03-17-2004 11:06 PM
Monitor resolution too high for my monitor mjames_84 Linux - General 7 03-09-2004 11:51 PM


All times are GMT -5. The time now is 09:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration