LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-23-2006, 07:03 AM   #1
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Rep: Reputation: 0
Monitor res set too high to see fedora to turn it back down again. Please help me


I installed me first ever linux yesterday (FC5) on my old PC. I thought it was about time I tried it. It didnt recognise my monitor and decided to set it at a max res of 800x600. under win98 it was running at 1024x768 withought trouble so I went in to the display setup and changed the drivers fedora was using. now when I boot the screen is doing that unreadable fast moving stretchy thing monitors do when they are running at a higher res than they support. As I know absolutely nothing about linux I dont know how to correct this. I believe I should be able to log into some kind of command prompt and change the drivers back by hand but I have no idea how to get to such a prompt or what to type when I get there. Could someone please help me?
 
Old 03-23-2006, 07:14 AM   #2
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
hit Ctrl+Alt+F1
Your should then have the command prompt
Here, type "vi /etc/X11/xorg.conf"
browse the file with the arrows
You should be able to delete the line :
Modes "800x600"
put the cursor on the line and type dd to delete
after that type :wq to save the changes.
Then Ctrl+Alt+F7 and Ctrl+Alt+BackSpace to restart the graphical interface.

I believe your problem has something to do with scan rate.

Last edited by Agrouf; 03-23-2006 at 07:16 AM.
 
Old 03-23-2006, 07:32 AM   #3
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
I've got to command prompt and typed in that line. I get a load of blue ~ down the left edge of the screen and the bottom line is "/etc/x11/xorg.conf" [New File]

The arrow keys dont do anything. No other text appears on the screen. I assume I have done something wrong?
 
Old 03-23-2006, 08:14 AM   #4
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
Quote:
Originally Posted by lawnor
I've got to command prompt and typed in that line. I get a load of blue ~ down the left edge of the screen and the bottom line is "/etc/x11/xorg.conf" [New File]

The arrow keys dont do anything. No other text appears on the screen. I assume I have done something wrong?
It's case sensitive.
vi /etc/X11/xorg.conf

:q! to exit the file you are currently editing without saving.

BTW I forgot to point out that you should log as root in order to modify this file.
type su in order to log as root.

Last edited by Agrouf; 03-23-2006 at 08:20 AM.
 
Old 03-23-2006, 08:45 AM   #5
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
it had two lines reading Modes "800x600" "640x480". I deleted them both and saved it. I now have 4 squished up overlapping login screens, which is an improvement. I think. Hmmm. I seem to be able to enter my user and pass...

... Right, I got in and got to desktop (4 fuzzy overlapping identical desktops) and figured out how to get to the display tab. I even managed to change the monitor. I thought generic 640x480 was top of the list. Guess I was wrong. It was a compaq p910. I installed it thinking it'd get me som,ething generic and useful and now I'm back where I started. Fuzzy wibbly unreadable screen, only this time deleting the modes line does not get me something I can just about see.

is there any way to select which monitor driver to use from the command prompt?
 
Old 03-23-2006, 09:01 AM   #6
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
You can select it in the xorg.conf file in the Section "screen".
This section should look like that :


Section "Screen"
Identifier "Default Screen"
Device "bla bla bla"
Monitor "Generic Monitor"
DefaultDepth 24
...
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Put the right monitor there.
Specifically look for HorizSync and VertRefresh. Put the correct values according to your monitors specs (in your monitor documentation).

Last edited by Agrouf; 03-23-2006 at 09:05 AM.
 
Old 03-23-2006, 09:28 AM   #7
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
How do I do that?
 
Old 03-23-2006, 09:53 AM   #8
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
1/ look for those lines (in Section "Monitor") :
HorizSync 30-96
VertRefresh 50-160
(or something similar)
(hint : type /Horiz in order to find all occurences of Horiz and then use n to go to the next occurence and N for the previous one)

2/ put the cursor on the numbers and use x to delete

3/ type i (for insert) and then enter the correct numbers

4/ press the Esc key of the keyboard

5/ same for Generic monitor

6/ :wq

Note : your problem could as well be because of the DefaultDepth. Try setting to 16 if you still have problems.

Last edited by Agrouf; 03-23-2006 at 10:00 AM.
 
Old 03-23-2006, 10:20 AM   #9
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you sooo much!
I had actually found the vi commands before you got back to me and was tinkering when you responded. I googled for the horizsync of my monitor and got fed back to another thread on these forums where someone had all the data I needed already layed out in xorg form! I now not only have my computer back but in 1024x768 which is what I wanted in the first place. Now I just need to up the colout depth from 256. Hope that goes well.....
 
Old 03-23-2006, 10:50 AM   #10
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
One final quick question: How do I make fedora remember to boot into 60Hz video mode? Anything else makes it go back into fuzzy-o-vision.
Hmm. It seems to remember it inside fedora, but not at the login screen.

Last edited by lawnor; 03-23-2006 at 10:51 AM.
 
Old 03-23-2006, 01:02 PM   #11
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
:S that's strange.
Is it kde or gnome login screen?
 
Old 03-23-2006, 02:39 PM   #12
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
I didn't pick either but I think I'm using gnome. Theres an "about Gnome" option in one of the menus inside linux so I assume Gnome is running.
 
Old 03-23-2006, 03:22 PM   #13
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
OK try this :
In xorg.conf, you must have a line with the resolution Modes.
eg :
Modes "640x480" "800x600" "1024x768"
I believe gdm takes the last one, so you should add 640x480 at the end and test :
Modes "640x480" "800x600" "1024x768" "640x480"

And please tell me if it changes something.
 
Old 03-24-2006, 09:50 AM   #14
lawnor
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
I already have them going from highest to lowest so 640x480 is already the last on the line.
 
Old 03-27-2006, 03:21 AM   #15
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
Maybe try putting them in the reverse order then, so 1024x768 is the last. Since your desktop is fine at this resolution, the gdm should be fine as well?
Sorry this is all I have to suggest, I hope a gdm expert will help you more on this that I can.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Res Tux Pougan Linux - General 1 08-17-2005 09:55 PM
How can I set high monitor refresh rate in Mandrake? Dimm0 Linux - Hardware 0 11-03-2004 02:08 PM
Set the wrong resolution for my monitor and need to get back to old settings in RH9 gbaiocchi Linux - Newbie 2 09-30-2004 08:44 PM
was fedora release date set back ? qwijibow Linux - General 4 05-19-2004 01:18 AM
high res console FirebirdV0273 Linux - Software 2 12-21-2003 04:35 PM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration